summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2008-12-05 22:02:25 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2008-12-05 22:02:25 +0000
commit7b4f05946c0f28ddde00636c59a34fd82bb2a94b (patch)
tree188a3e6eda396687338322b6a3d9b10f9453785a /media-libs/gst-plugins-ugly
parentVersion bump. (diff)
downloadgentoo-2-7b4f05946c0f28ddde00636c59a34fd82bb2a94b.tar.gz
gentoo-2-7b4f05946c0f28ddde00636c59a34fd82bb2a94b.tar.bz2
gentoo-2-7b4f05946c0f28ddde00636c59a34fd82bb2a94b.zip
Version bump.
(Portage version: 2.1.6_rc2/cvs/Linux 2.6.27.7 i686)
Diffstat (limited to 'media-libs/gst-plugins-ugly')
-rw-r--r--media-libs/gst-plugins-ugly/ChangeLog7
-rw-r--r--media-libs/gst-plugins-ugly/gst-plugins-ugly-0.10.10.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/media-libs/gst-plugins-ugly/ChangeLog b/media-libs/gst-plugins-ugly/ChangeLog
index 1484ac626616..1a13a31b8a1b 100644
--- a/media-libs/gst-plugins-ugly/ChangeLog
+++ b/media-libs/gst-plugins-ugly/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/gst-plugins-ugly
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-ugly/ChangeLog,v 1.46 2008/09/23 21:39:46 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-ugly/ChangeLog,v 1.47 2008/12/05 22:02:25 ssuominen Exp $
+
+*gst-plugins-ugly-0.10.10 (05 Dec 2008)
+
+ 05 Dec 2008; <ssuominen@gentoo.org> +gst-plugins-ugly-0.10.10.ebuild:
+ Version bump.
23 Sep 2008; Jeroen Roovers <jer@gentoo.org>
gst-plugins-ugly-0.10.8.ebuild:
diff --git a/media-libs/gst-plugins-ugly/gst-plugins-ugly-0.10.10.ebuild b/media-libs/gst-plugins-ugly/gst-plugins-ugly-0.10.10.ebuild
new file mode 100644
index 000000000000..da351b670acb
--- /dev/null
+++ b/media-libs/gst-plugins-ugly/gst-plugins-ugly-0.10.10.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-ugly/gst-plugins-ugly-0.10.10.ebuild,v 1.1 2008/12/05 22:02:25 ssuominen Exp $
+
+# order is important, gnome2 after gst-plugins
+inherit gst-plugins-ugly gst-plugins10 gnome2 eutils flag-o-matic libtool
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="http://gstreamer.sourceforge.net"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=media-libs/gst-plugins-base-0.10.21
+ >=media-libs/gstreamer-0.10.21
+ >=dev-libs/liboil-0.3.8
+ >=dev-libs/glib-2.12"
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.11.5
+ dev-util/pkgconfig
+ !<media-libs/gst-plugins-bad-0.10.6"
+
+GST_PLUGINS_BUILD=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ elibtoolize
+}
+
+src_compile() {
+ # gst doesnt handle optimisations well
+ strip-flags
+ replace-flags "-O3" "-O2"
+ filter-flags "-fprefetch-loop-arrays" # see bug 22249
+
+ gst-plugins-ugly_src_configure
+
+ emake || die "emake failed."
+}
+
+# override eclass
+src_install() {
+ gnome2_src_install
+}
+
+DOCS="AUTHORS README RELEASE"
+
+pkg_postinst () {
+ gnome2_pkg_postinst
+
+ elog "The Gstreamer plugins setup has changed quite a bit on Gentoo,"
+ elog "applications now should provide the basic plugins needed."
+ elog ""
+ elog "The new seperate plugins are all named 'gst-plugins-<plugin>'."
+ elog "To get a listing of currently available plugins execute 'emerge -s gst-plugins-'."
+ elog "In most cases it shouldn't be needed though to emerge extra plugins."
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+}