summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-05-20 01:51:41 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-05-20 01:51:41 +0000
commita4baf64733630ee5569b16e9b481d7eb79ce9055 (patch)
treec07efa09f03a8ef1857b249fd25b2e3aaa0c5a70 /media-libs/hamlib
parentRewritten ebuild, thanks a lot to Stefan Salewski (bug #266358). (diff)
downloadgentoo-2-a4baf64733630ee5569b16e9b481d7eb79ce9055.tar.gz
gentoo-2-a4baf64733630ee5569b16e9b481d7eb79ce9055.tar.bz2
gentoo-2-a4baf64733630ee5569b16e9b481d7eb79ce9055.zip
Version bump (1.2.9) and fix for bug 270039
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/hamlib')
-rw-r--r--media-libs/hamlib/ChangeLog8
-rw-r--r--media-libs/hamlib/hamlib-1.2.8-r1.ebuild4
-rw-r--r--media-libs/hamlib/hamlib-1.2.9.ebuild74
3 files changed, 83 insertions, 3 deletions
diff --git a/media-libs/hamlib/ChangeLog b/media-libs/hamlib/ChangeLog
index afca6f8f748d..a52c2bcd9761 100644
--- a/media-libs/hamlib/ChangeLog
+++ b/media-libs/hamlib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/hamlib
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/hamlib/ChangeLog,v 1.33 2009/02/15 13:49:37 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/hamlib/ChangeLog,v 1.34 2009/05/20 01:51:41 darkside Exp $
+
+*hamlib-1.2.9 (20 May 2009)
+
+ 20 May 2009; Jeremy Olexa <darkside@gentoo.org> hamlib-1.2.8-r1.ebuild,
+ +hamlib-1.2.9.ebuild:
+ Version bump (1.2.9) and fix for bug 270039
15 Feb 2009; Brent Baude <ranger@gentoo.org> hamlib-1.2.8-r1.ebuild:
stable ppc, bug 257055
diff --git a/media-libs/hamlib/hamlib-1.2.8-r1.ebuild b/media-libs/hamlib/hamlib-1.2.8-r1.ebuild
index 8fd5dc15a4b1..cf85ce2f6f48 100644
--- a/media-libs/hamlib/hamlib-1.2.8-r1.ebuild
+++ b/media-libs/hamlib/hamlib-1.2.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/hamlib/hamlib-1.2.8-r1.ebuild,v 1.5 2009/02/15 13:49:37 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/hamlib/hamlib-1.2.8-r1.ebuild,v 1.6 2009/05/20 01:51:41 darkside Exp $
inherit autotools eutils libtool multilib
@@ -17,7 +17,7 @@ RESTRICT="test"
RDEPEND="virtual/libc
>=sys-devel/libtool-1.5
- dev-libs/libusb
+ =virtual/libusb-0*
python? ( dev-lang/python
dev-lang/tcl )
tcl? ( dev-lang/tcl )"
diff --git a/media-libs/hamlib/hamlib-1.2.9.ebuild b/media-libs/hamlib/hamlib-1.2.9.ebuild
new file mode 100644
index 000000000000..090d6f92a84c
--- /dev/null
+++ b/media-libs/hamlib/hamlib-1.2.9.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/hamlib/hamlib-1.2.9.ebuild,v 1.1 2009/05/20 01:51:41 darkside Exp $
+
+inherit autotools eutils multilib
+
+DESCRIPTION="Ham radio backend rig control libraries"
+HOMEPAGE="http://hamlib.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2 GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="doc python tcl"
+
+RESTRICT="test"
+
+RDEPEND="virtual/libc
+ =virtual/libusb-0*
+ python? ( dev-lang/python
+ dev-lang/tcl )
+ tcl? ( dev-lang/tcl )"
+
+DEPEND=" ${RDEPEND}
+ dev-util/pkgconfig
+ dev-lang/swig
+ dev-libs/libxml2
+ doc? ( app-doc/doxygen )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-pkgconfig-fix.diff \
+ "${FILESDIR}"/${PN}-ltdl.diff
+
+ # remove bundled libltdl copy
+ rm -rf libltdl
+
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ --libdir=/usr/$(get_libdir)/hamlib \
+ --disable-static \
+ --with-rpc-backends \
+ --without-perl-binding \
+ $(use_with python python-binding) \
+ $(use_with tcl tcl-binding)
+
+ emake || die "emake failed"
+
+ if use doc ; then
+ cd doc && make doc || die "make doc failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS PLAN README README.betatester \
+ README.developer LICENSE NEWS TODO
+
+ if use doc; then
+ dohtml doc/html/*
+ fi
+
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins hamlib.pc
+
+ echo "LDPATH=/usr/$(get_libdir)/hamlib" > "${T}"/73hamlib
+ doenvd "${T}"/73hamlib
+}