summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2014-06-23 06:08:20 +0000
committerMichael Palimaka <kensington@gentoo.org>2014-06-23 06:08:20 +0000
commitbac37da1c8fbd1a03a7d5920450e5e6e7c51561b (patch)
treed3edb71153c151125195b706fef39f85b3e3e947 /media-libs/herqq
parentVersion bump. (diff)
downloadgentoo-2-bac37da1c8fbd1a03a7d5920450e5e6e7c51561b.tar.gz
gentoo-2-bac37da1c8fbd1a03a7d5920450e5e6e7c51561b.tar.bz2
gentoo-2-bac37da1c8fbd1a03a7d5920450e5e6e7c51561b.zip
Bump EAPI. Correct dependencies. Disable building of test application. Fix unconditional API documentation installation.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x06B1F38DCA45A1EC!)
Diffstat (limited to 'media-libs/herqq')
-rw-r--r--media-libs/herqq/ChangeLog8
-rw-r--r--media-libs/herqq/herqq-1.0.0-r2.ebuild45
2 files changed, 52 insertions, 1 deletions
diff --git a/media-libs/herqq/ChangeLog b/media-libs/herqq/ChangeLog
index 2f4621488bf2..9f5ec6475719 100644
--- a/media-libs/herqq/ChangeLog
+++ b/media-libs/herqq/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/herqq
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/herqq/ChangeLog,v 1.13 2014/01/02 18:46:17 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/herqq/ChangeLog,v 1.14 2014/06/23 06:08:20 kensington Exp $
+
+*herqq-1.0.0-r2 (23 Jun 2014)
+
+ 23 Jun 2014; Michael Palimaka <kensington@gentoo.org> +herqq-1.0.0-r2.ebuild:
+ Bump EAPI. Correct dependencies. Disable building of test application. Fix
+ unconditional API documentation installation.
02 Jan 2014; Sergey Popov <pinkbyte@gentoo.org> herqq-1.0.0-r1.ebuild:
Add blocker for media-libs/hupnp-ng, which is fork of this library
diff --git a/media-libs/herqq/herqq-1.0.0-r2.ebuild b/media-libs/herqq/herqq-1.0.0-r2.ebuild
new file mode 100644
index 000000000000..93e86707d3c4
--- /dev/null
+++ b/media-libs/herqq/herqq-1.0.0-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/herqq/herqq-1.0.0-r2.ebuild,v 1.1 2014/06/23 06:08:20 kensington Exp $
+
+EAPI=5
+
+inherit multilib qt4-r2
+
+DESCRIPTION="A software library for building UPnP devices"
+HOMEPAGE="http://www.herqq.org"
+SRC_URI="mirror://sourceforge/hupnp/${P}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+# no release of QtSolutions using bundled libQtSolutions_SOAP
+RDEPEND="
+ dev-qt/qtcore:4
+ !media-libs/hupnp-ng
+"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+"
+
+DOCS=( hupnp/ChangeLog )
+
+src_prepare() {
+ # fix the .pro file for multilib issues
+ sed \
+ -e "s:PREFIX/lib:PREFIX/$(get_libdir):" \
+ -i "${S}/hupnp/src.pro" \
+ -i "${S}/hupnp/lib/qtsoap-2.7-opensource/buildlib/buildlib.pro" || die
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ eqmake4 PREFIX="${EPREFIX}/usr/" CONFIG+=DISABLE_TESTAPP
+}
+
+src_install() {
+ qt4-r2_src_install
+ use doc && dohtml -r hupnp/docs/html/
+}