summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-05 08:06:51 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-05 08:06:51 +0000
commit0e1f7158f7a1b1a03945ef035f6af18129e7bb4b (patch)
tree7a733138fa8d85e88957c1e5e295c363ab2bbe8f /media-libs/id3lib
parentSet the gateway in the default route, just as ppp-2.4.3 used to set (the defa... (diff)
downloadgentoo-2-0e1f7158f7a1b1a03945ef035f6af18129e7bb4b.tar.gz
gentoo-2-0e1f7158f7a1b1a03945ef035f6af18129e7bb4b.tar.bz2
gentoo-2-0e1f7158f7a1b1a03945ef035f6af18129e7bb4b.zip
Add patch to fix unicode16 writing. Thanks for the users in bug #130922.
(Portage version: 2.1.2_pre2-r3)
Diffstat (limited to 'media-libs/id3lib')
-rw-r--r--media-libs/id3lib/ChangeLog8
-rw-r--r--media-libs/id3lib/files/digest-id3lib-3.8.3-r53
-rw-r--r--media-libs/id3lib/files/id3lib-3.8.3-unicode16.patch39
-rw-r--r--media-libs/id3lib/id3lib-3.8.3-r5.ebuild64
4 files changed, 113 insertions, 1 deletions
diff --git a/media-libs/id3lib/ChangeLog b/media-libs/id3lib/ChangeLog
index 20dad83bf559..e810e94464f7 100644
--- a/media-libs/id3lib/ChangeLog
+++ b/media-libs/id3lib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/id3lib
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/id3lib/ChangeLog,v 1.45 2006/09/30 08:20:08 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/id3lib/ChangeLog,v 1.46 2006/10/05 08:06:51 flameeyes Exp $
+
+*id3lib-3.8.3-r5 (05 Oct 2006)
+
+ 05 Oct 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/id3lib-3.8.3-unicode16.patch, +id3lib-3.8.3-r5.ebuild:
+ Add patch to fix unicode16 writing. Thanks for the users in bug #130922.
30 Sep 2006; Diego Pettenò <flameeyes@gentoo.org>
-id3lib-3.8.3-r3.ebuild, id3lib-3.8.3-r4.ebuild:
diff --git a/media-libs/id3lib/files/digest-id3lib-3.8.3-r5 b/media-libs/id3lib/files/digest-id3lib-3.8.3-r5
new file mode 100644
index 000000000000..d1e91dd6738a
--- /dev/null
+++ b/media-libs/id3lib/files/digest-id3lib-3.8.3-r5
@@ -0,0 +1,3 @@
+MD5 19f27ddd2dda4b2d26a559a4f0f402a7 id3lib-3.8.3.tar.gz 950726
+RMD160 bfa2499ec649ed40815ad0a370c78eb1517952c4 id3lib-3.8.3.tar.gz 950726
+SHA256 2749cc3c0cd7280b299518b1ddf5a5bcfe2d1100614519b68702230e26c7d079 id3lib-3.8.3.tar.gz 950726
diff --git a/media-libs/id3lib/files/id3lib-3.8.3-unicode16.patch b/media-libs/id3lib/files/id3lib-3.8.3-unicode16.patch
new file mode 100644
index 000000000000..b05d2cf298d3
--- /dev/null
+++ b/media-libs/id3lib/files/id3lib-3.8.3-unicode16.patch
@@ -0,0 +1,39 @@
+diff -ruN id3lib-3.8.3.orig/ChangeLog id3lib-3.8.3/ChangeLog
+--- id3lib-3.8.3.orig/ChangeLog 2003-03-02 01:23:00.000000000 +0100
++++ id3lib-3.8.3/ChangeLog 2006-02-22 00:33:59.946214472 +0100
+@@ -1,3 +1,8 @@
++2006-02-17 Jerome Couderc
++
++ * Patch from Spoon to fix UTF-16 writing bug
++ http://sourceforge.net/tracker/index.php?func=detail&aid=1016290&group_id=979&atid=300979
++
+ 2003-03-02 Sunday 17:38 Thijmen Klok <thijmen@id3lib.org>
+
+ * THANKS (1.20): added more people
+diff -ruN id3lib-3.8.3.orig/src/io_helpers.cpp id3lib-3.8.3/src/io_helpers.cpp
+--- id3lib-3.8.3.orig/src/io_helpers.cpp 2003-03-02 01:23:00.000000000 +0100
++++ id3lib-3.8.3/src/io_helpers.cpp 2006-02-22 00:35:02.926639992 +0100
+@@ -363,11 +363,22 @@
+ // Write the BOM: 0xFEFF
+ unicode_t BOM = 0xFEFF;
+ writer.writeChars((const unsigned char*) &BOM, 2);
++ // Patch from Spoon : 2004-08-25 14:17
++ // http://sourceforge.net/tracker/index.php?func=detail&aid=1016290&group_id=979&atid=300979
++ // Wrong code
++ //for (size_t i = 0; i < size; i += 2)
++ //{
++ // unicode_t ch = (data[i] << 8) | data[i+1];
++ // writer.writeChars((const unsigned char*) &ch, 2);
++ //}
++ // Right code
++ unsigned char *pdata = (unsigned char *) data.c_str();
+ for (size_t i = 0; i < size; i += 2)
+ {
+- unicode_t ch = (data[i] << 8) | data[i+1];
++ unicode_t ch = (pdata[i] << 8) | pdata[i+1];
+ writer.writeChars((const unsigned char*) &ch, 2);
+ }
++ // End patch
+ }
+ return writer.getCur() - beg;
+ }
diff --git a/media-libs/id3lib/id3lib-3.8.3-r5.ebuild b/media-libs/id3lib/id3lib-3.8.3-r5.ebuild
new file mode 100644
index 000000000000..09b564b5153a
--- /dev/null
+++ b/media-libs/id3lib/id3lib-3.8.3-r5.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/id3lib/id3lib-3.8.3-r5.ebuild,v 1.1 2006/10/05 08:06:51 flameeyes Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+inherit eutils autotools
+
+MY_P=${P/_/}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Id3 library for C/C++"
+HOMEPAGE="http://id3lib.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc examples"
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch "${FILESDIR}/${P}-zlib.patch"
+ epatch "${FILESDIR}/${P}-test_io.patch"
+ epatch "${FILESDIR}/${P}-autoconf259.patch"
+ epatch "${FILESDIR}/${P}-doxyinput.patch"
+ epatch "${FILESDIR}/${P}-unicode16.patch"
+
+ AT_M4DIR="${S}/m4" eautoreconf
+}
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+
+ if use doc; then
+ cd doc/
+ doxygen Doxyfile || die "doxygen failed"
+ fi
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Install failed"
+
+ dodoc AUTHORS ChangeLog HISTORY README THANKS TODO
+
+ # some example programs to be placed in docs dir.
+ if use examples; then
+ cp -pPR examples ${D}/usr/share/doc/${PF}/examples
+ cd ${D}/usr/share/doc/${PF}/examples
+ make distclean
+ fi
+
+ if use doc; then
+ dohtml -r doc
+ fi
+}