summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-06-27 14:57:20 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-06-27 14:57:20 +0000
commit76ce6e774e4351eb61a7dd10e8378ceec18ca3e0 (patch)
treea55a56b05d56b2174d4b362d8457d6469e8519aa /media-libs/ladspa-sdk
parentremove old (diff)
downloadgentoo-2-76ce6e774e4351eb61a7dd10e8378ceec18ca3e0.tar.gz
gentoo-2-76ce6e774e4351eb61a7dd10e8378ceec18ca3e0.tar.bz2
gentoo-2-76ce6e774e4351eb61a7dd10e8378ceec18ca3e0.zip
go multilib
(Portage version: 2.2.0_alpha185/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-libs/ladspa-sdk')
-rw-r--r--media-libs/ladspa-sdk/ChangeLog7
-rw-r--r--media-libs/ladspa-sdk/ladspa-sdk-1.13-r2.ebuild70
2 files changed, 76 insertions, 1 deletions
diff --git a/media-libs/ladspa-sdk/ChangeLog b/media-libs/ladspa-sdk/ChangeLog
index ad5c924da751..9e3120b4c4c4 100644
--- a/media-libs/ladspa-sdk/ChangeLog
+++ b/media-libs/ladspa-sdk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/ladspa-sdk
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/ladspa-sdk/ChangeLog,v 1.55 2013/06/27 14:36:15 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/ladspa-sdk/ChangeLog,v 1.56 2013/06/27 14:57:20 aballier Exp $
+
+*ladspa-sdk-1.13-r2 (27 Jun 2013)
+
+ 27 Jun 2013; Alexis Ballier <aballier@gentoo.org> +ladspa-sdk-1.13-r2.ebuild:
+ go multilib
27 Jun 2013; Alexis Ballier <aballier@gentoo.org> -ladspa-sdk-1.12-r2.ebuild,
-ladspa-sdk-1.13.ebuild, -files/ladspa-sdk-1.12-fbsd.patch,
diff --git a/media-libs/ladspa-sdk/ladspa-sdk-1.13-r2.ebuild b/media-libs/ladspa-sdk/ladspa-sdk-1.13-r2.ebuild
new file mode 100644
index 000000000000..600832e5f378
--- /dev/null
+++ b/media-libs/ladspa-sdk/ladspa-sdk-1.13-r2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/ladspa-sdk/ladspa-sdk-1.13-r2.ebuild,v 1.1 2013/06/27 14:57:20 aballier Exp $
+
+EAPI=5
+
+inherit eutils multilib toolchain-funcs portability flag-o-matic multilib-minimal
+
+MY_PN=${PN/-/_}
+MY_P=${MY_PN}_${PV}
+
+DESCRIPTION="The Linux Audio Developer's Simple Plugin API"
+HOMEPAGE="http://www.ladspa.org/"
+SRC_URI="http://www.ladspa.org/download/${MY_P}.tgz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND="abi_x86_32? ( !<=app-emulation/emul-linux-x86-soundlibs-20130224-r2
+ !app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)] )"
+DEPEND=">=sys-apps/sed-4"
+
+S="${WORKDIR}/${MY_PN}"
+
+src_prepare() {
+ cd "${WORKDIR}/${MY_PN}/src"
+ epatch "${FILESDIR}"/${P}-properbuild.patch \
+ "${FILESDIR}"/${P}-asneeded.patch \
+ "${FILESDIR}"/${P}-fbsd.patch \
+ "${FILESDIR}"/${P}-no-LD.patch
+
+ sed -i -e 's:-sndfile-play*:@echo Disabled \0:' \
+ makefile || die "sed makefile failed (sound playing tests)"
+
+ cd "${S}"
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ cd src
+ emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" \
+ DYNAMIC_LD_LIBS="$(dlopen_lib)" \
+ CC="$(tc-getCC)" CXX="$(tc-getCXX)" \
+ targets
+}
+
+multilib_src_test() {
+ cd src
+ emake test
+}
+
+multilib_src_install() {
+ cd src
+ emake INSTALL_PLUGINS_DIR="/usr/$(get_libdir)/ladspa" \
+ DESTDIR="${D}" \
+ MKDIR_P="mkdir -p" \
+ install
+}
+
+multilib_src_install_all() {
+ dohtml doc/*.html
+
+ # Needed for apps like rezound
+ # emul-linux-soundlibs doesnt seem to install this, so keep it only for the
+ # default abi.
+ dodir /etc/env.d
+ echo "LADSPA_PATH=/usr/$(get_libdir)/ladspa" > "${D}/etc/env.d/60ladspa"
+}