summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-04-06 10:08:14 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-04-06 10:08:14 +0000
commit9933f3b05d77862fbce0ad2141e25bc5c171accc (patch)
treecb142bd1c9bfb700667b93c85bc00bff70aa0cdd /media-libs/lensfun
parentFix pangox-compat deps (#460498 by ustcscgy) and firefox resizing problem (#4... (diff)
downloadgentoo-2-9933f3b05d77862fbce0ad2141e25bc5c171accc.tar.gz
gentoo-2-9933f3b05d77862fbce0ad2141e25bc5c171accc.tar.bz2
gentoo-2-9933f3b05d77862fbce0ad2141e25bc5c171accc.zip
Include <string.h> for memset() because it's no longer implicitly pulled in by libpng since 1.6.0. Use subslotting for libpng and zlib dependencies.
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'media-libs/lensfun')
-rw-r--r--media-libs/lensfun/ChangeLog7
-rw-r--r--media-libs/lensfun/files/lensfun-0.2.7-memset.patch13
-rw-r--r--media-libs/lensfun/lensfun-0.2.7.ebuild7
3 files changed, 23 insertions, 4 deletions
diff --git a/media-libs/lensfun/ChangeLog b/media-libs/lensfun/ChangeLog
index 9fb2ac208b37..2ceed540ce04 100644
--- a/media-libs/lensfun/ChangeLog
+++ b/media-libs/lensfun/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/lensfun
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/lensfun/ChangeLog,v 1.49 2013/03/23 20:51:22 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/lensfun/ChangeLog,v 1.50 2013/04/06 10:08:14 ssuominen Exp $
+
+ 06 Apr 2013; Samuli Suominen <ssuominen@gentoo.org> lensfun-0.2.7.ebuild,
+ +files/lensfun-0.2.7-memset.patch:
+ Include <string.h> for memset() because it's no longer implicitly pulled in
+ by libpng since 1.6.0. Use subslotting for libpng and zlib dependencies.
23 Mar 2013; Markus Meier <maekke@gentoo.org> lensfun-0.2.7.ebuild:
restore python-2.7 support
diff --git a/media-libs/lensfun/files/lensfun-0.2.7-memset.patch b/media-libs/lensfun/files/lensfun-0.2.7-memset.patch
new file mode 100644
index 000000000000..2b79e48f5be1
--- /dev/null
+++ b/media-libs/lensfun/files/lensfun-0.2.7-memset.patch
@@ -0,0 +1,13 @@
+libs/auxfun/image.cpp: In member function ‘bool Image::SavePNG(const char*)’:
+libs/auxfun/image.cpp:258:42: error: ‘memset’ was not declared in this scope
+
+--- libs/auxfun/image.cpp
++++ libs/auxfun/image.cpp
+@@ -6,6 +6,7 @@
+ #include "image.h"
+ #include <zlib.h>
+ #include <png.h>
++#include <string.h>
+ #include <stdlib.h>
+ #ifdef _MSC_VER
+ #define _USE_MATH_DEFINES 1
diff --git a/media-libs/lensfun/lensfun-0.2.7.ebuild b/media-libs/lensfun/lensfun-0.2.7.ebuild
index 7ba714ae0960..91eb70d2e3d6 100644
--- a/media-libs/lensfun/lensfun-0.2.7.ebuild
+++ b/media-libs/lensfun/lensfun-0.2.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/lensfun/lensfun-0.2.7.ebuild,v 1.2 2013/03/23 20:51:22 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/lensfun/lensfun-0.2.7.ebuild,v 1.3 2013/04/06 10:08:14 ssuominen Exp $
EAPI=5
@@ -18,14 +18,15 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd6
IUSE="doc sse sse2"
RDEPEND=">=dev-libs/glib-2.28
- media-libs/libpng:0
- sys-libs/zlib"
+ media-libs/libpng:0=
+ sys-libs/zlib:="
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
PATCHES=(
"${FILESDIR}"/${P}-build.patch
"${FILESDIR}"/${PN}-0.2.6-auxfun.patch
+ "${FILESDIR}"/${P}-memset.patch
)
DOCS=( README docs/mounts.txt )