summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-08-05 21:41:10 +0000
committerTim Harder <radhermit@gentoo.org>2011-08-05 21:41:10 +0000
commit063d50310c90ad17e12083ef77f16013abb4abb2 (patch)
tree0d8c9781c41ee9c196386a8acae2d0144dc0e6eb /media-libs/libbluray
parentWe still need dev-libs/openssl. 8-) (diff)
downloadgentoo-2-063d50310c90ad17e12083ef77f16013abb4abb2.tar.gz
gentoo-2-063d50310c90ad17e12083ef77f16013abb4abb2.tar.bz2
gentoo-2-063d50310c90ad17e12083ef77f16013abb4abb2.zip
Revbump and remove old. Fix build error with xine plugin (bug #355331), set REQUIRED_USE, and remove the libtool archive when not building static libs. Based on work by Martin von Gagern.
(Portage version: 2.2.0_alpha50/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libbluray')
-rw-r--r--media-libs/libbluray/ChangeLog10
-rw-r--r--media-libs/libbluray/libbluray-0.0.1_pre20110210-r1.ebuild (renamed from media-libs/libbluray/libbluray-0.0.1_pre20110210.ebuild)30
2 files changed, 19 insertions, 21 deletions
diff --git a/media-libs/libbluray/ChangeLog b/media-libs/libbluray/ChangeLog
index f582f0562116..5f4b669fa37f 100644
--- a/media-libs/libbluray/ChangeLog
+++ b/media-libs/libbluray/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-libs/libbluray
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libbluray/ChangeLog,v 1.5 2011/02/10 08:01:53 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libbluray/ChangeLog,v 1.6 2011/08/05 21:41:09 radhermit Exp $
+
+*libbluray-0.0.1_pre20110210-r1 (05 Aug 2011)
+
+ 05 Aug 2011; Tim Harder <radhermit@gentoo.org>
+ -libbluray-0.0.1_pre20110210.ebuild, +libbluray-0.0.1_pre20110210-r1.ebuild:
+ Revbump and remove old. Fix build error with xine plugin (bug #355331), set
+ REQUIRED_USE, and remove the libtool archive when not building static libs.
+ Based on work by Martin von Gagern.
*libbluray-0.0.1_pre20110210 (10 Feb 2011)
diff --git a/media-libs/libbluray/libbluray-0.0.1_pre20110210.ebuild b/media-libs/libbluray/libbluray-0.0.1_pre20110210-r1.ebuild
index dd76c6312612..ba63bb18dbf9 100644
--- a/media-libs/libbluray/libbluray-0.0.1_pre20110210.ebuild
+++ b/media-libs/libbluray/libbluray-0.0.1_pre20110210-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libbluray/libbluray-0.0.1_pre20110210.ebuild,v 1.1 2011/02/10 08:01:53 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libbluray/libbluray-0.0.1_pre20110210-r1.ebuild,v 1.1 2011/08/05 21:41:10 radhermit Exp $
EAPI=4
@@ -17,7 +17,6 @@ IUSE="aacs java static-libs utils xine"
COMMON_DEPEND="
dev-libs/libxml2
- xine? ( media-libs/xine-lib )
"
RDEPEND="
${COMMON_DEPEND}
@@ -32,8 +31,13 @@ DEPEND="
)
dev-util/pkgconfig
"
+PDEPEND="
+ xine? ( media-libs/libbluray-xine )
+"
+
+REQUIRED_USE="utils? ( static-libs )"
-DOCS="doc/README README.txt TODO.txt"
+DOCS=( doc/README README.txt TODO.txt )
src_prepare() {
use java && export JDK_HOME="$(java-config -g JAVA_HOME)"
@@ -53,22 +57,12 @@ src_configure() {
econf \
$(use_enable java bdjava) \
$(use_enable static-libs static) \
- $(use_enable utils static) \
$(use_enable utils examples) \
- $myconf
-}
-
-src_compile() {
- emake
-
- if use xine; then
- cd player_wrappers/xine
- emake
- fi
+ ${myconf}
}
src_install() {
- default_src_install
+ default
if use utils; then
cd src/examples/
@@ -85,9 +79,5 @@ src_install() {
doenvd "${FILESDIR}"/90${PN}
fi
- if use xine; then
- cd "${S}"/player_wrappers/xine
- emake DESTDIR="${D}" install
- newdoc HOWTO README.xine
- fi
+ use static-libs || find "${ED}" -name '*.la' -exec rm -f '{}' +
}