summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRomain Perier <mrpouet@gentoo.org>2009-07-17 10:52:03 +0000
committerRomain Perier <mrpouet@gentoo.org>2009-07-17 10:52:03 +0000
commit04fba881c3b74b30909ffeb933148b4b84e68087 (patch)
tree116a2a92ada3dd85f1b54e4c1b9a24861c838732 /media-libs/libcanberra
parentTweak USE defaults a bit. (diff)
downloadgentoo-2-04fba881c3b74b30909ffeb933148b4b84e68087.tar.gz
gentoo-2-04fba881c3b74b30909ffeb933148b4b84e68087.tar.bz2
gentoo-2-04fba881c3b74b30909ffeb933148b4b84e68087.zip
Fix correctly bug #277739, remove template fix, replaced LT_* macros by AC_LIBTOOL* (equivalent for old version) for backward compatibility with < sys-devel/libtool-2.2
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libcanberra')
-rw-r--r--media-libs/libcanberra/ChangeLog8
-rw-r--r--media-libs/libcanberra/files/libcanberra-0.14-backward-compatibility-libtool.patch30
-rw-r--r--media-libs/libcanberra/libcanberra-0.14.ebuild19
3 files changed, 53 insertions, 4 deletions
diff --git a/media-libs/libcanberra/ChangeLog b/media-libs/libcanberra/ChangeLog
index 1122dca92425..e59bc8b7f5da 100644
--- a/media-libs/libcanberra/ChangeLog
+++ b/media-libs/libcanberra/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/libcanberra
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libcanberra/ChangeLog,v 1.22 2009/07/16 11:01:07 mrpouet Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libcanberra/ChangeLog,v 1.23 2009/07/17 10:52:03 mrpouet Exp $
+
+ 17 Jul 2009; Romain Perier <mrpouet@gentoo.org> libcanberra-0.14.ebuild,
+ +files/libcanberra-0.14-backward-compatibility-libtool.patch:
+ Fix correctly bug #277739, remove template fix, replaced LT_* by
+ AC_LIBTOOL* macros (equivalent for old version) for backward compatibility
+ with < sys-devel/libtool-2.2
16 Jul 2009; Romain Perier <mrpouet@gentoo.org> libcanberra-0.14.ebuild:
Fix bug #277739. Moved sys-devel/libtool to >=sys-devel/libtool-2.2 into
diff --git a/media-libs/libcanberra/files/libcanberra-0.14-backward-compatibility-libtool.patch b/media-libs/libcanberra/files/libcanberra-0.14-backward-compatibility-libtool.patch
new file mode 100644
index 000000000000..54428f00f1dd
--- /dev/null
+++ b/media-libs/libcanberra/files/libcanberra-0.14-backward-compatibility-libtool.patch
@@ -0,0 +1,30 @@
+ configure.ac | 9 ++++++---
+ 1 files changed, 6 insertions(+), 3 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index e804538..1e96988 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -68,8 +68,11 @@ for flag in $DESIRED_FLAGS ; do
+ done
+
+ #### libtool stuff ####
+-LT_PREREQ(2.2)
+-LT_INIT([dlopen win32-dll disable-static])
++AC_LIBTOOL_DLOPEN
++AC_LIBTOOL_WIN32_DLL
++AC_DISABLE_STATIC
++AM_DISABLE_STATIC
++AC_PROG_LIBTOOL
+
+ dnl Unfortunately, even up to libtool 2.2.6a there is no way to know
+ dnl exactly which version of libltdl is present in the system, so we
+@@ -89,7 +92,7 @@ dnl can give the proper place to find libltdl through the standard
+ dnl variables like LDFLAGS and CPPFLAGS.
+
+ AC_CHECK_HEADER([ltdl.h],
+- [AC_CHECK_LIB([ltdl], [lt_dladvise_init], [LIBLTDL=-lltdl], [LIBLTDL=])],
++ [AC_CHECK_LIB([ltdl], [lt_dlopen], [LIBLTDL=-lltdl], [LIBLTDL=])],
+ [LIBLTDL=])
+
+ AS_IF([test "x$LIBLTDL" = "x"],
diff --git a/media-libs/libcanberra/libcanberra-0.14.ebuild b/media-libs/libcanberra/libcanberra-0.14.ebuild
index 80fbb8cc8f58..3ea05c66b1a2 100644
--- a/media-libs/libcanberra/libcanberra-0.14.ebuild
+++ b/media-libs/libcanberra/libcanberra-0.14.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libcanberra/libcanberra-0.14.ebuild,v 1.2 2009/07/16 11:01:07 mrpouet Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libcanberra/libcanberra-0.14.ebuild,v 1.3 2009/07/17 10:52:03 mrpouet Exp $
EAPI="1"
-inherit eutils gnome2-utils
+inherit eutils gnome2-utils autotools
DESCRIPTION="Portable Sound Event Library"
HOMEPAGE="http://0pointer.de/lennart/projects/libcanberra/"
@@ -16,7 +16,7 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
IUSE="alsa doc gstreamer +gtk oss pulseaudio"
RDEPEND="media-libs/libvorbis
- >=sys-devel/libtool-2.2
+ sys-devel/libtool
alsa? ( media-libs/alsa-lib )
pulseaudio? ( >=media-sound/pulseaudio-0.9.11 )
gstreamer? ( >=media-libs/gstreamer-0.10.15 )
@@ -27,6 +27,19 @@ DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.17
doc? ( >=dev-util/gtk-doc-1.9 )"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-backward-compatibility-libtool.patch"
+
+ rm "${S}/lt*" || die "clean-up ltmain.sh failed"
+ rm "${S}/m4/lt*" || die "clean-up lt scripts failed"
+ rm "${S}/m4/libtool*" || die "clean-up libtool script failed"
+
+ eautoreconf
+}
+
src_compile() {
econf --disable-static \
$(use_enable alsa) \