summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-06-16 19:22:15 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-06-16 19:22:15 +0000
commit0ea019e9af09d24b746f9ed0bb0cc79217280848 (patch)
tree2a68c1442ad2f43c36b91bf01fbba01984c22428 /media-libs/libdvdnav
parentrphil forgot the _01 in the directory name (diff)
downloadgentoo-2-0ea019e9af09d24b746f9ed0bb0cc79217280848.tar.gz
gentoo-2-0ea019e9af09d24b746f9ed0bb0cc79217280848.tar.bz2
gentoo-2-0ea019e9af09d24b746f9ed0bb0cc79217280848.zip
This is a bunch of gcc-3.1 fixes, updates and generally preparing to unmask
xine-0.9.10, when we do unmask it users of xine-d4d and xine-d5d will need to know that those plugins are not yet available for the new version.
Diffstat (limited to 'media-libs/libdvdnav')
-rw-r--r--media-libs/libdvdnav/ChangeLog10
-rw-r--r--media-libs/libdvdnav/files/digest-libdvdnav-0.1.11
-rw-r--r--media-libs/libdvdnav/libdvdnav-0.1.1.ebuild29
3 files changed, 38 insertions, 2 deletions
diff --git a/media-libs/libdvdnav/ChangeLog b/media-libs/libdvdnav/ChangeLog
index 3ebf2ce47962..545904c19df8 100644
--- a/media-libs/libdvdnav/ChangeLog
+++ b/media-libs/libdvdnav/ChangeLog
@@ -1,9 +1,15 @@
# ChangeLog for media-lib/libdvdnav
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libdvdnav/ChangeLog,v 1.1 2002/05/01 03:07:14 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libdvdnav/ChangeLog,v 1.2 2002/06/16 19:22:15 lostlogic Exp $
+
+*libdvdnav-0.1.1 (16 Jun 2002)
+
+ 16 Jun 2002; Brandon Low <lostlogic@gentoo.org> libdvdnav-0.1.1.ebuild:
+
+ Update to new version for xine-0.9.10
*libdvdnav-0.1.0 (30 Apr 2002)
30 April 2002; Arcady Genkin <agenkin@thpoon.com> libdvdnav-0.1.0.ebuild:
- Initial version. \ No newline at end of file
+ Initial version.
diff --git a/media-libs/libdvdnav/files/digest-libdvdnav-0.1.1 b/media-libs/libdvdnav/files/digest-libdvdnav-0.1.1
new file mode 100644
index 000000000000..12f64f532572
--- /dev/null
+++ b/media-libs/libdvdnav/files/digest-libdvdnav-0.1.1
@@ -0,0 +1 @@
+MD5 8bd7de2e866b2cd0b336b1a0287a8730 libdvdnav-0.1.1.tar.gz 219327
diff --git a/media-libs/libdvdnav/libdvdnav-0.1.1.ebuild b/media-libs/libdvdnav/libdvdnav-0.1.1.ebuild
new file mode 100644
index 000000000000..6d5be69c1a7d
--- /dev/null
+++ b/media-libs/libdvdnav/libdvdnav-0.1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2002 Arcady Genkin <agenkin@thpoon.com>
+# Distributed under the terms of the GNU General Public License, v2
+# Maintainer: Arcady Genkin <agenkin@thpoon.com>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libdvdnav/libdvdnav-0.1.1.ebuild,v 1.1 2002/06/16 19:22:15 lostlogic Exp $
+
+DESCRIPTION="Library for DVD navigation tools."
+HOMEPAGE="http://sourceforge.net/projects/dvd/"
+
+SRC_URI="mirror://sourceforge/dvd/${P}.tar.gz"
+S=${WORKDIR}/${P}
+
+LICENSE="GPL"
+
+DEPEND="media-libs/libdvdread"
+
+src_compile() {
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING INSTALL NEWS README
+}