summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-02-27 07:57:53 +0000
committerJustin Lecher <jlec@gentoo.org>2015-02-27 07:57:53 +0000
commitb5284891f703d139f5062a69b3132f2fdbc5c382 (patch)
treec840e85c05959492a1a6bb31d7fdac743a1012d6 /media-libs/libemf
parentMirror the sources, #537754; Bump to EAPI=5 (diff)
downloadgentoo-2-b5284891f703d139f5062a69b3132f2fdbc5c382.tar.gz
gentoo-2-b5284891f703d139f5062a69b3132f2fdbc5c382.tar.bz2
gentoo-2-b5284891f703d139f5062a69b3132f2fdbc5c382.zip
Version Bump
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'media-libs/libemf')
-rw-r--r--media-libs/libemf/ChangeLog9
-rw-r--r--media-libs/libemf/libemf-1.0.7.ebuild36
2 files changed, 43 insertions, 2 deletions
diff --git a/media-libs/libemf/ChangeLog b/media-libs/libemf/ChangeLog
index a7068dccbe29..04fd6af45f12 100644
--- a/media-libs/libemf/ChangeLog
+++ b/media-libs/libemf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/libemf
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libemf/ChangeLog,v 1.43 2013/08/12 12:47:11 kensington Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libemf/ChangeLog,v 1.44 2015/02/27 07:57:53 jlec Exp $
+
+*libemf-1.0.7 (27 Feb 2015)
+
+ 27 Feb 2015; Justin Lecher <jlec@gentoo.org> +libemf-1.0.7.ebuild:
+ Version Bump
12 Aug 2013; Michael Palimaka <kensington@gentoo.org> -libemf-1.0.4.ebuild:
Remove old.
diff --git a/media-libs/libemf/libemf-1.0.7.ebuild b/media-libs/libemf/libemf-1.0.7.ebuild
new file mode 100644
index 000000000000..936971f94d10
--- /dev/null
+++ b/media-libs/libemf/libemf-1.0.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libemf/libemf-1.0.7.ebuild,v 1.1 2015/02/27 07:57:53 jlec Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils
+
+MY_P="${P/emf/EMF}"
+DESCRIPTION="Library implementation of ECMA-234 API for the generation of enhanced metafiles"
+HOMEPAGE="http://libemf.sourceforge.net/"
+SRC_URI="mirror://sourceforge/libemf/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 -arm ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="doc static-libs"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare(){
+ sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' configure.ac || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=( --enable-editing )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ use doc && HTML_DOCS=( doc/html/. )
+ autotools-utils_src_install
+}