summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2005-05-10 06:07:47 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2005-05-10 06:07:47 +0000
commitc7010ad9cd2f5085dc3f5030a4de5f8ba8042473 (patch)
treeea5694039d91b8c62b7e30bdee03df8c6b5f0635 /media-libs/libexif/libexif-0.5.12-r3.ebuild
parentversion bump to 1.0.3 (currently masked until testing is done); stablize 0.9.... (diff)
downloadgentoo-2-c7010ad9cd2f5085dc3f5030a4de5f8ba8042473.tar.gz
gentoo-2-c7010ad9cd2f5085dc3f5030a4de5f8ba8042473.tar.bz2
gentoo-2-c7010ad9cd2f5085dc3f5030a4de5f8ba8042473.zip
Revbump to fix security bug #92035. Stable on amd64, sparc, and x86.
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'media-libs/libexif/libexif-0.5.12-r3.ebuild')
-rw-r--r--media-libs/libexif/libexif-0.5.12-r3.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/media-libs/libexif/libexif-0.5.12-r3.ebuild b/media-libs/libexif/libexif-0.5.12-r3.ebuild
new file mode 100644
index 000000000000..c79d1a287b1c
--- /dev/null
+++ b/media-libs/libexif/libexif-0.5.12-r3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libexif/libexif-0.5.12-r3.ebuild,v 1.1 2005/05/10 06:07:47 eradicator Exp $
+
+inherit eutils
+
+DESCRIPTION="Library for parsing, editing, and saving EXIF data"
+HOMEPAGE="http://libexif.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~ppc-macos sparc x86"
+IUSE="nls"
+
+DEPEND="dev-util/pkgconfig"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/libexif-0.5-CAN-2005-0664.patch
+ epatch ${FILESDIR}/${PN}-0.5.12-recurse.patch
+}
+
+src_compile() {
+ econf $(use_enable nls) || die
+ emake || die
+}
+
+src_install() {
+ dodir /usr/$(get_libdir)
+ dodir /usr/include/libexif
+ dodir /usr/share/locale
+ dodir /usr/$(get_libdir)/pkgconfig
+ einstall || die
+
+ dodoc ChangeLog README
+
+ # installs a blank directory for whatever broken reason
+ use nls || rmdir ${D}/usr/share/locale
+}
+
+pkg_postinst() {
+ einfo
+ einfo "if you've upgraded from ${PN}-0.5.8 you'll"
+ einfo "have to run revdep-rebuild from gentoolkit"
+ einfo
+}