summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2004-02-23 18:51:49 +0000
committerMartin Schlemmer <azarah@gentoo.org>2004-02-23 18:51:49 +0000
commit25678207a38ffcc9bae90024396200c8fd54f1fc (patch)
tree5508241897646383d9850712e18bca811f6d96e8 /media-libs/libfame/libfame-0.9.0-r1.ebuild
parentWork around the buggy make files (bug #41530) (Manifest recommit) (diff)
downloadgentoo-2-25678207a38ffcc9bae90024396200c8fd54f1fc.tar.gz
gentoo-2-25678207a38ffcc9bae90024396200c8fd54f1fc.tar.bz2
gentoo-2-25678207a38ffcc9bae90024396200c8fd54f1fc.zip
Do not add -march=i[345]86 to CFLAGS, as it breaks with some flags, bug
#41770. Remove libtoolize for amd64, as update_gnuconfig() should be enough.
Diffstat (limited to 'media-libs/libfame/libfame-0.9.0-r1.ebuild')
-rw-r--r--media-libs/libfame/libfame-0.9.0-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/media-libs/libfame/libfame-0.9.0-r1.ebuild b/media-libs/libfame/libfame-0.9.0-r1.ebuild
new file mode 100644
index 000000000000..db95c474905a
--- /dev/null
+++ b/media-libs/libfame/libfame-0.9.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libfame/libfame-0.9.0-r1.ebuild,v 1.1 2004/02/23 18:51:49 azarah Exp $
+
+inherit flag-o-matic gnuconfig
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="MPEG-1 and MPEG-4 video encoding library"
+SRC_URI="mirror://sourceforge/fame/${P}.tar.gz"
+HOMEPAGE="http://fame.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64 ~ia64"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # Do not add -march=i586, bug #41770.
+ sed -i -e 's:-march=i[345]86 ::g' configure
+
+ # This is needed for alpha and probably other newer arches (amd64)
+ # (13 Jan 2004 agriffis)
+ gnuconfig_update
+}
+
+src_compile() {
+# filter-flags -fprefetch-loop-arrays
+ econf $(use_enable mmx) $(use_enable sse) || die
+ emake || die
+}
+
+src_install() {
+ dodir /usr
+ dodir /usr/lib
+
+ einstall install || die
+ dobin libfame-config
+
+ insinto /usr/share/aclocal
+ doins libfame.m4
+
+ dodoc CHANGES README
+ doman doc/*.3
+}