summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-01-13 15:08:35 +0000
committerAron Griffis <agriffis@gentoo.org>2004-01-13 15:08:35 +0000
commit47d6ba7392061ac73eab572f974ea62b688b2f6f (patch)
treed4a2ac3691cca37d790f728f2b689cecbcb8592e /media-libs/libfame
parentstable on sparc (diff)
downloadgentoo-2-47d6ba7392061ac73eab572f974ea62b688b2f6f.tar.gz
gentoo-2-47d6ba7392061ac73eab572f974ea62b688b2f6f.tar.bz2
gentoo-2-47d6ba7392061ac73eab572f974ea62b688b2f6f.zip
Use gnuconfig_update to enable building on alphaev67
Diffstat (limited to 'media-libs/libfame')
-rw-r--r--media-libs/libfame/ChangeLog7
-rw-r--r--media-libs/libfame/libfame-0.9.0.ebuild30
2 files changed, 20 insertions, 17 deletions
diff --git a/media-libs/libfame/ChangeLog b/media-libs/libfame/ChangeLog
index 67d6e76f8b57..e44d94e8da03 100644
--- a/media-libs/libfame/ChangeLog
+++ b/media-libs/libfame/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-libs/libfame
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libfame/ChangeLog,v 1.12 2003/11/29 23:11:28 brad_mssw Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libfame/ChangeLog,v 1.13 2004/01/13 15:08:35 agriffis Exp $
+
+ 13 Jan 2004; Aron Griffis <agriffis@gentoo.org> libfame-0.9.0.ebuild:
+ Use gnuconfig_update to enable building on alphaev67
29 Nov 2003; Brad House <brad_mssw@gentoo.org> libfame-0.9.0.ebuild:
mark stable on amd64
diff --git a/media-libs/libfame/libfame-0.9.0.ebuild b/media-libs/libfame/libfame-0.9.0.ebuild
index 2a29f78fefec..9553fee7dad9 100644
--- a/media-libs/libfame/libfame-0.9.0.ebuild
+++ b/media-libs/libfame/libfame-0.9.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libfame/libfame-0.9.0.ebuild,v 1.13 2003/11/29 23:11:28 brad_mssw Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libfame/libfame-0.9.0.ebuild,v 1.14 2004/01/13 15:08:35 agriffis Exp $
-inherit flag-o-matic
+inherit flag-o-matic gnuconfig
S=${WORKDIR}/${P}
DESCRIPTION="MPEG-1 and MPEG-4 video encoding library"
@@ -11,24 +11,24 @@ HOMEPAGE="http://fame.sourceforge.net/"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="x86 ppc sparc ~alpha hppa amd64"
+KEYWORDS="x86 ppc sparc alpha hppa amd64"
DEPEND="virtual/glibc"
-replace-flags "-fprefetch-loop-arrays" " "
+src_unpack() {
+ unpack ${A} || die
+ cd ${S} || die
-src_compile() {
- local myconf
-
- if [ "${ARCH}" = "amd64" ]
- then
- libtoolize -c -f
- fi
+ # This is needed for alpha and probably other newer arches
+ # (13 Jan 2004 agriffis)
+ gnuconfig_update
- use mmx && myconf="${myconf} --enable-mmx"
- use sse && myconf="${myconf} --enable-sse"
+ [[ "${ARCH}" == "amd64" ]] && libtoolize -c -f
+}
- econf ${myconf} || die
+src_compile() {
+ filter-flags -fprefetch-loop-arrays
+ econf $(use_enable mmx) $(use_enable sse) || die
emake || die
}