summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-02-13 14:29:41 +0000
committerAchim Gottinger <achim@gentoo.org>2001-02-13 14:29:41 +0000
commitc8371d9e9ca933c7773a76ee3133ec8f0d7fbe5d (patch)
treede46edaa6630baa8b7d0d425cb6ddf761dd7d2c2 /media-libs/libgd
parent*** empty log message *** (diff)
downloadgentoo-2-c8371d9e9ca933c7773a76ee3133ec8f0d7fbe5d.tar.gz
gentoo-2-c8371d9e9ca933c7773a76ee3133ec8f0d7fbe5d.tar.bz2
gentoo-2-c8371d9e9ca933c7773a76ee3133ec8f0d7fbe5d.zip
Maintainence and FHS 2.1 fixes
Added a lot of USE flags GGI support and lcms support for libmng
Diffstat (limited to 'media-libs/libgd')
-rw-r--r--media-libs/libgd/libgd-1.8.3-r2.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/media-libs/libgd/libgd-1.8.3-r2.ebuild b/media-libs/libgd/libgd-1.8.3-r2.ebuild
new file mode 100644
index 000000000000..6eb85af2b8a8
--- /dev/null
+++ b/media-libs/libgd/libgd-1.8.3-r2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libgd/libgd-1.8.3-r2.ebuild,v 1.1 2001/02/13 14:29:40 achim Exp $
+
+P=libgd-1.8.3
+A=gd-1.8.3.tar.gz
+S=${WORKDIR}/gd-1.8.3
+DESCRIPTION="A graphics library for fast image creation"
+SRC_URI="http://www.boutell.com/gd/http/"${A}
+HOMEPAGE="http://www.boutell.com/gd/"
+
+DEPEND="virtual/glibc
+ >=media-libs/jpeg-6b
+ >=media-libs/libpng-1.0.7
+ >=media-libs/freetype-1.3.1
+ X? ( >=x11-base/xfree-4.0.1 )"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ cp Makefile Makefile.orig
+ if [ "`use X`" ]
+ then
+ sed -e "s/^CFLAGS=.*/CFLAGS=$CFLAGS -DHAVE_XPM -DHAVE_JPEG -DHAVE_LIBTTF -DHAVE_PNG /" \
+ -e "s/^LIBS=.*/LIBS=-lm -lgd -lpng -lz -ljpeg -lttf -lXpm -lX11/" \
+ -e "s/^INCLUDEDIRS=/INCLUDEDIRS=-I\/usr\/include\/freetype /" \
+ Makefile.orig > Makefile
+ else
+ sed -e "s/^CFLAGS=.*/CFLAGS=$CFLAGS -DHAVE_JPEG -DHAVE_LIBTTF -DHAVE_PNG /" \
+ -e "s/^LIBS=.*/LIBS=-lm -lgd -lpng -lz -ljpeg -lttf/" \
+ -e "s/^INCLUDEDIRS=/INCLUDEDIRS=-I\/usr\/include\/freetype /" \
+ Makefile.orig > Makefile
+ fi
+
+}
+
+src_compile() {
+
+ try make
+
+}
+
+src_install() {
+
+ dodir /usr/{bin,lib,include}
+
+ try make INSTALL_LIB=${D}/usr/lib INSTALL_BIN=${D}/usr/bin \
+ INSTALL_INCLUDE=${D}/usr/include install
+
+ preplib /usr
+ dodoc readme.txt
+ docinto html
+ dodoc index.html
+
+}
+
+
+
+
+