summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-02-04 08:19:05 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-02-04 08:19:05 +0000
commitd9b3cbe0f699d9cde8236dc5e16ea9858612c0c3 (patch)
tree8978231cabcdecd505e0f2544066ea4705a04662 /media-libs/libgpod
parentFix the common coinor pkg-config installation problem (diff)
downloadgentoo-2-d9b3cbe0f699d9cde8236dc5e16ea9858612c0c3.tar.gz
gentoo-2-d9b3cbe0f699d9cde8236dc5e16ea9858612c0c3.tar.bz2
gentoo-2-d9b3cbe0f699d9cde8236dc5e16ea9858612c0c3.zip
Version bump wrt #498284 by "Nikoli"
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'media-libs/libgpod')
-rw-r--r--media-libs/libgpod/ChangeLog9
-rw-r--r--media-libs/libgpod/libgpod-0.8.3.ebuild70
2 files changed, 77 insertions, 2 deletions
diff --git a/media-libs/libgpod/ChangeLog b/media-libs/libgpod/ChangeLog
index 2b34e9e36387..9b7c68af571e 100644
--- a/media-libs/libgpod/ChangeLog
+++ b/media-libs/libgpod/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/libgpod
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libgpod/ChangeLog,v 1.98 2013/05/11 22:04:47 ssuominen Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libgpod/ChangeLog,v 1.99 2014/02/04 08:19:05 ssuominen Exp $
+
+*libgpod-0.8.3 (04 Feb 2014)
+
+ 04 Feb 2014; Samuli Suominen <ssuominen@gentoo.org> +libgpod-0.8.3.ebuild:
+ Version bump wrt #498284 by "Nikoli"
11 May 2013; Samuli Suominen <ssuominen@gentoo.org> libgpod-0.8.2.ebuild:
Use subslot operator for the libplist and libimobiledevice dependencies.
diff --git a/media-libs/libgpod/libgpod-0.8.3.ebuild b/media-libs/libgpod/libgpod-0.8.3.ebuild
new file mode 100644
index 000000000000..61ebb1b87bf9
--- /dev/null
+++ b/media-libs/libgpod/libgpod-0.8.3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libgpod/libgpod-0.8.3.ebuild,v 1.1 2014/02/04 08:19:05 ssuominen Exp $
+
+EAPI=5
+
+# TODO: Use python-r1 instead and support Python 3.x?
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils mono python-single-r1 udev
+
+DESCRIPTION="Shared library to access the contents of an iPod"
+HOMEPAGE="http://www.gtkpod.org/libgpod/"
+SRC_URI="mirror://sourceforge/gtkpod/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gtk python +udev ios mono static-libs"
+
+RDEPEND=">=app-pda/libplist-1.0:=
+ >=dev-db/sqlite-3
+ >=dev-libs/glib-2.16:2
+ dev-libs/libxml2
+ sys-apps/sg3_utils
+ gtk? ( x11-libs/gdk-pixbuf:2 )
+ ios? ( app-pda/libimobiledevice:= )
+ python? (
+ ${PYTHON_DEPS}
+ >=media-libs/mutagen-1.8[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-2.8:2[${PYTHON_USEDEP}]
+ )
+ udev? ( virtual/udev )
+ mono? (
+ >=dev-lang/mono-1.9.1
+ >=dev-dotnet/gtk-sharp-2.12
+ )"
+DEPEND="${RDEPEND}
+ python? ( >=dev-lang/swig-1.3.24 )
+ dev-libs/libxslt
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS="AUTHORS NEWS README* TROUBLESHOOTING"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable udev) \
+ $(use_enable gtk gdk-pixbuf) \
+ $(use_enable python pygobject) \
+ --without-hal \
+ $(use_with ios libimobiledevice) \
+ --with-udev-dir="$(get_udevdir)"
+ --with-html-dir=/usr/share/doc/${PF}/html \
+ $(use_with python) \
+ $(use_with mono)
+}
+
+src_install() {
+ default
+ rmdir "${ED}"/tmp
+ prune_libtool_files --all
+}