summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2009-01-19 23:58:34 +0000
committerOlivier Crête <tester@gentoo.org>2009-01-19 23:58:34 +0000
commitda2f5a19c63df5e6166858eb3ed81df8afc02477 (patch)
tree519ebce95a7c229d30d3f46b68148652b91fca61 /media-libs/libgpod
parentEAPI=2; add use-based dep (diff)
downloadgentoo-2-da2f5a19c63df5e6166858eb3ed81df8afc02477.tar.gz
gentoo-2-da2f5a19c63df5e6166858eb3ed81df8afc02477.tar.bz2
gentoo-2-da2f5a19c63df5e6166858eb3ed81df8afc02477.zip
Version bump
(Portage version: 2.1.6.4/cvs/Linux 2.6.27-gentoo-r7 i686)
Diffstat (limited to 'media-libs/libgpod')
-rw-r--r--media-libs/libgpod/ChangeLog9
-rw-r--r--media-libs/libgpod/libgpod-0.7.0.ebuild59
2 files changed, 66 insertions, 2 deletions
diff --git a/media-libs/libgpod/ChangeLog b/media-libs/libgpod/ChangeLog
index fa8c456d8aba..fc65a42d5ba0 100644
--- a/media-libs/libgpod/ChangeLog
+++ b/media-libs/libgpod/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/libgpod
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libgpod/ChangeLog,v 1.54 2008/11/30 16:38:47 bluebird Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libgpod/ChangeLog,v 1.55 2009/01/19 23:58:34 tester Exp $
+
+*libgpod-0.7.0 (19 Jan 2009)
+
+ 19 Jan 2009; Olivier Crête <tester@gentoo.org> +libgpod-0.7.0.ebuild:
+ Version bump
30 Nov 2008; Friedrich Oslage <bluebird@gentoo.org> libgpod-0.6.0.ebuild:
Stable on sparc, bug #231573
diff --git a/media-libs/libgpod/libgpod-0.7.0.ebuild b/media-libs/libgpod/libgpod-0.7.0.ebuild
new file mode 100644
index 000000000000..91e8c5f7a5db
--- /dev/null
+++ b/media-libs/libgpod/libgpod-0.7.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libgpod/libgpod-0.7.0.ebuild,v 1.1 2009/01/19 23:58:34 tester Exp $
+
+inherit eutils libtool
+
+DESCRIPTION="Shared library to access the contents of an iPod"
+HOMEPAGE="http://www.gtkpod.org/libgpod.html"
+SRC_URI="mirror://sourceforge/gtkpod/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="gtk python doc test hal"
+
+RDEPEND=">=dev-libs/glib-2.4
+ hal? ( =sys-apps/hal-0.5* )
+ sys-apps/sg3_utils
+ gtk? ( >=x11-libs/gtk+-2 )
+ python? ( >=dev-lang/python-2.3
+ >=x11-libs/gtk+-2
+ media-libs/mutagen
+ gtk? ( >=dev-python/pygobject-2 ) )
+ test? ( media-libs/taglib )"
+DEPEND="${RDEPEND}
+ doc? ( dev-util/gtk-doc )
+ python? ( >=dev-lang/swig-1.3.24 )
+ dev-util/pkgconfig"
+
+src_compile() {
+
+ local myconf
+
+ if use gtk; then
+ myconf="--enable-pygobject"
+ else
+ myconf="--disable-pygobject"
+ fi
+
+ econf ${myconf} \
+ $(use_enable doc gtk-doc) \
+ $(use_enable gtk gdk-pixbuf) \
+ $(use_with hal hal) \
+ $(use_with python) || die "configure failed"
+
+ emake || die "make failed"
+
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ dodoc README TROUBLESHOOTING AUTHORS NEWS README.SysInfo
+}
+
+pkg_postinst() {
+ einfo "If you use a newer Ipod like the Ipod classic, make sure to read"
+ einfo "the information in README.SysInfo in /usr/share/doc/${P}"
+ einfo "This is no needed if HAL is installed and works correctly."
+}