summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-06-01 23:12:45 +0000
committerTim Harder <radhermit@gentoo.org>2013-06-01 23:12:45 +0000
commita61963faf78ed229bdadd01a6ad1b6d26a05f4ad (patch)
tree7370a739646ff4831b22166ce92068cb5beb05f7 /media-libs/liblo
parentRevision bump: EAPI 5, fix minor QA issues, set proper prefix, wrt bug #45344... (diff)
downloadgentoo-2-a61963faf78ed229bdadd01a6ad1b6d26a05f4ad.tar.gz
gentoo-2-a61963faf78ed229bdadd01a6ad1b6d26a05f4ad.tar.bz2
gentoo-2-a61963faf78ed229bdadd01a6ad1b6d26a05f4ad.zip
Skip more examples when threads are disabled and don't build examples by default (fixes bug #472036).
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'media-libs/liblo')
-rw-r--r--media-libs/liblo/ChangeLog7
-rw-r--r--media-libs/liblo/files/liblo-0.27-no-threads.patch15
-rw-r--r--media-libs/liblo/liblo-0.27.ebuild13
3 files changed, 32 insertions, 3 deletions
diff --git a/media-libs/liblo/ChangeLog b/media-libs/liblo/ChangeLog
index fdca9d7421e9..35a3b548fd91 100644
--- a/media-libs/liblo/ChangeLog
+++ b/media-libs/liblo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/liblo
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/liblo/ChangeLog,v 1.25 2013/06/01 08:15:44 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/liblo/ChangeLog,v 1.26 2013/06/01 23:12:45 radhermit Exp $
+
+ 01 Jun 2013; Tim Harder <radhermit@gentoo.org> liblo-0.27.ebuild,
+ +files/liblo-0.27-no-threads.patch:
+ Skip more examples when threads are disabled and don't build examples by
+ default (fixes bug #472036).
*liblo-0.27 (01 Jun 2013)
diff --git a/media-libs/liblo/files/liblo-0.27-no-threads.patch b/media-libs/liblo/files/liblo-0.27-no-threads.patch
new file mode 100644
index 000000000000..5e3ebe8e43a0
--- /dev/null
+++ b/media-libs/liblo/files/liblo-0.27-no-threads.patch
@@ -0,0 +1,15 @@
+--- liblo-0.27/examples/Makefile.am
++++ liblo-0.27/examples/Makefile.am
+@@ -3,10 +3,9 @@
+ # Example server depends on server threads, so skip it if threads are
+ # disabled.
+
+-noinst_PROGRAMS = example_client nonblocking_server_example \
+- example_tcp_echo_server
++noinst_PROGRAMS = example_client nonblocking_server_example
+ if ENABLE_THREADS
+-noinst_PROGRAMS += example_server
++noinst_PROGRAMS += example_server example_tcp_echo_server
+ endif
+
+ AM_CFLAGS = -Wall -I@top_srcdir@
diff --git a/media-libs/liblo/liblo-0.27.ebuild b/media-libs/liblo/liblo-0.27.ebuild
index 57721e48e28b..11865b358c91 100644
--- a/media-libs/liblo/liblo-0.27.ebuild
+++ b/media-libs/liblo/liblo-0.27.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/liblo/liblo-0.27.ebuild,v 1.1 2013/06/01 08:15:44 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/liblo/liblo-0.27.ebuild,v 1.2 2013/06/01 23:12:45 radhermit Exp $
EAPI=5
-inherit eutils
+inherit eutils autotools
DESCRIPTION="Lightweight OSC (Open Sound Control) implementation"
HOMEPAGE="http://plugin.org.uk/liblo"
@@ -18,6 +18,15 @@ RESTRICT="test"
DEPEND="doc? ( app-doc/doxygen )"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-no-threads.patch
+
+ # don't build examples by default
+ sed -i '/^SUBDIRS =/s/examples//' Makefile.am || die
+
+ eautoreconf
+}
+
src_configure() {
use doc || export ac_cv_prog_HAVE_DOXYGEN=false