summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Hildebrand <zypher@gentoo.org>2004-04-08 12:12:32 +0000
committerMarc Hildebrand <zypher@gentoo.org>2004-04-08 12:12:32 +0000
commit0d28f63b5a46e381e0942212dd5b3754a1ecd8e0 (patch)
tree4ef81f3ad21089a2bae2205f4682dacfea3de444 /media-libs/libmustux
parentversion bump, bug #47082, mark 1.10.18.1 x86 (Manifest recommit) (diff)
downloadgentoo-2-0d28f63b5a46e381e0942212dd5b3754a1ecd8e0.tar.gz
gentoo-2-0d28f63b5a46e381e0942212dd5b3754a1ecd8e0.tar.bz2
gentoo-2-0d28f63b5a46e381e0942212dd5b3754a1ecd8e0.zip
Version bump
Diffstat (limited to 'media-libs/libmustux')
-rw-r--r--media-libs/libmustux/libmustux-0.20.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-libs/libmustux/libmustux-0.20.1.ebuild b/media-libs/libmustux/libmustux-0.20.1.ebuild
new file mode 100644
index 000000000000..7f37873f1785
--- /dev/null
+++ b/media-libs/libmustux/libmustux-0.20.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmustux/libmustux-0.20.1.ebuild,v 1.1 2004/04/08 12:12:32 zypher Exp $
+
+inherit kde-functions
+
+DESCRIPTION="Protux - Libary"
+HOMEPAGE="http://www.nognu.org/protux"
+SRC_URI="http://savannah.nongnu.org/download/protux/${P}.tar.gz"
+
+IUSE="static"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+DEPEND="virtual/x11
+ >=x11-libs/qt-3
+ media-libs/alsa-lib"
+
+set-qtdir 3
+
+src_compile() {
+ export QT_MOC=${QTDIR}/bin/moc
+ local myconf
+ myconf="--with-gnu-ld"
+ use static || myconf="${myconf} --enable-static=no"
+ econf ${myconf} || die "configure failed"
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYRIGHT ChangeLog NEWS README TODO
+}