summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-05-12 15:56:05 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-05-12 15:56:05 +0000
commit279da3918699f71fa55559d92829e48b169dba83 (patch)
tree5efcbb60d9b2f62fb88921e9d93627971e254a78 /media-libs/libsdl2
parentbump; drop pypy2_0 py2.6 add py3 support (diff)
downloadgentoo-2-279da3918699f71fa55559d92829e48b169dba83.tar.gz
gentoo-2-279da3918699f71fa55559d92829e48b169dba83.tar.bz2
gentoo-2-279da3918699f71fa55559d92829e48b169dba83.zip
version bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
Diffstat (limited to 'media-libs/libsdl2')
-rw-r--r--media-libs/libsdl2/ChangeLog8
-rw-r--r--media-libs/libsdl2/files/libsdl2-2.0.3-static-libs.patch89
-rw-r--r--media-libs/libsdl2/libsdl2-2.0.3.ebuild147
3 files changed, 243 insertions, 1 deletions
diff --git a/media-libs/libsdl2/ChangeLog b/media-libs/libsdl2/ChangeLog
index 05809352277c..1458f95d7434 100644
--- a/media-libs/libsdl2/ChangeLog
+++ b/media-libs/libsdl2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/libsdl2
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl2/ChangeLog,v 1.15 2014/05/10 16:46:06 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl2/ChangeLog,v 1.16 2014/05/12 15:56:05 hasufell Exp $
+
+*libsdl2-2.0.3 (12 May 2014)
+
+ 12 May 2014; Julian Ospald <hasufell@gentoo.org> +libsdl2-2.0.3.ebuild,
+ +files/libsdl2-2.0.3-static-libs.patch:
+ version bump
10 May 2014; Julian Ospald <hasufell@gentoo.org> libsdl2-2.0.2-r1.ebuild:
add wayland support wrt #504136
diff --git a/media-libs/libsdl2/files/libsdl2-2.0.3-static-libs.patch b/media-libs/libsdl2/files/libsdl2-2.0.3-static-libs.patch
new file mode 100644
index 000000000000..e4823e1b0531
--- /dev/null
+++ b/media-libs/libsdl2/files/libsdl2-2.0.3-static-libs.patch
@@ -0,0 +1,89 @@
+--- SDL2-2.0.2.orig/Makefile.in
++++ SDL2-2.0.2/Makefile.in
+@@ -33,10 +33,10 @@
+ OBJECTS = @OBJECTS@
+ VERSION_OBJECTS = @VERSION_OBJECTS@
+
+-SDLMAIN_TARGET = libSDL2main.a
++SDLMAIN_TARGET = libSDL2main.la
+ SDLMAIN_OBJECTS = @SDLMAIN_OBJECTS@
+
+-SDLTEST_TARGET = libSDL2_test.a
++SDLTEST_TARGET = libSDL2_test.la
+ SDLTEST_OBJECTS = @SDLTEST_OBJECTS@
+
+ SRC_DIST = *.txt acinclude Android.mk autogen.sh android-project build-scripts cmake configure configure.in debian include Makefile.* sdl2-config.in sdl2.m4 sdl2.pc.in SDL2.spec.in src test VisualC.html VisualC Xcode Xcode-iOS
+@@ -123,15 +123,13 @@
+ .PHONY: all update-revision install install-bin install-hdrs install-lib install-data uninstall uninstall-bin uninstall-hdrs uninstall-lib uninstall-data clean distclean dist $(OBJECTS:.lo=.d)
+
+ $(objects)/$(TARGET): $(OBJECTS) $(VERSION_OBJECTS)
+- $(LIBTOOL) --mode=link $(CC) -o $@ $(OBJECTS) $(VERSION_OBJECTS) $(LDFLAGS) $(EXTRA_LDFLAGS) $(LT_LDFLAGS)
++ $(LIBTOOL) --mode=link $(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS) $(EXTRA_LDFLAGS) $(LT_LDFLAGS)
+
+ $(objects)/$(SDLMAIN_TARGET): $(SDLMAIN_OBJECTS)
+- $(AR) cru $@ $(SDLMAIN_OBJECTS)
+- $(RANLIB) $@
++ $(LIBTOOL) --mode=link $(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS) $(EXTRA_LDFLAGS) $(LT_LDFLAGS) -all-static
+
+ $(objects)/$(SDLTEST_TARGET): $(SDLTEST_OBJECTS)
+- $(AR) cru $@ $(SDLTEST_OBJECTS)
+- $(RANLIB) $@
++ $(LIBTOOL) --mode=link $(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS) $(EXTRA_LDFLAGS) $(LT_LDFLAGS) -all-static
+
+ install: all install-bin install-hdrs install-lib install-data
+ install-bin:
+@@ -152,10 +150,8 @@
+ install-lib: $(objects) $(objects)/$(TARGET) $(objects)/$(SDLMAIN_TARGET) $(objects)/$(SDLTEST_TARGET)
+ $(SHELL) $(auxdir)/mkinstalldirs $(DESTDIR)$(libdir)
+ $(LIBTOOL) --mode=install $(INSTALL) $(objects)/$(TARGET) $(DESTDIR)$(libdir)/$(TARGET)
+- $(INSTALL) -m 644 $(objects)/$(SDLMAIN_TARGET) $(DESTDIR)$(libdir)/$(SDLMAIN_TARGET)
+- $(RANLIB) $(DESTDIR)$(libdir)/$(SDLMAIN_TARGET)
+- $(INSTALL) -m 644 $(objects)/$(SDLTEST_TARGET) $(DESTDIR)$(libdir)/$(SDLTEST_TARGET)
+- $(RANLIB) $(DESTDIR)$(libdir)/$(SDLTEST_TARGET)
++ $(LIBTOOL) --mode=install $(INSTALL) -m 644 $(objects)/$(SDLMAIN_TARGET) $(DESTDIR)$(libdir)/$(SDLMAIN_TARGET)
++ $(LIBTOOL) --mode=install $(INSTALL) -m 644 $(objects)/$(SDLTEST_TARGET) $(DESTDIR)$(libdir)/$(SDLTEST_TARGET)
+ install-data:
+ $(SHELL) $(auxdir)/mkinstalldirs $(DESTDIR)$(datadir)/aclocal
+ $(INSTALL) -m 644 $(srcdir)/sdl2.m4 $(DESTDIR)$(datadir)/aclocal/sdl2.m4
+--- SDL2-2.0.2.orig/configure.in
++++ SDL2-2.0.2/configure.in
+@@ -2858,7 +2858,7 @@
+ if test -f /lib/w32api/libuuid.a; then
+ LIBUUID=/lib/w32api/libuuid.a
+ else
+- LIBUUID=-luuid
++ LIBUUID=-Wl,-luuid
+ fi
+ EXTRA_LDFLAGS="$EXTRA_LDFLAGS -luser32 -lgdi32 -lwinmm -limm32 -lole32 -loleaut32 -lshell32 -lversion $LIBUUID -XCClinker -static-libgcc"
+ # The Windows platform requires special setup
+@@ -3132,23 +3132,23 @@
+
+ VERSION_OBJECTS=`echo $VERSION_SOURCES`
+ VERSION_DEPENDS=`echo $VERSION_SOURCES`
+-VERSION_OBJECTS=`echo "$VERSION_OBJECTS" | sed 's,[[^ ]]*/\([[^ ]]*\)\.rc,$(objects)/\1.o,g'`
++VERSION_OBJECTS=`echo "$VERSION_OBJECTS" | sed 's,[[^ ]]*/\([[^ ]]*\)\.rc,$(objects)/\1.lo,g'`
+ VERSION_DEPENDS=`echo "$VERSION_DEPENDS" | sed "s,\\([[^ ]]*\\)/\\([[^ ]]*\\)\\.rc,\\\\
+-\\$(objects)/\\2.o: \\1/\\2.rc\\\\
+- \\$(WINDRES) \\$< \\$@,g"`
++\\$(objects)/\\2.lo: \\1/\\2.rc\\\\
++ \\$(LIBTOOL) --mode=compile --tag=RC \\$(WINDRES) -i \\$< -o \\$@,g"`
+
+ SDLMAIN_OBJECTS=`echo $SDLMAIN_SOURCES`
+ SDLMAIN_DEPENDS=`echo $SDLMAIN_SOURCES`
+-SDLMAIN_OBJECTS=`echo "$SDLMAIN_OBJECTS" | sed 's,[[^ ]]*/\([[^ ]]*\)\.c,$(objects)/\1.o,g'`
++SDLMAIN_OBJECTS=`echo "$SDLMAIN_OBJECTS" | sed 's,[[^ ]]*/\([[^ ]]*\)\.c,$(objects)/\1.lo,g'`
+ SDLMAIN_DEPENDS=`echo "$SDLMAIN_DEPENDS" | sed "s,\\([[^ ]]*\\)/\\([[^ ]]*\\)\\.c,\\\\
+-\\$(objects)/\\2.o: \\1/\\2.c\\\\
++\\$(objects)/\\2.lo: \\1/\\2.c\\\\
+ \\$(LIBTOOL) --mode=compile \\$(CC) \\$(CFLAGS) \\$(EXTRA_CFLAGS) $DEPENDENCY_TRACKING_OPTIONS -c \\$< -o \\$@,g"`
+
+ SDLTEST_OBJECTS=`echo $SDLTEST_SOURCES`
+ SDLTEST_DEPENDS=`echo $SDLTEST_SOURCES`
+-SDLTEST_OBJECTS=`echo "$SDLTEST_OBJECTS" | sed 's,[[^ ]]*/\([[^ ]]*\)\.c,$(objects)/\1.o,g'`
++SDLTEST_OBJECTS=`echo "$SDLTEST_OBJECTS" | sed 's,[[^ ]]*/\([[^ ]]*\)\.c,$(objects)/\1.lo,g'`
+ SDLTEST_DEPENDS=`echo "$SDLTEST_DEPENDS" | sed "s,\\([[^ ]]*\\)/\\([[^ ]]*\\)\\.c,\\\\
+-\\$(objects)/\\2.o: \\1/\\2.c\\\\
++\\$(objects)/\\2.lo: \\1/\\2.c\\\\
+ \\$(LIBTOOL) --mode=compile \\$(CC) \\$(CFLAGS) \\$(EXTRA_CFLAGS) $DEPENDENCY_TRACKING_OPTIONS -c \\$< -o \\$@,g"`
+
+ # Set runtime shared library paths as needed
diff --git a/media-libs/libsdl2/libsdl2-2.0.3.ebuild b/media-libs/libsdl2/libsdl2-2.0.3.ebuild
new file mode 100644
index 000000000000..0af84b4d026d
--- /dev/null
+++ b/media-libs/libsdl2/libsdl2-2.0.3.ebuild
@@ -0,0 +1,147 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl2/libsdl2-2.0.3.ebuild,v 1.1 2014/05/12 15:56:05 hasufell Exp $
+
+# TODO: convert FusionSound #484250
+
+EAPI=5
+inherit autotools flag-o-matic toolchain-funcs eutils multilib-minimal
+
+MY_P=SDL2-${PV}
+DESCRIPTION="Simple Direct Media Layer"
+HOMEPAGE="http://www.libsdl.org"
+SRC_URI="http://www.libsdl.org/release/${MY_P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="3dnow alsa altivec +audio custom-cflags dbus fusionsound gles haptic +joystick mmx nas opengl oss pulseaudio sse sse2 static-libs +threads tslib udev +video wayland X xinerama xscreensaver"
+REQUIRED_USE="
+ alsa? ( audio )
+ fusionsound? ( audio )
+ gles? ( video )
+ nas? ( audio )
+ opengl? ( video )
+ pulseaudio? ( audio )
+ xinerama? ( X )
+ xscreensaver? ( X )"
+
+RDEPEND="
+ alsa? ( media-libs/alsa-lib[${MULTILIB_USEDEP}] )
+ dbus? ( sys-apps/dbus[${MULTILIB_USEDEP}] )
+ fusionsound? ( || ( >=media-libs/FusionSound-1.1.1 >=dev-libs/DirectFB-1.7.1[fusionsound] ) )
+ gles? ( media-libs/mesa[${MULTILIB_USEDEP},gles2] )
+ nas? ( media-libs/nas[${MULTILIB_USEDEP}] )
+ opengl? (
+ virtual/opengl[${MULTILIB_USEDEP}]
+ virtual/glu[${MULTILIB_USEDEP}]
+ )
+ pulseaudio? ( media-sound/pulseaudio[${MULTILIB_USEDEP}] )
+ tslib? ( x11-libs/tslib[${MULTILIB_USEDEP}] )
+ udev? ( virtual/udev[${MULTILIB_USEDEP}] )
+ wayland? (
+ dev-libs/wayland[${MULTILIB_USEDEP}]
+ media-libs/mesa[${MULTILIB_USEDEP},wayland]
+ x11-libs/libxkbcommon[${MULTILIB_USEDEP}]
+ )
+ X? (
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXcursor[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXi[${MULTILIB_USEDEP}]
+ x11-libs/libXrandr[${MULTILIB_USEDEP}]
+ x11-libs/libXt[${MULTILIB_USEDEP}]
+ x11-libs/libXxf86vm[${MULTILIB_USEDEP}]
+ xinerama? ( x11-libs/libXinerama[${MULTILIB_USEDEP}] )
+ xscreensaver? ( x11-libs/libXScrnSaver[${MULTILIB_USEDEP}] )
+ )"
+DEPEND="${RDEPEND}
+ X? (
+ x11-proto/xextproto[${MULTILIB_USEDEP}]
+ x11-proto/xproto[${MULTILIB_USEDEP}]
+ )
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ # https://bugzilla.libsdl.org/show_bug.cgi?id=1431
+ epatch "${FILESDIR}"/${P}-static-libs.patch
+ AT_M4DIR="/usr/share/aclocal acinclude" eautoreconf
+}
+
+multilib_src_configure() {
+ use custom-cflags || strip-flags
+
+ # sorted by `./configure --help`
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable static-libs static) \
+ $(use_enable audio) \
+ $(use_enable video) \
+ --enable-render \
+ --enable-events \
+ $(use_enable joystick) \
+ $(use_enable haptic) \
+ --enable-power \
+ $(use_enable threads) \
+ --enable-timers \
+ --enable-file \
+ --disable-loadso \
+ --enable-cpuinfo \
+ --enable-atomic \
+ --enable-assembly \
+ $(use_enable sse ssemath) \
+ $(use_enable mmx) \
+ $(use_enable 3dnow) \
+ $(use_enable sse) \
+ $(use_enable sse2) \
+ $(use_enable altivec) \
+ $(use_enable oss) \
+ $(use_enable alsa) \
+ --disable-alsa-shared \
+ --disable-esd \
+ $(use_enable pulseaudio) \
+ --disable-pulseaudio-shared \
+ --disable-arts \
+ $(use_enable nas) \
+ --disable-nas-shared \
+ --disable-sndio \
+ --disable-sndio-shared \
+ $(use_enable audio diskaudio) \
+ $(use_enable audio dummyaudio) \
+ $(use_enable X video-x11) \
+ --disable-x11-shared \
+ $(use_enable wayland video-wayland) \
+ --disable-wayland-shared \
+ $(use_enable X video-x11-xcursor) \
+ $(use_enable xinerama video-x11-xinerama) \
+ $(use_enable X video-x11-xinput) \
+ $(use_enable X video-x11-xrandr) \
+ $(use_enable xscreensaver video-x11-scrnsaver) \
+ $(use_enable X video-x11-xshape) \
+ $(use_enable X video-x11-vm) \
+ --disable-video-cocoa \
+ --disable-video-directfb \
+ $(multilib_native_use_enable fusionsound) \
+ --disable-fusionsound-shared \
+ $(use_enable video video-dummy) \
+ $(use_enable opengl video-opengl) \
+ $(use_enable gles video-opengles) \
+ $(use_enable udev libudev) \
+ $(use_enable dbus) \
+ $(use_enable tslib input-tslib) \
+ --disable-directx \
+ --disable-rpath \
+ --disable-render-d3d \
+ $(use_with X x)
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+}
+
+multilib_src_install_all() {
+ use static-libs || prune_libtool_files
+ dodoc {BUGS,CREDITS,README,README-SDL,README-hg,TODO,WhatsNew}.txt
+}