summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-04-18 17:05:02 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-04-18 17:05:02 +0000
commit9cf46aa0e5421d7f453442f29417555e8f11f67f (patch)
tree15d476bac1ac0f47002f45dbf6f09bef1daa5e23 /media-libs/libsdl2
parentmask >=media-libs/libsdl2-2.0.2-r1 for multilib migration wrt #484130 (diff)
downloadgentoo-2-9cf46aa0e5421d7f453442f29417555e8f11f67f.tar.gz
gentoo-2-9cf46aa0e5421d7f453442f29417555e8f11f67f.tar.bz2
gentoo-2-9cf46aa0e5421d7f453442f29417555e8f11f67f.zip
add multilib support wrt #484130
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
Diffstat (limited to 'media-libs/libsdl2')
-rw-r--r--media-libs/libsdl2/ChangeLog7
-rw-r--r--media-libs/libsdl2/libsdl2-2.0.2-r1.ebuild140
2 files changed, 146 insertions, 1 deletions
diff --git a/media-libs/libsdl2/ChangeLog b/media-libs/libsdl2/ChangeLog
index e14d127385ba..bd3d80b9e017 100644
--- a/media-libs/libsdl2/ChangeLog
+++ b/media-libs/libsdl2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/libsdl2
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl2/ChangeLog,v 1.11 2014/04/05 15:59:09 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl2/ChangeLog,v 1.12 2014/04/18 17:05:02 hasufell Exp $
+
+*libsdl2-2.0.2-r1 (18 Apr 2014)
+
+ 18 Apr 2014; Julian Ospald <hasufell@gentoo.org> +libsdl2-2.0.2-r1.ebuild:
+ add multilib support wrt #484130
05 Apr 2014; Julian Ospald <hasufell@gentoo.org> libsdl2-2.0.1-r1.ebuild,
libsdl2-2.0.2.ebuild:
diff --git a/media-libs/libsdl2/libsdl2-2.0.2-r1.ebuild b/media-libs/libsdl2/libsdl2-2.0.2-r1.ebuild
new file mode 100644
index 000000000000..0362d8de900d
--- /dev/null
+++ b/media-libs/libsdl2/libsdl2-2.0.2-r1.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl2/libsdl2-2.0.2-r1.ebuild,v 1.1 2014/04/18 17:05:02 hasufell Exp $
+
+# TODO: convert FusionSound #484250
+
+EAPI=5
+inherit autotools flag-o-matic toolchain-funcs eutils multilib-minimal
+
+MY_P=SDL2-${PV}
+DESCRIPTION="Simple Direct Media Layer"
+HOMEPAGE="http://www.libsdl.org"
+SRC_URI="http://www.libsdl.org/release/${MY_P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="3dnow alsa altivec +audio custom-cflags dbus fusionsound gles haptic +joystick mmx nas opengl oss pulseaudio sse sse2 static-libs +threads tslib udev +video X xinerama xscreensaver"
+REQUIRED_USE="
+ alsa? ( audio )
+ fusionsound? ( audio )
+ gles? ( video )
+ nas? ( audio )
+ opengl? ( video )
+ pulseaudio? ( audio )
+ xinerama? ( X )
+ xscreensaver? ( X )"
+
+RDEPEND="
+ alsa? ( media-libs/alsa-lib[${MULTILIB_USEDEP}] )
+ dbus? ( sys-apps/dbus )
+ fusionsound? ( || ( >=media-libs/FusionSound-1.1.1 >=dev-libs/DirectFB-1.7.1[fusionsound] ) )
+ gles? ( media-libs/mesa[${MULTILIB_USEDEP},gles2] )
+ nas? ( media-libs/nas[${MULTILIB_USEDEP}] )
+ opengl? (
+ virtual/opengl[${MULTILIB_USEDEP}]
+ virtual/glu[${MULTILIB_USEDEP}]
+ )
+ pulseaudio? ( media-sound/pulseaudio[${MULTILIB_USEDEP}] )
+ tslib? ( x11-libs/tslib[${MULTILIB_USEDEP}] )
+ udev? ( virtual/udev[${MULTILIB_USEDEP}] )
+ X? (
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXcursor[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXi[${MULTILIB_USEDEP}]
+ x11-libs/libXrandr[${MULTILIB_USEDEP}]
+ x11-libs/libXt[${MULTILIB_USEDEP}]
+ x11-libs/libXxf86vm[${MULTILIB_USEDEP}]
+ xinerama? ( x11-libs/libXinerama[${MULTILIB_USEDEP}] )
+ xscreensaver? ( x11-libs/libXScrnSaver[${MULTILIB_USEDEP}] )
+ )"
+DEPEND="${RDEPEND}
+ X? (
+ x11-proto/xextproto[${MULTILIB_USEDEP}]
+ x11-proto/xproto[${MULTILIB_USEDEP}]
+ )
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ # https://bugzilla.libsdl.org/show_bug.cgi?id=1431
+ epatch "${FILESDIR}"/${P}-static-libs.patch
+ AT_M4DIR="/usr/share/aclocal acinclude" eautoreconf
+}
+
+multilib_src_configure() {
+ use custom-cflags || strip-flags
+
+ # sorted by `./configure --help`
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable static-libs static) \
+ $(use_enable audio) \
+ $(use_enable video) \
+ --enable-render \
+ --enable-events \
+ $(use_enable joystick) \
+ $(use_enable haptic) \
+ --enable-power \
+ $(use_enable threads) \
+ --enable-timers \
+ --enable-file \
+ --disable-loadso \
+ --enable-cpuinfo \
+ --enable-atomic \
+ --enable-assembly \
+ $(use_enable sse ssemath) \
+ $(use_enable mmx) \
+ $(use_enable 3dnow) \
+ $(use_enable sse) \
+ $(use_enable sse2) \
+ $(use_enable altivec) \
+ $(use_enable oss) \
+ $(use_enable alsa) \
+ --disable-alsa-shared \
+ --disable-esd \
+ $(use_enable pulseaudio) \
+ --disable-pulseaudio-shared \
+ --disable-arts \
+ $(use_enable nas) \
+ --disable-nas-shared \
+ --disable-sndio \
+ --disable-sndio-shared \
+ $(use_enable audio diskaudio) \
+ $(use_enable audio dummyaudio) \
+ $(use_enable X video-x11) \
+ --disable-x11-shared \
+ $(use_enable X video-x11-xcursor) \
+ $(use_enable xinerama video-x11-xinerama) \
+ $(use_enable X video-x11-xinput) \
+ $(use_enable X video-x11-xrandr) \
+ $(use_enable xscreensaver video-x11-scrnsaver) \
+ $(use_enable X video-x11-xshape) \
+ $(use_enable X video-x11-vm) \
+ --disable-video-cocoa \
+ --disable-video-directfb \
+ $(multilib_is_native_abi && use_enable fusionsound || echo "--disable-fusionsound") \
+ --disable-fusionsound-shared \
+ $(use_enable video video-dummy) \
+ $(use_enable opengl video-opengl) \
+ $(use_enable gles video-opengles) \
+ $(use_enable udev libudev) \
+ $(use_enable dbus) \
+ $(use_enable tslib input-tslib) \
+ --disable-directx \
+ --disable-rpath \
+ --disable-render-d3d \
+ $(use_with X x)
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+}
+
+multilib_src_install_all() {
+ use static-libs || prune_libtool_files
+ dodoc {BUGS,CREDITS,README,README-SDL,README-hg,TODO,WhatsNew}.txt
+}