summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-07-31 17:35:07 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-07-31 17:35:07 +0000
commit31a105c8e342f2bfe4140060ef7871bb6a708a39 (patch)
tree9787783824a133de45158ca174fe06869c39b60a /media-libs/libshout/libshout-2.3.1-r1.ebuild
parentconvert to multilib and stack it for medialibs -r7 (diff)
downloadgentoo-2-31a105c8e342f2bfe4140060ef7871bb6a708a39.tar.gz
gentoo-2-31a105c8e342f2bfe4140060ef7871bb6a708a39.tar.bz2
gentoo-2-31a105c8e342f2bfe4140060ef7871bb6a708a39.zip
convert to multilib and stack it for medialibs r7
(Portage version: 2.2.0_alpha191/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-libs/libshout/libshout-2.3.1-r1.ebuild')
-rw-r--r--media-libs/libshout/libshout-2.3.1-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-libs/libshout/libshout-2.3.1-r1.ebuild b/media-libs/libshout/libshout-2.3.1-r1.ebuild
new file mode 100644
index 000000000000..6f9feac8da4f
--- /dev/null
+++ b/media-libs/libshout/libshout-2.3.1-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libshout/libshout-2.3.1-r1.ebuild,v 1.1 2013/07/31 17:35:07 aballier Exp $
+
+EAPI=5
+inherit eutils multilib-minimal
+
+DESCRIPTION="library for connecting and sending data to icecast servers"
+HOMEPAGE="http://www.icecast.org/"
+SRC_URI="http://downloads.xiph.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="speex static-libs theora"
+
+RDEPEND="media-libs/libogg[${MULTILIB_USEDEP}]
+ media-libs/libvorbis[${MULTILIB_USEDEP}]
+ speex? ( media-libs/speex[${MULTILIB_USEDEP}] )
+ theora? ( media-libs/libtheora[${MULTILIB_USEDEP}] )
+ abi_x86_32? ( !<=app-emulation/emul-linux-x86-medialibs-20130224-r6
+ !app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable static-libs static) \
+ $(use_enable theora) \
+ $(use_enable speex)
+}
+
+multilib_src_install_all() {
+ dodoc README examples/example.c
+ rm -rf "${ED}"/usr/share/doc/${PN}
+ prune_libtool_files
+}