summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-29 13:23:23 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-29 13:23:23 +0000
commit7303c088eb3984c4d73c9ae7ce9bbdf2d225b1bc (patch)
tree436962d98694f58de6ef99d036fe2ec7e276b7da /media-libs/libtheora
parentstable amd64, bug 282918 (diff)
downloadgentoo-2-7303c088eb3984c4d73c9ae7ce9bbdf2d225b1bc.tar.gz
gentoo-2-7303c088eb3984c4d73c9ae7ce9bbdf2d225b1bc.tar.bz2
gentoo-2-7303c088eb3984c4d73c9ae7ce9bbdf2d225b1bc.zip
Fix properly
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libtheora')
-rw-r--r--media-libs/libtheora/ChangeLog6
-rw-r--r--media-libs/libtheora/files/libtheora-1.1_beta3-encoder_disabled.c67
-rw-r--r--media-libs/libtheora/files/libtheora-1.1_beta3-theora_disable_encode.patch15
-rw-r--r--media-libs/libtheora/libtheora-1.1_alpha2.ebuild68
-rw-r--r--media-libs/libtheora/libtheora-1.1_beta3.ebuild6
5 files changed, 73 insertions, 89 deletions
diff --git a/media-libs/libtheora/ChangeLog b/media-libs/libtheora/ChangeLog
index 8fbfe9eaabbd..6e74bccd67f6 100644
--- a/media-libs/libtheora/ChangeLog
+++ b/media-libs/libtheora/ChangeLog
@@ -1,10 +1,10 @@
# ChangeLog for media-libs/libtheora
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/ChangeLog,v 1.95 2009/08/27 16:49:13 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/ChangeLog,v 1.96 2009/08/29 13:23:22 ssuominen Exp $
- 27 Aug 2009; Samuli Suominen <ssuominen@gentoo.org>
+ 29 Aug 2009; Samuli Suominen <ssuominen@gentoo.org>
libtheora-1.1_beta3.ebuild,
- +files/libtheora-1.1_beta3-theora_disable_encode.patch:
+ +files/libtheora-1.1_beta3-encoder_disabled.c:
Fix building with USE="-encode".
*libtheora-1.1_beta3 (27 Aug 2009)
diff --git a/media-libs/libtheora/files/libtheora-1.1_beta3-encoder_disabled.c b/media-libs/libtheora/files/libtheora-1.1_beta3-encoder_disabled.c
new file mode 100644
index 000000000000..547d1e47884c
--- /dev/null
+++ b/media-libs/libtheora/files/libtheora-1.1_beta3-encoder_disabled.c
@@ -0,0 +1,67 @@
+/********************************************************************
+ * *
+ * THIS FILE IS PART OF THE OggTheora SOFTWARE CODEC SOURCE CODE. *
+ * USE, DISTRIBUTION AND REPRODUCTION OF THIS LIBRARY SOURCE IS *
+ * GOVERNED BY A BSD-STYLE SOURCE LICENSE INCLUDED WITH THIS SOURCE *
+ * IN 'COPYING'. PLEASE READ THESE TERMS BEFORE DISTRIBUTING. *
+ * *
+ * THE Theora SOURCE CODE IS COPYRIGHT (C) 2002-2009 *
+ * by the Xiph.Org Foundation http://www.xiph.org/ *
+ * *
+ ********************************************************************
+
+ function:
+ last mod: $Id: libtheora-1.1_beta3-encoder_disabled.c,v 1.1 2009/08/29 13:23:23 ssuominen Exp $
+
+ ********************************************************************/
+#include "apiwrapper.h"
+#include "encint.h"
+
+th_enc_ctx *th_encode_alloc(const th_info *_info){
+ return NULL;
+}
+
+void th_encode_free(th_enc_ctx *_enc){}
+
+
+int th_encode_ctl(th_enc_ctx *_enc,int _req,void *_buf,size_t _buf_sz){
+ return OC_DISABLED;
+}
+
+int th_encode_flushheader(th_enc_ctx *_enc,th_comment *_tc,ogg_packet *_op){
+ return OC_DISABLED;
+}
+
+int th_encode_ycbcr_in(th_enc_ctx *_enc,th_ycbcr_buffer _img){
+ return OC_DISABLED;
+}
+
+int th_encode_packetout(th_enc_ctx *_enc,int _last_p,ogg_packet *_op){
+ return OC_DISABLED;
+}
+
+
+
+int theora_encode_init(theora_state *_te,theora_info *_ci){
+ return OC_DISABLED;
+}
+
+int theora_encode_YUVin(theora_state *_te,yuv_buffer *_yuv){
+ return OC_DISABLED;
+}
+
+int theora_encode_packetout(theora_state *_te,int _last_p,ogg_packet *_op){
+ return OC_DISABLED;
+}
+
+int theora_encode_header(theora_state *_te,ogg_packet *_op){
+ return OC_DISABLED;
+}
+
+int theora_encode_comment(theora_comment *_tc,ogg_packet *_op){
+ return OC_DISABLED;
+}
+
+int theora_encode_tables(theora_state *_te,ogg_packet *_op){
+ return OC_DISABLED;
+}
diff --git a/media-libs/libtheora/files/libtheora-1.1_beta3-theora_disable_encode.patch b/media-libs/libtheora/files/libtheora-1.1_beta3-theora_disable_encode.patch
deleted file mode 100644
index 310e572bd4f8..000000000000
--- a/media-libs/libtheora/files/libtheora-1.1_beta3-theora_disable_encode.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff -ur libtheora-1.1beta3.orig/lib/Makefile.am libtheora-1.1beta3/lib/Makefile.am
---- libtheora-1.1beta3.orig/lib/Makefile.am 2009-08-06 04:43:12.000000000 +0300
-+++ libtheora-1.1beta3/lib/Makefile.am 2009-08-27 19:51:51.000000000 +0300
-@@ -17,7 +17,11 @@
- x86/x86state.c \
- x86_vc
-
-+if THEORA_DISABLE_ENCODE
-+lib_LTLIBRARIES = libtheoradec.la libtheora.la
-+else
- lib_LTLIBRARIES = libtheoradec.la libtheoraenc.la libtheora.la
-+endif
-
- if THEORA_DISABLE_ENCODE
- encoder_uniq_sources = \
diff --git a/media-libs/libtheora/libtheora-1.1_alpha2.ebuild b/media-libs/libtheora/libtheora-1.1_alpha2.ebuild
deleted file mode 100644
index 508f70c75c34..000000000000
--- a/media-libs/libtheora/libtheora-1.1_alpha2.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/libtheora-1.1_alpha2.ebuild,v 1.2 2009/06/21 03:37:29 ssuominen Exp $
-
-EAPI=2
-inherit autotools eutils flag-o-matic
-
-DESCRIPTION="The Theora Video Compression Codec"
-HOMEPAGE="http://www.theora.org"
-SRC_URI="http://downloads.xiph.org/releases/theora/${P/_}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="doc encode examples"
-
-RDEPEND="media-libs/libogg
- encode? ( media-libs/libvorbis )
- examples? ( media-libs/libpng
- media-libs/libvorbis
- media-libs/libsdl )"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )
- dev-util/pkgconfig"
-
-VARTEXFONTS=${T}/fonts
-S=${WORKDIR}/${P/_}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.0_beta2-flags.patch
- AT_M4DIR="m4" eautoreconf
-}
-
-src_configure() {
- use x86 && filter-flags -fforce-addr -frename-registers #200549
- use doc || export ac_cv_prog_HAVE_DOXYGEN="false"
-
- local myconf
- use examples && myconf="--enable-encode"
-
- # --disable-spec because LaTeX documentation has been prebuilt
- econf \
- --disable-dependency-tracking \
- --disable-spec \
- $(use_enable encode) \
- $(use_enable examples) \
- ${myconf}
-}
-
-src_install() {
- emake DESTDIR="${D}" docdir=/usr/share/doc/${PF} \
- install || die "emake install failed"
-
- dodoc AUTHORS CHANGES README
- prepalldocs
-
- if use examples; then
- if use doc; then
- insinto /usr/share/doc/${PF}/examples
- doins examples/*.[ch]
- fi
-
- dobin examples/.libs/png2theora || die "dobin failed"
- for bin in dump_{psnr,video} {encoder,player}_example; do
- newbin examples/.libs/${bin} theora_${bin} || die "newbin failed"
- done
- fi
-}
diff --git a/media-libs/libtheora/libtheora-1.1_beta3.ebuild b/media-libs/libtheora/libtheora-1.1_beta3.ebuild
index 8147c0ce425c..8ac323722cec 100644
--- a/media-libs/libtheora/libtheora-1.1_beta3.ebuild
+++ b/media-libs/libtheora/libtheora-1.1_beta3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/libtheora-1.1_beta3.ebuild,v 1.2 2009/08/27 16:49:13 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/libtheora-1.1_beta3.ebuild,v 1.3 2009/08/29 13:23:22 ssuominen Exp $
EAPI=2
inherit autotools eutils flag-o-matic
@@ -27,8 +27,8 @@ VARTEXFONTS=${T}/fonts
S=${WORKDIR}/${P/_}
src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.0_beta2-flags.patch \
- "${FILESDIR}"/${P}-theora_disable_encode.patch
+ epatch "${FILESDIR}"/${PN}-1.0_beta2-flags.patch
+ cp -f "${FILESDIR}"/${P}-encoder_disabled.c "${S}"/lib/encoder_disabled.c
AT_M4DIR="m4" eautoreconf
}