summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn J. Ellis <jje@gentoo.org>2003-08-05 09:58:13 +0000
committerJohn J. Ellis <jje@gentoo.org>2003-08-05 09:58:13 +0000
commitaa8fafa21682a95e0809d3bdc78c12609fa14aa6 (patch)
treec96e384346b4389b73b4b5779766168fe91345d4 /media-libs/libvorbis/libvorbis-1.0-r3.ebuild
parentAdded simd patch (use sse) ~x86 masked. Closes #21585. (diff)
downloadgentoo-2-aa8fafa21682a95e0809d3bdc78c12609fa14aa6.tar.gz
gentoo-2-aa8fafa21682a95e0809d3bdc78c12609fa14aa6.tar.bz2
gentoo-2-aa8fafa21682a95e0809d3bdc78c12609fa14aa6.zip
Added simd patch (use sse) ~x86 masked. Closes #21585.
Diffstat (limited to 'media-libs/libvorbis/libvorbis-1.0-r3.ebuild')
-rw-r--r--media-libs/libvorbis/libvorbis-1.0-r3.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/media-libs/libvorbis/libvorbis-1.0-r3.ebuild b/media-libs/libvorbis/libvorbis-1.0-r3.ebuild
new file mode 100644
index 000000000000..397c1c4573da
--- /dev/null
+++ b/media-libs/libvorbis/libvorbis-1.0-r3.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libvorbis/libvorbis-1.0-r3.ebuild,v 1.1 2003/08/05 09:58:07 jje Exp $
+
+inherit libtool eutils
+
+S=${WORKDIR}/${P}
+DESCRIPTION="the Ogg Vorbis sound file format library"
+SRC_URI="http://fatpipe.vorbis.com/files/1.0/unix/${P}.tar.gz"
+HOMEPAGE="http://www.xiph.org/ogg/vorbis/index.html"
+
+IUSE="sse"
+DEPEND=">=media-libs/libogg-1.0"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ if [ `use x86` ] ; then
+ use sse && epatch ${FILESDIR}/${PN}-simd.patch
+ fi
+
+ epatch ${FILESDIR}/${PN}-m4.patch || die "Patching failed"
+ # Fix a gcc crash. With the new atexit patch to gcc, it
+ # seems it do not handle -mno-ieee-fp too well.
+ cp configure configure.orig
+ sed -e "s:-mno-ieee-fp::g" \
+ configure.orig >configure
+}
+
+src_compile() {
+ elibtoolize
+
+ #export CFLAGS="${CFLAGS/-march=*/}"
+
+ ./configure --prefix=/usr \
+ --host=${CHOST} || die
+
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ dosym /usr/lib/libvorbisfile.so.3.0.0 /usr/lib/libvorbisfile.so.0
+ dosym /usr/lib/libvorbisenc.so.2.0.0 /usr/lib/libvorbisenc.so.0
+
+ echo "Removing docs installed by make install"
+ rm -rf ${D}/usr/share/doc
+
+ dodoc AUTHORS COPYING README todo.txt
+ docinto txt
+ dodoc doc/*.txt
+ dohtml -r doc
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Note the 1.0 version of libvorbis has been installed"
+ einfo "Applications that used pre-1.0 vorbis libraries will"
+ einfo "need to be recompiled for the new version."
+ einfo "Now that the vorbis folks have finalized the API"
+ einfo "this should be the last time for a while that"
+ einfo "recompilation is needed for these things."
+ einfo
+}
+