summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-06-25 16:37:22 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-06-25 16:37:22 +0000
commit3b07a5caca4500eeb98e1b84bb4c84f179f74dde (patch)
treeeeebb35047b3ff23af84375f4f5a80192dc603d7 /media-libs/libvpx/libvpx-9999.ebuild
parentremove old (diff)
downloadgentoo-2-3b07a5caca4500eeb98e1b84bb4c84f179f74dde.tar.gz
gentoo-2-3b07a5caca4500eeb98e1b84bb4c84f179f74dde.tar.bz2
gentoo-2-3b07a5caca4500eeb98e1b84bb4c84f179f74dde.zip
set AS to yasm based on CHOST which seems to be the sanest to do, bug #345161
(Portage version: 2.2.0_alpha185/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-libs/libvpx/libvpx-9999.ebuild')
-rw-r--r--media-libs/libvpx/libvpx-9999.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/media-libs/libvpx/libvpx-9999.ebuild b/media-libs/libvpx/libvpx-9999.ebuild
index 84cae7ee460c..a76803399b0f 100644
--- a/media-libs/libvpx/libvpx-9999.ebuild
+++ b/media-libs/libvpx/libvpx-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libvpx/libvpx-9999.ebuild,v 1.32 2013/06/25 16:26:41 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libvpx/libvpx-9999.ebuild,v 1.33 2013/06/25 16:37:22 aballier Exp $
EAPI=4
inherit multilib toolchain-funcs flag-o-matic multilib-minimal
@@ -47,11 +47,11 @@ multilib_src_configure() {
# let the build system decide which AS to use (it honours $AS but
# then feeds it with yasm flags without checking...) #345161
- local a
tc-export AS
- for a in {amd64,x86}{,-{fbsd,linux}} ; do
- use ${a} && unset AS
- done
+ case "${CHOST}" in
+ i?86*) export AS=yasm;;
+ x86_64*) export AS=yasm;;
+ esac
# build verbose by default
MAKEOPTS="${MAKEOPTS} verbose=yes"