summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-10-09 19:36:13 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-10-09 19:36:13 +0000
commiteb6eda5350318438cd0032365d75b3ec039557ea (patch)
treeb3bb4f36377ff8fceb3f51ee8702f39b90d2e8f1 /media-libs/mediastreamer
parentadd ncurses useflag (diff)
downloadgentoo-2-eb6eda5350318438cd0032365d75b3ec039557ea.tar.gz
gentoo-2-eb6eda5350318438cd0032365d75b3ec039557ea.tar.bz2
gentoo-2-eb6eda5350318438cd0032365d75b3ec039557ea.zip
fix tests
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'media-libs/mediastreamer')
-rw-r--r--media-libs/mediastreamer/ChangeLog6
-rw-r--r--media-libs/mediastreamer/files/mediastreamer-2.9.0-tests.patch26
-rw-r--r--media-libs/mediastreamer/mediastreamer-2.9.0.ebuild16
3 files changed, 43 insertions, 5 deletions
diff --git a/media-libs/mediastreamer/ChangeLog b/media-libs/mediastreamer/ChangeLog
index 88ed063c845e..b8280fa9c8c7 100644
--- a/media-libs/mediastreamer/ChangeLog
+++ b/media-libs/mediastreamer/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/mediastreamer
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mediastreamer/ChangeLog,v 1.70 2013/10/09 18:52:30 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mediastreamer/ChangeLog,v 1.71 2013/10/09 19:36:13 hasufell Exp $
+
+ 09 Oct 2013; Julian Ospald <hasufell@gentoo.org> mediastreamer-2.9.0.ebuild,
+ +files/mediastreamer-2.9.0-tests.patch:
+ fix tests
*mediastreamer-2.9.0 (09 Oct 2013)
diff --git a/media-libs/mediastreamer/files/mediastreamer-2.9.0-tests.patch b/media-libs/mediastreamer/files/mediastreamer-2.9.0-tests.patch
new file mode 100644
index 000000000000..3bcb8bd36618
--- /dev/null
+++ b/media-libs/mediastreamer/files/mediastreamer-2.9.0-tests.patch
@@ -0,0 +1,26 @@
+From d9f448013bd5ea92ce42c99ef3338932ec694b62 Mon Sep 17 00:00:00 2001
+From: hasufell <hasufell@gentoo.org>
+Date: Wed, 9 Oct 2013 21:18:28 +0200
+Subject: [PATCH] fix tests
+
+---
+ configure.ac | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/configure.ac b/configure.ac
+index 4b923a9..4aec221 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -873,6 +873,9 @@ case "$target_os" in
+ #hack for macport
+ CUNIT_LIBS+=" -lncurses"
+ ;;
++ *linux*)
++ CUNIT_LIBS+=" -lncurses"
++ ;;
+ *mingw*)
+ CPPFLAGS="$CPPFLAGS -D_WIN32_WINNT=0x0501"
+ LIBS="$LIBS -lws2_32 -liphlpapi"
+--
+1.8.3.2
+
diff --git a/media-libs/mediastreamer/mediastreamer-2.9.0.ebuild b/media-libs/mediastreamer/mediastreamer-2.9.0.ebuild
index 890dae0d575e..fcadebf3afc5 100644
--- a/media-libs/mediastreamer/mediastreamer-2.9.0.ebuild
+++ b/media-libs/mediastreamer/mediastreamer-2.9.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mediastreamer/mediastreamer-2.9.0.ebuild,v 1.1 2013/10/09 18:52:30 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mediastreamer/mediastreamer-2.9.0.ebuild,v 1.2 2013/10/09 19:36:13 hasufell Exp $
EAPI=5
@@ -18,7 +18,7 @@ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
# TODO: run-time test for ipv6: does it really need ortp[ipv6] ?
IUSE="+alsa amr bindist coreaudio debug doc examples +filters g726 g729 gsm ilbc
ipv6 ntp-timestamp opus +ortp oss pcap portaudio pulseaudio sdl silk +speex
- static-libs theora upnp v4l video x264 X"
+ static-libs test theora upnp v4l video x264 X"
REQUIRED_USE="|| ( oss alsa portaudio coreaudio pulseaudio )
video? ( || ( sdl X ) )
@@ -48,6 +48,7 @@ DEPEND="${RDEPEND}
dev-util/intltool
virtual/pkgconfig
doc? ( app-doc/doxygen )
+ test? ( >=dev-util/cunit-2.1_p2[ncurses] )
X? ( x11-proto/videoproto )"
PDEPEND="amr? ( !bindist? ( media-plugins/mediastreamer-amr ) )
@@ -90,7 +91,8 @@ src_prepare() {
epatch "${FILESDIR}/${P}-v4l-automagic.patch" \
"${FILESDIR}/${P}-libav9.patch" \
- "${FILESDIR}/${P}-underlinking.patch"
+ "${FILESDIR}/${P}-underlinking.patch" \
+ "${FILESDIR}/${P}-tests.patch"
eautoreconf
}
@@ -111,7 +113,7 @@ src_configure() {
$(use_enable coreaudio macsnd)
$(use_enable debug)
$(use_enable filters)
- $(use_enable g726 spandsp )
+ $(use_enable g726 spandsp)
$(use_enable gsm)
$(use_enable ipv6)
$(use_enable ntp-timestamp)
@@ -146,6 +148,12 @@ src_configure() {
econf "${myeconfargs[@]}"
}
+src_test() {
+ default
+ cd tester || die
+ ./mediastreamer2_tester || die
+}
+
src_install() {
default
prune_libtool_files