summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFerris McCormick <fmccor@gentoo.org>2005-08-10 20:37:47 +0000
committerFerris McCormick <fmccor@gentoo.org>2005-08-10 20:37:47 +0000
commit3d50927f175d0922fd7fa0b1a1085280c0156f51 (patch)
tree395805e8700158f1479cf78d3128b4c6b244dfe0 /media-libs/mesa
parentVersion bump. Resolves bug #102048. (diff)
downloadgentoo-2-3d50927f175d0922fd7fa0b1a1085280c0156f51.tar.gz
gentoo-2-3d50927f175d0922fd7fa0b1a1085280c0156f51.tar.bz2
gentoo-2-3d50927f175d0922fd7fa0b1a1085280c0156f51.zip
(1) Correct a few $(...) to \$(...), and (2) add some sparc-only checks to help with sparc testing.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'media-libs/mesa')
-rw-r--r--media-libs/mesa/ChangeLog13
-rw-r--r--media-libs/mesa/mesa-6.3.1.1.ebuild9
2 files changed, 19 insertions, 3 deletions
diff --git a/media-libs/mesa/ChangeLog b/media-libs/mesa/ChangeLog
index f8d6af7e089f..957289f5919a 100644
--- a/media-libs/mesa/ChangeLog
+++ b/media-libs/mesa/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for media-libs/mesa
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/ChangeLog,v 1.14 2005/08/10 15:20:28 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/ChangeLog,v 1.15 2005/08/10 20:37:47 fmccor Exp $
+
+ 10 Aug 2005; Ferris McCormick <fmccor@gentoo.org> mesa-6.3.1.1.ebuild:
+ 1. Correct echo "$(...)" to echo "\$(...)";
+ 2. When building for sparc, make sure that:
+ a. Use sparc assembly versions where appropriate;
+ b. Make sure sparc-specific sources are built;
+ c. For testing, don't actually build the dri drivers
+ because they are known not to work.
+ d. TODO: Figure out why two versions of libGL are built,
+ and why the install ends up linking to the incorrect
+ version (the one with the undefined externals).
10 Aug 2005; Ferris McCormick <fmccor@gentoo.org> mesa-6.3.1.1.ebuild:
Add ~sparc keyword (X modular testing).
diff --git a/media-libs/mesa/mesa-6.3.1.1.ebuild b/media-libs/mesa/mesa-6.3.1.1.ebuild
index f50923fe0a66..7042ca47ef42 100644
--- a/media-libs/mesa/mesa-6.3.1.1.ebuild
+++ b/media-libs/mesa/mesa-6.3.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-6.3.1.1.ebuild,v 1.5 2005/08/10 15:20:28 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-6.3.1.1.ebuild,v 1.6 2005/08/10 20:37:47 fmccor Exp $
inherit eutils toolchain-funcs
@@ -62,6 +62,11 @@ src_unpack() {
# Set up linux-dri configs
echo "OPT_FLAGS = ${CFLAGS}" >> ${HOSTCONF}
+ if use sparc; then
+ echo "ASM_FLAGS = -DUSE_SPARC_ASM" >> ${HOSTCONF}
+ echo "ASM_SOURCES = \$(SPARC_SOURCES) \$(SPARC_API)" >> ${HOSTCONF}
+ echo "DRIVER_DIRS = " >> ${HOSTCONF}
+ fi
echo "CC = $(tc-getCC)" >> ${HOSTCONF}
echo "CXX = $(tc-getCXX)" >> ${HOSTCONF}
echo "DRM_SOURCE_PATH=\$(TOP)/../${LIBDRM_P}" >> ${HOSTCONF}
@@ -72,7 +77,7 @@ src_unpack() {
# Documented in configs/default
if use motif; then
# Add -lXm
- echo "GLW_LIB_DEPS = -L$(LIB_DIR) -l$(GL_LIB) $(EXTRA_LIB_PATH) -lXt -lX11 -lXm" >> ${HOSTCONF}
+ echo "GLW_LIB_DEPS = -L\$(LIB_DIR) -l\$(GL_LIB) \$(EXTRA_LIB_PATH) -lXt -lX11 -lXm" >> ${HOSTCONF}
# Add GLwMDrawA.c
echo "GLW_SOURCES = GLwDrawA.c GLwMDrawA.c" >> ${HOSTCONF}
fi