summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-11-27 20:13:11 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-11-27 20:13:11 +0000
commit2aaf6643910c2459518c24a26ee3a2acaf690cbd (patch)
treeb804d8683429c8942e3d59d7da9e68e236f12cb3 /media-libs/ming/files
parentVersoion bumped. (diff)
downloadgentoo-2-2aaf6643910c2459518c24a26ee3a2acaf690cbd.tar.gz
gentoo-2-2aaf6643910c2459518c24a26ee3a2acaf690cbd.tar.bz2
gentoo-2-2aaf6643910c2459518c24a26ee3a2acaf690cbd.zip
Closing #32951
Diffstat (limited to 'media-libs/ming/files')
-rw-r--r--media-libs/ming/files/ming-0.2a-fpic.patch75
-rw-r--r--media-libs/ming/files/ming-0.2a-gentoo.diff4
2 files changed, 77 insertions, 2 deletions
diff --git a/media-libs/ming/files/ming-0.2a-fpic.patch b/media-libs/ming/files/ming-0.2a-fpic.patch
new file mode 100644
index 000000000000..814974ce9150
--- /dev/null
+++ b/media-libs/ming/files/ming-0.2a-fpic.patch
@@ -0,0 +1,75 @@
+diff -ur /tmp/ming-0.2a/src/Makefile ./src/Makefile
+--- src/Makefile 2001-08-17 17:06:01.000000000 +0000
++++ src/Makefile 2003-11-27 20:06:20.802157704 +0000
+@@ -1,7 +1,7 @@
+-
+ #CC = gcc -g -pg -a # profiling flags
+ #CC = gcc -O5
+-CC = gcc -g -Wall
++CC = gcc
++CFLAGS = -g -Wall
+
+ LIBDIR = /usr/local/lib
+
+@@ -16,12 +16,15 @@
+ actioncompiler/compileaction.o \
+ actioncompiler/assembler.o
+
++%.o: %.c
++ ${CC} ${CFLAGS} -fPIC -c -o $@ $<
++
+ all: dynamic
+
+ dynamic: ${OFILES}
+ cd blocks && make
+ cd actioncompiler && make
+- ${CC} ${OFILES} ${COMPILEROFILES} blocks/*.o -shared -fpic \
++ ${CC} ${CFLAGS} ${OFILES} ${COMPILEROFILES} blocks/*.o -shared \
+ -o libming.so
+ cp libming.so ..
+
+diff -ur /tmp/ming-0.2a/src/actioncompiler/Makefile ./src/actioncompiler/Makefile
+--- src/actioncompiler/Makefile 2001-08-17 17:35:48.000000000 +0000
++++ src/actioncompiler/Makefile 2003-11-27 20:07:50.409535312 +0000
+@@ -1,7 +1,8 @@
+
+ #CC = gcc -g -pg -a # profiling flags
+ #CC = gcc -O5
+-CC = gcc -g -Wall
++CC = gcc
++CFLAGS = -g -Wall
+
+ DEBUG = --debug
+
+@@ -18,6 +19,9 @@
+
+ OFILES = ${MOSTFILES} compileaction.o
+
++%.o: %.c
++ ${CC} ${CFLAGS} -fPIC -c -o $@ $<
++
+ all: ${OFILES}
+
+ clean:
+diff -ur /tmp/ming-0.2a/src/blocks/Makefile ./src/blocks/Makefile
+--- src/blocks/Makefile 2001-08-17 17:06:05.000000000 +0000
++++ src/blocks/Makefile 2003-11-27 20:06:20.802157704 +0000
+@@ -1,6 +1,7 @@
+ #CC = gcc -g -pg -a # profiling flags
+ #CC = gcc -O5
+-CC = gcc -g -Wall
++CC = gcc
++CFLAGS = -g -Wall
+
+ OFILES = output.o character.o shape.o morph.o fillstyle.o matrix.o font.o \
+ block.o cxform.o text.o action.o button.o placeobject.o \
+@@ -9,6 +10,9 @@
+ dbl.o linestyle.o gradient.o bitmap.o error.o input.o \
+ placeobject.o #sound.o
+
++%.o: %.c
++ ${CC} ${CFLAGS} -fPIC -c -o $@ $<
++
+ all: ${OFILES}
+
+ clean:
diff --git a/media-libs/ming/files/ming-0.2a-gentoo.diff b/media-libs/ming/files/ming-0.2a-gentoo.diff
index c839e74886e0..d9e0d02309e9 100644
--- a/media-libs/ming/files/ming-0.2a-gentoo.diff
+++ b/media-libs/ming/files/ming-0.2a-gentoo.diff
@@ -1,5 +1,5 @@
---- lmp3.c Mon May 13 22:51:15 2002
-+++ listmp3.c Mon May 13 22:50:18 2002
+--- util/lmp3.c Mon May 13 22:51:15 2002
++++ util/listmp3.c Mon May 13 22:50:18 2002
@@ -169,7 +169,7 @@
putchar('\n');