summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-06-11 12:19:48 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-06-11 12:19:48 +0000
commitaf49107c428d1abf1ff73fac48d6e83ca9021939 (patch)
tree29b2ddaf0da8e310f30a2692ee6dd349996bbe70 /media-libs/ming/files
parentFixed bug #136047 and fixed the valgrind part of bug #136303 (diff)
downloadgentoo-2-af49107c428d1abf1ff73fac48d6e83ca9021939.tar.gz
gentoo-2-af49107c428d1abf1ff73fac48d6e83ca9021939.tar.bz2
gentoo-2-af49107c428d1abf1ff73fac48d6e83ca9021939.zip
Bug #123728, fix python module linking brokenness. Also fix QA issue of missing SONAME.
(Portage version: 2.1)
Diffstat (limited to 'media-libs/ming/files')
-rw-r--r--media-libs/ming/files/digest-ming-0.2a-r31
-rw-r--r--media-libs/ming/files/ming-0.2a-linking.patch30
2 files changed, 31 insertions, 0 deletions
diff --git a/media-libs/ming/files/digest-ming-0.2a-r3 b/media-libs/ming/files/digest-ming-0.2a-r3
new file mode 100644
index 000000000000..146ed635587e
--- /dev/null
+++ b/media-libs/ming/files/digest-ming-0.2a-r3
@@ -0,0 +1 @@
+MD5 72b25da0af28d9cb025c2aaf3fd0185c ming-0.2a.tgz 316447
diff --git a/media-libs/ming/files/ming-0.2a-linking.patch b/media-libs/ming/files/ming-0.2a-linking.patch
new file mode 100644
index 000000000000..7cfe815e2ac0
--- /dev/null
+++ b/media-libs/ming/files/ming-0.2a-linking.patch
@@ -0,0 +1,30 @@
+diff -Nuar --exclude '*~' ming-0.2a.orig/py_ext/Makefile ming-0.2a/py_ext/Makefile
+--- ming-0.2a.orig/py_ext/Makefile 2006-06-11 03:55:18.102054000 -0700
++++ ming-0.2a/py_ext/Makefile 2006-06-11 03:59:15.500918176 -0700
+@@ -7,7 +7,7 @@
+ all:
+
+ mingcmodule.so: ming_wrap.o
+- $(CC) $(CFLAGS) -shared -o mingcmodule.so ming_wrap.o -lming
++ $(CC) $(CFLAGS) $(LDFLAGS) -shared -o $@ $^ -L.. -lming
+
+ mingc.pyd: ming_wrap.o
+ dllwrap --dllname mingc.pyd --driver-name gcc --def mingc.def \
+diff -Nuar --exclude '*~' ming-0.2a.orig/src/Makefile ming-0.2a/src/Makefile
+--- ming-0.2a.orig/src/Makefile 2006-06-11 03:55:18.076055000 -0700
++++ ming-0.2a/src/Makefile 2006-06-11 04:04:20.289175057 -0700
+@@ -24,7 +24,7 @@
+ dynamic: ${OFILES}
+ cd blocks && make
+ cd actioncompiler && make
+- ${CC} ${CFLAGS} ${OFILES} ${COMPILEROFILES} blocks/*.o -shared \
++ ${CC} ${CFLAGS} ${LDFLAGS} ${OFILES} ${COMPILEROFILES} blocks/*.o -shared \
+ -o libming.so
+ cp libming.so ..
+
+@@ -45,4 +45,4 @@
+ # ${CC} ${FLAGS} -c $<
+
+ test: static test.o
+- ${CC} -o test test.o libming.a -lm
++ ${CC} ${LDFLAGS} -o test test.o libming.a -lm