summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2014-08-27 19:59:35 +0000
committerIan Stakenvicius <axs@gentoo.org>2014-08-27 19:59:35 +0000
commitbc54be619ef686bef6ff1b09156c7ccf25a6839e (patch)
tree3018985a779c7fdb23f440182c0d1e9425c3481c /media-libs/ming
parentInstall site directory. (diff)
downloadgentoo-2-bc54be619ef686bef6ff1b09156c7ccf25a6839e.tar.gz
gentoo-2-bc54be619ef686bef6ff1b09156c7ccf25a6839e.tar.bz2
gentoo-2-bc54be619ef686bef6ff1b09156c7ccf25a6839e.zip
version bump, bumped EAPI to 5, migrated ebuild to distutils-r1
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 2B6559ED)
Diffstat (limited to 'media-libs/ming')
-rw-r--r--media-libs/ming/ChangeLog7
-rw-r--r--media-libs/ming/ming-0.4.5.ebuild119
2 files changed, 125 insertions, 1 deletions
diff --git a/media-libs/ming/ChangeLog b/media-libs/ming/ChangeLog
index 1997866b7353..adc7ceb0efd3 100644
--- a/media-libs/ming/ChangeLog
+++ b/media-libs/ming/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/ming
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/ming/ChangeLog,v 1.104 2014/08/10 21:10:58 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/ming/ChangeLog,v 1.105 2014/08/27 19:59:35 axs Exp $
+
+*ming-0.4.5 (27 Aug 2014)
+
+ 27 Aug 2014; Ian Stakenvicius (_AxS_) <axs@gentoo.org> +ming-0.4.5.ebuild:
+ version bump, bumped EAPI to 5, migrated ebuild to distutils-r1
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> ming-0.4.4.ebuild:
QA: drop trailing '.' from DESCRIPTION
diff --git a/media-libs/ming/ming-0.4.5.ebuild b/media-libs/ming/ming-0.4.5.ebuild
new file mode 100644
index 000000000000..f21cc64d7fdb
--- /dev/null
+++ b/media-libs/ming/ming-0.4.5.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/ming/ming-0.4.5.ebuild,v 1.1 2014/08/27 19:59:35 axs Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PHP_EXT_NAME=ming
+PHP_EXT_OPTIONAL_USE=php
+AUTOTOOLS_AUTORECONF=yes
+GENTOO_DEPEND_ON_PERL=no
+inherit autotools-utils flag-o-matic multilib php-ext-source-r2 perl-module distutils-r1
+
+DESCRIPTION="An Open Source library for Flash movie generation"
+HOMEPAGE="http://ming.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ming/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="+perl +python php static-libs"
+
+RDEPEND="perl? ( dev-lang/perl:= )
+ python? ( ${PYTHON_DEPS} )
+ media-libs/freetype
+ media-libs/libpng:=
+ media-libs/giflib
+ sys-libs/zlib
+ !media-libs/libswf"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ virtual/yacc"
+
+S=${WORKDIR}/${P/_/.}
+
+# Tests only work when the package is tested on a system
+# which does not presently have any version of ming installed.
+RESTRICT="test"
+
+src_prepare() {
+ # Let's get rid of the TEXTRELS, link dynamic. Use gif.
+ sed -i \
+ -e 's/libming.a/libming.so/' \
+ -e 's/lungif/lgif/' \
+ perl_ext/Makefile.PL
+ sed -i \
+ -e 's/ungif/gif/' \
+ py_ext/setup.py.in
+
+ if use php; then
+ cd "${S}/php_ext"
+ php-ext-source-r2_phpize
+ cd "${S}"
+ fi
+
+ sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.in || die
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ # build is sensitive to -O3 (bug #297437)
+ replace-flags -O3 -O2
+
+ # build python via distutils calls, disable here
+ local myeconfargs=(
+ --disable-python
+ $(use_enable static-libs static)
+ $(use_enable perl)
+ )
+ autotools-utils_src_configure
+}
+
+run_distutils() {
+ if use python; then
+ pushd "${BUILD_DIR}"/py_ext > /dev/null || die
+ distutils-r1_"${@}"
+ popd > /dev/null || die
+ fi
+}
+
+src_compile() {
+ autotools-utils_src_compile
+
+ run_distutils ${FUNCNAME}
+
+ if use php; then
+ cd "${S}"/php_ext
+ myconf="--disable-rpath
+ --disable-static
+ --with-ming"
+ php-ext-source-r2_src_compile
+ fi
+}
+
+src_install() {
+ run_distutils ${FUNCNAME}
+
+ autotools-utils_src_install INSTALLDIRS="vendor"
+
+ fixlocalpod
+
+ if use php; then
+ cd "${S}"/php_ext
+ php-ext-source-r2_src_install
+ fi
+}
+
+pkg_postinst() {
+ use perl && perl-module_pkg_postinst
+}
+
+pkg_prerm() {
+ use perl && perl-module_pkg_prerm
+}
+
+pkg_postrm() {
+ use perl && perl-module_pkg_postrm
+}