summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-01-29 17:51:44 +0000
committerMichał Górny <mgorny@gentoo.org>2015-01-29 17:51:44 +0000
commitb0214fc05a0d867856ed96d0bc5fdf34330f2cb7 (patch)
tree07a66db3fdcc895848a8006207b414be143e6937 /media-libs/mlt/mlt-0.8.2.ebuild
parentSwitch to CPU_FLAGS_X86. (diff)
downloadgentoo-2-b0214fc05a0d867856ed96d0bc5fdf34330f2cb7.tar.gz
gentoo-2-b0214fc05a0d867856ed96d0bc5fdf34330f2cb7.tar.bz2
gentoo-2-b0214fc05a0d867856ed96d0bc5fdf34330f2cb7.zip
Convert to CPU_FLAGS_X86.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'media-libs/mlt/mlt-0.8.2.ebuild')
-rw-r--r--media-libs/mlt/mlt-0.8.2.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/media-libs/mlt/mlt-0.8.2.ebuild b/media-libs/mlt/mlt-0.8.2.ebuild
index 13d222dc60d0..f4597ca537c3 100644
--- a/media-libs/mlt/mlt-0.8.2.ebuild
+++ b/media-libs/mlt/mlt-0.8.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mlt/mlt-0.8.2.ebuild,v 1.7 2014/06/22 15:46:01 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mlt/mlt-0.8.2.ebuild,v 1.8 2015/01/29 17:51:44 mgorny Exp $
EAPI=4
PYTHON_DEPEND="python? 2:2.6"
@@ -14,7 +14,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc ~ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux"
IUSE="compressed-lumas dv debug ffmpeg frei0r gtk jack kde libsamplerate melt
-mmx qt4 quicktime rtaudio sdl sse sse2 vorbis xine xml lua python ruby vdpau" # java perl php tcl
+cpu_flags_x86_mmx qt4 quicktime rtaudio sdl cpu_flags_x86_sse cpu_flags_x86_sse2 vorbis xine xml lua python ruby vdpau" # java perl php tcl
IUSE="${IUSE} kernel_linux"
#rtaudio will use OSS on non linux OSes
@@ -82,8 +82,8 @@ src_configure() {
--disable-swfdec
$(use_enable debug)
$(use_enable dv)
- $(use_enable sse)
- $(use_enable sse2)
+ $(use_enable cpu_flags_x86_sse sse)
+ $(use_enable cpu_flags_x86_sse2 sse2)
$(use_enable gtk gtk2)
$(use_enable vorbis)
$(use_enable sdl)
@@ -108,7 +108,7 @@ src_configure() {
use compressed-lumas && myconf="${myconf} --luma-compress"
( use x86 || use amd64 ) && \
- myconf="${myconf} $(use_enable mmx)" ||
+ myconf="${myconf} $(use_enable cpu_flags_x86_mmx mmx)" ||
myconf="${myconf} --disable-mmx"
use melt || sed -i -e "s;src/melt;;" Makefile