summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Cort <tcort@gentoo.org>2006-11-06 11:37:16 +0000
committerThomas Cort <tcort@gentoo.org>2006-11-06 11:37:16 +0000
commit124b5944b28049d4d732656e7382a7174ee5c9e4 (patch)
tree14e4a09fe8cea50592e01fc6850ae043169daee4 /media-libs/mutagen
parentversion bump/version cleanout (diff)
downloadgentoo-2-124b5944b28049d4d732656e7382a7174ee5c9e4.tar.gz
gentoo-2-124b5944b28049d4d732656e7382a7174ee5c9e4.tar.bz2
gentoo-2-124b5944b28049d4d732656e7382a7174ee5c9e4.zip
Added patch to fix wrong assert. Patch by Timothy Redaelli <drizzt@gentoo.org> on Bug #154063.
(Portage version: 2.1.1-r1)
Diffstat (limited to 'media-libs/mutagen')
-rw-r--r--media-libs/mutagen/ChangeLog7
-rw-r--r--media-libs/mutagen/files/mutagen-1.8-test.patch10
-rw-r--r--media-libs/mutagen/mutagen-1.8.ebuild8
3 files changed, 23 insertions, 2 deletions
diff --git a/media-libs/mutagen/ChangeLog b/media-libs/mutagen/ChangeLog
index 04620779d6f4..d4c57813088a 100644
--- a/media-libs/mutagen/ChangeLog
+++ b/media-libs/mutagen/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/mutagen
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mutagen/ChangeLog,v 1.35 2006/11/04 20:13:23 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mutagen/ChangeLog,v 1.36 2006/11/06 11:37:16 tcort Exp $
+
+ 06 Nov 2006; <tcort@gentoo.org> +files/mutagen-1.8-test.patch,
+ mutagen-1.8.ebuild:
+ Added patch to fix wrong assert. Patch by Timothy Redaelli
+ <drizzt@gentoo.org> on Bug #154063.
04 Nov 2006; <tcort@gentoo.org> mutagen-1.8.ebuild:
Stable on alpha and amd64 wrt Bug #154063.
diff --git a/media-libs/mutagen/files/mutagen-1.8-test.patch b/media-libs/mutagen/files/mutagen-1.8-test.patch
new file mode 100644
index 000000000000..4dabe268e8e3
--- /dev/null
+++ b/media-libs/mutagen/files/mutagen-1.8-test.patch
@@ -0,0 +1,10 @@
+--- tests/test___init__.py.old 2006-11-04 22:14:02.000000000 +0100
++++ tests/test___init__.py 2006-11-04 22:17:38.000000000 +0100
+@@ -146,6 +146,6 @@
+ from mutagen import version
+ from os.path import dirname, basename, abspath
+ trunk = basename(dirname(dirname(dirname(abspath(__file__)))))
+- if trunk != "trunk":
++ if trunk == "trunk":
+ self.failIf(version[-1] < 0, "mutagen.version is a prerelease.")
+ add(TMutagen)
diff --git a/media-libs/mutagen/mutagen-1.8.ebuild b/media-libs/mutagen/mutagen-1.8.ebuild
index 180dd95d5293..abcc9da39bf1 100644
--- a/media-libs/mutagen/mutagen-1.8.ebuild
+++ b/media-libs/mutagen/mutagen-1.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mutagen/mutagen-1.8.ebuild,v 1.2 2006/11/04 20:13:23 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mutagen/mutagen-1.8.ebuild,v 1.3 2006/11/06 11:37:16 tcort Exp $
inherit distutils
@@ -23,6 +23,12 @@ DEPEND="test? (
RDEPEND=">=virtual/python-2.4"
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-test.patch
+}
+
src_test() {
python setup.py test || die "src_test failed."
}