summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-07-22 15:09:07 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-07-22 15:09:07 +0000
commit1ccb201578d43a3238365a31b6dc662c9c8997a1 (patch)
tree513d64156f482db31c1f29d0b72eddd7e823bcce /media-libs/opengtl
parentRefactor the way that SoftMMU targets are enabled by default and detect which (diff)
downloadgentoo-2-1ccb201578d43a3238365a31b6dc662c9c8997a1.tar.gz
gentoo-2-1ccb201578d43a3238365a31b6dc662c9c8997a1.tar.bz2
gentoo-2-1ccb201578d43a3238365a31b6dc662c9c8997a1.zip
New library, dependency of app-office/calligra
(Portage version: 2.1.10.7/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/opengtl')
-rw-r--r--media-libs/opengtl/ChangeLog10
-rw-r--r--media-libs/opengtl/metadata.xml5
-rw-r--r--media-libs/opengtl/opengtl-0.9.15.1.ebuild43
3 files changed, 58 insertions, 0 deletions
diff --git a/media-libs/opengtl/ChangeLog b/media-libs/opengtl/ChangeLog
new file mode 100644
index 000000000000..fb7d862b2618
--- /dev/null
+++ b/media-libs/opengtl/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-libs/opengtl
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/opengtl/ChangeLog,v 1.1 2011/07/22 15:09:07 dilfridge Exp $
+
+*opengtl-0.9.15.1 (22 Jul 2011)
+
+ 22 Jul 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+ +opengtl-0.9.15.1.ebuild, +metadata.xml:
+ New library, dependency of app-office/calligra
+
diff --git a/media-libs/opengtl/metadata.xml b/media-libs/opengtl/metadata.xml
new file mode 100644
index 000000000000..8d1e86a9cefb
--- /dev/null
+++ b/media-libs/opengtl/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>kde</herd>
+</pkgmetadata>
diff --git a/media-libs/opengtl/opengtl-0.9.15.1.ebuild b/media-libs/opengtl/opengtl-0.9.15.1.ebuild
new file mode 100644
index 000000000000..849087baff2c
--- /dev/null
+++ b/media-libs/opengtl/opengtl-0.9.15.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/opengtl/opengtl-0.9.15.1.ebuild,v 1.1 2011/07/22 15:09:07 dilfridge Exp $
+
+EAPI=4
+
+MY_P="OpenGTL-${PV}"
+
+inherit cmake-utils
+
+DESCRIPTION="Collection of libraries for graphics transformation algorithms"
+HOMEPAGE="http://opengtl.org/"
+SRC_URI="http://download.opengtl.org/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug test"
+
+RDEPEND="
+ media-libs/libpng
+ >=sys-devel/llvm-2.7
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ test? ( dev-util/lcov )
+"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use debug OPENGTL_ENABLE_DEBUG_OUTPUT)
+ $(cmake-utils_use test OPENGTL_BUILD_TESTS)
+ $(cmake-utils_use test OPENGTL_CODE_COVERAGE)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ newdoc OpenShiva/doc/reference/region.pdf OpenShiva.pdf
+}