summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2008-03-01 18:19:58 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2008-03-01 18:19:58 +0000
commit7bceb6ce3755a8b60ff546578899173bc2ca4954 (patch)
tree5601d40532b0efa3277201ef811707903508ca56 /media-libs/openjpeg/files
parentAdded the local USE flag tools for openjpeg (diff)
downloadgentoo-2-7bceb6ce3755a8b60ff546578899173bc2ca4954.tar.gz
gentoo-2-7bceb6ce3755a8b60ff546578899173bc2ca4954.tar.bz2
gentoo-2-7bceb6ce3755a8b60ff546578899173bc2ca4954.zip
Fix wrt bug #211999.
Thanks to Jakub Moc for reporting. (Portage version: 2.1.4.4)
Diffstat (limited to 'media-libs/openjpeg/files')
-rw-r--r--media-libs/openjpeg/files/openjpeg-1.3-codec-Makefile21
-rw-r--r--media-libs/openjpeg/files/openjpeg-1.3-codec-Makefile.patch20
2 files changed, 21 insertions, 20 deletions
diff --git a/media-libs/openjpeg/files/openjpeg-1.3-codec-Makefile b/media-libs/openjpeg/files/openjpeg-1.3-codec-Makefile
new file mode 100644
index 000000000000..8a07423fd9a3
--- /dev/null
+++ b/media-libs/openjpeg/files/openjpeg-1.3-codec-Makefile
@@ -0,0 +1,21 @@
+# Makefile for the main OpenJPEG codecs: j2k_to_image and image_to_j2k
+
+CFLAGS += -lstdc++ # -g -p -pg
+
+PREFIX = /usr
+INSTALL_BINDIR = $(PREFIX)/bin
+
+all: j2k_to_image image_to_j2k
+
+j2k_to_image: j2k_to_image.c ../libopenjpeg.a
+ $(CC) $(CFLAGS) $(LDFLAGS) compat/getopt.c index.c convert.c j2k_to_image.c -o j2k_to_image -L.. -lopenjpeg -I ../libopenjpeg/ -lm -ltiff
+
+image_to_j2k: image_to_j2k.c ../libopenjpeg.a
+ $(CC) $(CFLAGS) $(LDFLAGS) compat/getopt.c index.c convert.c image_to_j2k.c -o image_to_j2k -L.. -lopenjpeg -I ../libopenjpeg/ -lm -ltiff
+
+clean:
+ rm -f j2k_to_image image_to_j2k
+
+install: all
+ install -d '$(DESTDIR)$(INSTALL_BINDIR)'
+ install -m 755 j2k_to_image image_to_j2k '$(DESTDIR)$(INSTALL_BINDIR)'
diff --git a/media-libs/openjpeg/files/openjpeg-1.3-codec-Makefile.patch b/media-libs/openjpeg/files/openjpeg-1.3-codec-Makefile.patch
deleted file mode 100644
index f1a3206def40..000000000000
--- a/media-libs/openjpeg/files/openjpeg-1.3-codec-Makefile.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- codec/Makefile 2007-11-27 13:38:52.000000000 +0100
-+++ codec/Makefile.new 2008-02-28 11:18:08.000000000 +0100
-@@ -2,6 +2,9 @@
-
- CFLAGS = -O3 -lstdc++ # -g -p -pg
-
-+PREFIX = /usr
-+INSTALL_BINDIR = $(PREFIX)/bin
-+
- all: j2k_to_image image_to_j2k
-
- j2k_to_image: j2k_to_image.c ../libopenjpeg.a
-@@ -12,3 +15,7 @@
-
- clean:
- rm -f j2k_to_image image_to_j2k
-+
-+install: all
-+ install -d '$(DESTDIR)$(INSTALL_BINDIR)'
-+ install -m 755 j2k_to_image image_to_j2k '$(DESTDIR)$(INSTALL_BINDIR)'