summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-05-08 08:50:21 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-05-08 08:50:21 +0000
commit02191e1c7a690013ad1431f0a734fab5ba73c49f (patch)
tree16fb66fdb8d7f418a0014c923f985d0ce1ea9d18 /media-libs/opus
parentVersion bump. (diff)
downloadgentoo-2-02191e1c7a690013ad1431f0a734fab5ba73c49f.tar.gz
gentoo-2-02191e1c7a690013ad1431f0a734fab5ba73c49f.tar.bz2
gentoo-2-02191e1c7a690013ad1431f0a734fab5ba73c49f.zip
Add multilib support by Karl Lindén, bug #468564
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-libs/opus')
-rw-r--r--media-libs/opus/ChangeLog7
-rw-r--r--media-libs/opus/opus-1.0.2-r2.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/media-libs/opus/ChangeLog b/media-libs/opus/ChangeLog
index 9a4bc4864078..0e932218a413 100644
--- a/media-libs/opus/ChangeLog
+++ b/media-libs/opus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/opus
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/opus/ChangeLog,v 1.22 2013/02/23 09:41:18 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/opus/ChangeLog,v 1.23 2013/05/08 08:50:21 aballier Exp $
+
+*opus-1.0.2-r2 (08 May 2013)
+
+ 08 May 2013; Alexis Ballier <aballier@gentoo.org> +opus-1.0.2-r2.ebuild:
+ Add multilib support by Karl Lindén, bug #468564
23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> opus-1.0.1.ebuild:
Stable for sparc, wrt bug #458188
diff --git a/media-libs/opus/opus-1.0.2-r2.ebuild b/media-libs/opus/opus-1.0.2-r2.ebuild
new file mode 100644
index 000000000000..e855414980d5
--- /dev/null
+++ b/media-libs/opus/opus-1.0.2-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/opus/opus-1.0.2-r2.ebuild,v 1.1 2013/05/08 08:50:21 aballier Exp $
+
+EAPI=5
+
+if [[ ${PV} == *9999 ]] ; then
+ SCM="git-2"
+ EGIT_REPO_URI="git://git.opus-codec.org/opus.git"
+ AUTOTOOLS_AUTORECONF="1"
+fi
+
+inherit autotools-multilib ${SCM}
+
+MY_P=${P/_/-}
+DESCRIPTION="Open versatile codec designed for interactive speech and audio transmission over the internet"
+HOMEPAGE="http://opus-codec.org/"
+SRC_URI="http://downloads.xiph.org/releases/opus/${P}.tar.gz"
+if [[ ${PV} == *9999 ]] ; then
+ SRC_URI=""
+elif [[ ${PV%_p*} != ${PV} ]] ; then # Gentoo snapshot
+ SRC_URI="http://dev.gentoo.org/~lu_zero/${PN}/${P}.tar.xz"
+else # Official release
+ SRC_URI="http://downloads.xiph.org/releases/${PN}/${MY_P}.tar.gz"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-fbsd"
+IUSE="custom-modes doc static-libs"
+
+DEPEND="doc? ( app-doc/doxygen )"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable custom-modes)
+ $(use_enable doc)
+ )
+ autotools-multilib_src_configure
+}