summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2013-01-12 13:07:24 +0000
committerHanno Böck <hanno@gentoo.org>2013-01-12 13:07:24 +0000
commit366cc5060001bfe955121436e32c1bedf09203f7 (patch)
tree1e179fd90118284c32dc65d0118cc1bcffbc6077 /media-libs/opus
parentSuppress false QA warning for help2man, bug 450278. (diff)
downloadgentoo-2-366cc5060001bfe955121436e32c1bedf09203f7.tar.gz
gentoo-2-366cc5060001bfe955121436e32c1bedf09203f7.tar.bz2
gentoo-2-366cc5060001bfe955121436e32c1bedf09203f7.zip
Security bump (#446720), don't enable discouraged custom modes (#451268), verbose log (#442592)
(Portage version: 2.1.11.40/cvs/Linux x86_64, signed Manifest commit with key 0xA5880072BBB51E42)
Diffstat (limited to 'media-libs/opus')
-rw-r--r--media-libs/opus/ChangeLog8
-rw-r--r--media-libs/opus/metadata.xml5
-rw-r--r--media-libs/opus/opus-1.0.2.ebuild52
3 files changed, 60 insertions, 5 deletions
diff --git a/media-libs/opus/ChangeLog b/media-libs/opus/ChangeLog
index ddc0cce155f2..523bf0b01ada 100644
--- a/media-libs/opus/ChangeLog
+++ b/media-libs/opus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/opus
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/opus/ChangeLog,v 1.11 2013/01/07 19:32:59 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/opus/ChangeLog,v 1.12 2013/01/12 13:07:24 hanno Exp $
+
+*opus-1.0.2 (12 Jan 2013)
+
+ 12 Jan 2013; Hanno Boeck <hanno@gentoo.org> +opus-1.0.2.ebuild, metadata.xml:
+ Security bump (#446720), don't enable discouraged custom modes (#451268),
+ verbose log (#442592)
07 Jan 2013; Jeroen Roovers <jer@gentoo.org> opus-1.0.1.ebuild:
Marked ~hppa (bug #450672).
diff --git a/media-libs/opus/metadata.xml b/media-libs/opus/metadata.xml
index c572c7d9b478..2c6f9b082570 100644
--- a/media-libs/opus/metadata.xml
+++ b/media-libs/opus/metadata.xml
@@ -1,8 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>video</herd>
- <maintainer>
- <email>media-video@gentoo.org</email>
- </maintainer>
+ <herd>audio</herd>
</pkgmetadata>
diff --git a/media-libs/opus/opus-1.0.2.ebuild b/media-libs/opus/opus-1.0.2.ebuild
new file mode 100644
index 000000000000..aa65c4b9578c
--- /dev/null
+++ b/media-libs/opus/opus-1.0.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/opus/opus-1.0.2.ebuild,v 1.1 2013/01/12 13:07:24 hanno Exp $
+
+EAPI=4
+
+if [[ ${PV} == *9999 ]] ; then
+ SCM="git-2"
+ EGIT_REPO_URI="git://git.opus-codec.org/opus.git"
+fi
+
+inherit autotools ${SCM}
+
+MY_P=${P/_/-}
+DESCRIPTION="Open versatile codec designed for interactive speech and audio transmission over the internet"
+HOMEPAGE="http://opus-codec.org/"
+SRC_URI="http://downloads.xiph.org/releases/opus/${P}.tar.gz"
+if [[ ${PV} == *9999 ]] ; then
+ SRC_URI=""
+elif [[ ${PV%_p*} != ${PV} ]] ; then # Gentoo snapshot
+ SRC_URI="http://dev.gentoo.org/~lu_zero/${PN}/${P}.tar.xz"
+else # Official release
+ SRC_URI="http://downloads.xiph.org/releases/${PN}/${MY_P}.tar.gz"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd"
+IUSE="doc static-libs"
+
+DEPEND="doc? ( app-doc/doxygen )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable doc) $(use_enable static-libs static) --disable-silent-rules
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete
+ rm -fR "${D}/usr/share/doc/opus"
+ use doc && dohtml -r doc/html/*
+}