summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2014-09-14 10:03:46 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2014-09-14 10:03:46 +0000
commit8ebea6dabdd4f8f45cfe460358732452e492ff3b (patch)
tree5d80870422b6f394182a0b139d59494fe76d2366 /media-libs/opusfile
parentVersion bump (diff)
downloadgentoo-2-8ebea6dabdd4f8f45cfe460358732452e492ff3b.tar.gz
gentoo-2-8ebea6dabdd4f8f45cfe460358732452e492ff3b.tar.bz2
gentoo-2-8ebea6dabdd4f8f45cfe460358732452e492ff3b.zip
Version bump
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 09BF4F54C2BA7F3C!)
Diffstat (limited to 'media-libs/opusfile')
-rw-r--r--media-libs/opusfile/ChangeLog7
-rw-r--r--media-libs/opusfile/opusfile-0.6.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/media-libs/opusfile/ChangeLog b/media-libs/opusfile/ChangeLog
index c3659a7231b9..03a8e004c466 100644
--- a/media-libs/opusfile/ChangeLog
+++ b/media-libs/opusfile/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/opusfile
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/opusfile/ChangeLog,v 1.10 2014/07/19 17:27:13 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/opusfile/ChangeLog,v 1.11 2014/09/14 10:03:46 hwoarang Exp $
+
+*opusfile-0.6 (14 Sep 2014)
+
+ 14 Sep 2014; Markos Chandras <hwoarang@gentoo.org> +opusfile-0.6.ebuild:
+ Version bump
19 Jul 2014; Tobias Klausmann <klausman@gentoo.org> opusfile-0.5.ebuild:
Keyworded on alpha, bug #507650
diff --git a/media-libs/opusfile/opusfile-0.6.ebuild b/media-libs/opusfile/opusfile-0.6.ebuild
new file mode 100644
index 000000000000..9034ba501cfb
--- /dev/null
+++ b/media-libs/opusfile/opusfile-0.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/opusfile/opusfile-0.6.ebuild,v 1.1 2014/09/14 10:03:46 hwoarang Exp $
+
+EAPI=5
+
+DESCRIPTION="A high-level decoding and seeking API for .opus files"
+HOMEPAGE="http://www.opus-codec.org/"
+SRC_URI="http://downloads.xiph.org/releases/opus/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~x86"
+IUSE="doc fixed-point +float +http static-libs"
+
+RDEPEND="media-libs/libogg
+ media-libs/opus
+ http? ( dev-libs/openssl )"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+REQUIRED_USE="^^ ( fixed-point float )"
+
+src_configure() {
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable doc) \
+ $(use_enable fixed-point)\
+ $(use_enable float) \
+ $(use_enable http) \
+ $(use_enable static-libs static)
+}