summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2004-10-16 01:55:39 +0000
committerChris White <chriswhite@gentoo.org>2004-10-16 01:55:39 +0000
commit74576f7d87da81757efdd664ff72d4b4159f9d7b (patch)
treea9712d443fe2a987516f7a4ffb1f62c9188eef19 /media-libs/phat
parentAdd gcc34 patch from Mandrakesoft (bug #66904) (Manifest recommit) (diff)
downloadgentoo-2-74576f7d87da81757efdd664ff72d4b4159f9d7b.tar.gz
gentoo-2-74576f7d87da81757efdd664ff72d4b4159f9d7b.tar.bz2
gentoo-2-74576f7d87da81757efdd664ff72d4b4159f9d7b.zip
Intial import to the tree. Thanks to mikael soderholm <gnarlie@ihku.org> for the intial ebuild. This closes bug #66879.
Diffstat (limited to 'media-libs/phat')
-rw-r--r--media-libs/phat/ChangeLog11
-rw-r--r--media-libs/phat/Manifest2
-rw-r--r--media-libs/phat/files/digest-phat-0.2.31
-rw-r--r--media-libs/phat/metadata.xml8
-rw-r--r--media-libs/phat/phat-0.2.3.ebuild27
5 files changed, 49 insertions, 0 deletions
diff --git a/media-libs/phat/ChangeLog b/media-libs/phat/ChangeLog
new file mode 100644
index 000000000000..02dc0995646c
--- /dev/null
+++ b/media-libs/phat/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for media-libs/phat
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/phat/ChangeLog,v 1.1 2004/10/16 01:55:39 chriswhite Exp $
+
+*phat-0.2.3 (16 Oct 2004)
+
+ 16 Oct 2004; Chris White <chriswhite@gentoo.org> +metadata.xml,
+ +phat-0.2.3.ebuild:
+ Intial import to the tree. Thanks to mikael soderholm
+ <gnarlie@ihku.org> for the intial ebuild. This closes bug #66879.
+
diff --git a/media-libs/phat/Manifest b/media-libs/phat/Manifest
new file mode 100644
index 000000000000..1cb8bfd789df
--- /dev/null
+++ b/media-libs/phat/Manifest
@@ -0,0 +1,2 @@
+MD5 36270e7cf18d5ec97a66f40e77d07de7 phat-0.2.3.ebuild 605
+MD5 a188652fea06dc2403bf387d33481386 files/digest-phat-0.2.3 62
diff --git a/media-libs/phat/files/digest-phat-0.2.3 b/media-libs/phat/files/digest-phat-0.2.3
new file mode 100644
index 000000000000..fff41bad5c04
--- /dev/null
+++ b/media-libs/phat/files/digest-phat-0.2.3
@@ -0,0 +1 @@
+MD5 e06f136041c257c86a144345c10dd8fd phat-0.2.3.tar.gz 353417
diff --git a/media-libs/phat/metadata.xml b/media-libs/phat/metadata.xml
new file mode 100644
index 000000000000..ec6a427b666f
--- /dev/null
+++ b/media-libs/phat/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+<maintainer>
+ <email>chriswhite@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/media-libs/phat/phat-0.2.3.ebuild b/media-libs/phat/phat-0.2.3.ebuild
new file mode 100644
index 000000000000..199702f668b4
--- /dev/null
+++ b/media-libs/phat/phat-0.2.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/phat/phat-0.2.3.ebuild,v 1.1 2004/10/16 01:55:39 chriswhite Exp $
+
+DESCRIPTION="PHAT is a collection of GTK+ widgets geared toward pro-audio apps."
+HOMEPAGE="http://www.gazuga.net/phat.php"
+SRC_URI="http://www.gazuga.net/phatfiles/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="debug doc"
+
+DEPEND=">x11-libs/gtk+-2*"
+
+src_compile() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable doc gtk-doc) || die
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}