summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-09-17 08:52:05 +0000
committerJustin Lecher <jlec@gentoo.org>2014-09-17 08:52:05 +0000
commitd2422f290386e5024df3702c85cc0f8c58815f58 (patch)
tree23f75d699a1564c3e8820dcbe3cc211f350c22e6 /media-libs/qhull
parentVersion bump. (diff)
downloadgentoo-2-d2422f290386e5024df3702c85cc0f8c58815f58.tar.gz
gentoo-2-d2422f290386e5024df3702c85cc0f8c58815f58.tar.bz2
gentoo-2-d2422f290386e5024df3702c85cc0f8c58815f58.zip
media-libs/qhull: Drop pc support again as matplotlib works better without
(Portage version: 2.2.13/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'media-libs/qhull')
-rw-r--r--media-libs/qhull/ChangeLog8
-rw-r--r--media-libs/qhull/files/qhull-2012.1-pc.patch15
-rw-r--r--media-libs/qhull/files/qhull.pc.in11
-rw-r--r--media-libs/qhull/qhull-2012.1-r3.ebuild (renamed from media-libs/qhull/qhull-2012.1-r2.ebuild)13
4 files changed, 9 insertions, 38 deletions
diff --git a/media-libs/qhull/ChangeLog b/media-libs/qhull/ChangeLog
index eb71d7894eb0..e383d64e204e 100644
--- a/media-libs/qhull/ChangeLog
+++ b/media-libs/qhull/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/qhull
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/qhull/ChangeLog,v 1.57 2014/09/17 08:33:56 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/qhull/ChangeLog,v 1.58 2014/09/17 08:52:05 jlec Exp $
+
+*qhull-2012.1-r3 (17 Sep 2014)
+
+ 17 Sep 2014; Justin Lecher <jlec@gentoo.org> -qhull-2012.1-r2.ebuild,
+ +qhull-2012.1-r3.ebuild, -files/qhull-2012.1-pc.patch, -files/qhull.pc.in:
+ Drop pc support again as matplotlib works better without
*qhull-2012.1-r2 (17 Sep 2014)
diff --git a/media-libs/qhull/files/qhull-2012.1-pc.patch b/media-libs/qhull/files/qhull-2012.1-pc.patch
deleted file mode 100644
index d609e8962f19..000000000000
--- a/media-libs/qhull/files/qhull-2012.1-pc.patch
+++ /dev/null
@@ -1,15 +0,0 @@
- CMakeLists.txt | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 98dbc70..b323e10 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -430,3 +430,7 @@ install(FILES html/qhull.man DESTINATION ${MAN_INSTALL_DIR} RENAME qhull
- install(FILES html/rbox.man DESTINATION ${MAN_INSTALL_DIR} RENAME rbox.1)
- install(FILES ${doc_FILES} DESTINATION ${DOC_INSTALL_DIR})
- install(DIRECTORY html/ DESTINATION ${DOC_INSTALL_DIR})
-+
-+
-+configure_file("qhull.pc.in" "qhull.pc" @ONLY)
-+install(FILES "${CMAKE_CURRENT_BINARY_DIR}/qhull.pc" DESTINATION "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}/pkgconfig")
diff --git a/media-libs/qhull/files/qhull.pc.in b/media-libs/qhull/files/qhull.pc.in
deleted file mode 100644
index 2bb503b24e88..000000000000
--- a/media-libs/qhull/files/qhull.pc.in
+++ /dev/null
@@ -1,11 +0,0 @@
-prefix=@CMAKE_INSTALL_PREFIX@
-exec_prefix=${prefix}
-includedir=${exec_prefix}/include
-libdir=${exec_prefix}/@CMAKE_INSTALL_LIBDIR@
-
-Name: qhull
-Description: General dimension convex hull library
-Version: @VERSION@
-Requires:
-Libs: -L${libdir} -lqhull -lm
-Cflags: -I${includedir}
diff --git a/media-libs/qhull/qhull-2012.1-r2.ebuild b/media-libs/qhull/qhull-2012.1-r3.ebuild
index 5aafccb4d2cf..04ef8932877c 100644
--- a/media-libs/qhull/qhull-2012.1-r2.ebuild
+++ b/media-libs/qhull/qhull-2012.1-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/qhull/qhull-2012.1-r2.ebuild,v 1.1 2014/09/17 08:33:56 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/qhull/qhull-2012.1-r3.ebuild,v 1.1 2014/09/17 08:52:05 jlec Exp $
EAPI=5
@@ -19,16 +19,7 @@ IUSE="doc static-libs"
DOCS=( Announce.txt File_id.diz README.txt REGISTER.txt )
-PATCHES=(
- "${FILESDIR}"/${P}-64bit.patch
- "${FILESDIR}"/${P}-pc.patch
- )
-
-src_prepare() {
- # From fedora, matplotlib depends on it
- cp "${FILESDIR}"/${PN}.pc.in . || die
- cmake-utils_src_prepare
-}
+PATCHES=( "${FILESDIR}"/${P}-64bit.patch )
src_configure() {
append-flags -fno-strict-aliasing