summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-02-10 22:06:36 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-02-10 22:06:36 +0000
commitdae86e4eebf1d6cc33efcee71a2fa7049bf63315 (patch)
treed08c2a2079e6c8f7ba2a067bf74956443be43835 /media-libs/qhull
parenta few little tweaks that don't affect functionality (diff)
downloadgentoo-2-dae86e4eebf1d6cc33efcee71a2fa7049bf63315.tar.gz
gentoo-2-dae86e4eebf1d6cc33efcee71a2fa7049bf63315.tar.bz2
gentoo-2-dae86e4eebf1d6cc33efcee71a2fa7049bf63315.zip
qhull - library for computing properties of geometric hulls
Diffstat (limited to 'media-libs/qhull')
-rw-r--r--media-libs/qhull/ChangeLog19
-rw-r--r--media-libs/qhull/files/digest-qhull-3.11
-rw-r--r--media-libs/qhull/qhull-3.1.ebuild48
3 files changed, 68 insertions, 0 deletions
diff --git a/media-libs/qhull/ChangeLog b/media-libs/qhull/ChangeLog
new file mode 100644
index 000000000000..a0fa37988c51
--- /dev/null
+++ b/media-libs/qhull/ChangeLog
@@ -0,0 +1,19 @@
+# ChangeLog for media-libs/qhull
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/media-libs/qhull/ChangeLog,v 1.1 2002/02/10 22:06:36 karltk Exp $
+
+*qhull-3.1 ( 10 Feb 2002 )
+
+ 10 Feb 2002; Karl Trygve Kalleberg <karltk@gentoo.org> ChangeLog files/digest-qhull-3.1 qhull-3.1.ebuild:
+
+ Qhull computes convex hulls, Delaunay triangulations, halfspace
+ intersections about a point, Voronoi diagrams, furthest-site Delaunay
+ triangulations, and furthest-site Voronoi diagrams. It runs in 2-d, 3-d,
+ 4-d, and higher dimensions. It implements the Quickhull algorithm for
+ computing the convex hull. Qhull handles roundoff errors from floating
+ point arithmetic. It computes volumes, surface areas, and approximations to
+ the convex hull.
+
+ Qhull does not support constrained Delaunay triangulations, triangulation of
+ non-convex surfaces, mesh generation of non-convex objects, or medium-sized
+ inputs in 9-D and higher.
diff --git a/media-libs/qhull/files/digest-qhull-3.1 b/media-libs/qhull/files/digest-qhull-3.1
new file mode 100644
index 000000000000..bdb2ce816057
--- /dev/null
+++ b/media-libs/qhull/files/digest-qhull-3.1
@@ -0,0 +1 @@
+MD5 08b85478c0b8e4c88aa72e6a5b125464 qhull3.1.tgz 446464
diff --git a/media-libs/qhull/qhull-3.1.ebuild b/media-libs/qhull/qhull-3.1.ebuild
new file mode 100644
index 000000000000..c7634c4fed27
--- /dev/null
+++ b/media-libs/qhull/qhull-3.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Tools Team <tools@gentoo.org>
+# Author: Karl Trygve Kalleberg <karltk@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/qhull/qhull-3.1.ebuild,v 1.1 2002/02/10 22:06:36 karltk Exp $
+
+S=${WORKDIR}/qhull3.1
+DESCRIPTION="Geometry library"
+SRC_URI="http://www.geom.umn.edu/software/qhull/qhull3.1.tgz"
+HOMEPAGE="http://www.geom.umn.edu/software/qhull/"
+
+DEPEND=""
+#RDEPEND=""
+
+src_compile() {
+ cd src
+ make -f Makefile.txt
+
+}
+
+src_install () {
+
+ cd src
+
+ dolib libqhull.a
+ dobin qconvex
+ dobin qdelaunay
+ dobin qhalf
+ dobin qhull
+ dobin qvoronoi
+ dobin rbox
+
+ dodir /usr/include/qhull
+ insinto /usr/include/qhull
+ doins *.h
+
+ cd ${S}
+ dodoc Announce.txt COPYING.txt File_id.diz README.txt REGISTER.txt
+
+ cd html
+
+ rename .htm .html *.htm
+ rename .man .1 *.man
+
+ dohtml -a html,gif *
+
+ doman *.1
+}