summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-11-27 07:35:52 +0000
committerTim Harder <radhermit@gentoo.org>2012-11-27 07:35:52 +0000
commitcac67913dfb107756a173b9a0a15909feb45ab87 (patch)
tree1b84a5eb1038d3463960d4d3fa7e7614eb1a56f0 /media-libs/rtaudio/files
parentVersion bump with some minor fixes. Drop old. (diff)
downloadgentoo-2-cac67913dfb107756a173b9a0a15909feb45ab87.tar.gz
gentoo-2-cac67913dfb107756a173b9a0a15909feb45ab87.tar.bz2
gentoo-2-cac67913dfb107756a173b9a0a15909feb45ab87.zip
Initial import, ebuild by me.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'media-libs/rtaudio/files')
-rw-r--r--media-libs/rtaudio/files/rtaudio-4.0.11-cflags.patch24
-rw-r--r--media-libs/rtaudio/files/rtaudio-4.0.11-configure.patch51
-rw-r--r--media-libs/rtaudio/files/rtaudio-4.0.11-makefile.patch21
3 files changed, 96 insertions, 0 deletions
diff --git a/media-libs/rtaudio/files/rtaudio-4.0.11-cflags.patch b/media-libs/rtaudio/files/rtaudio-4.0.11-cflags.patch
new file mode 100644
index 000000000000..9fa657929c21
--- /dev/null
+++ b/media-libs/rtaudio/files/rtaudio-4.0.11-cflags.patch
@@ -0,0 +1,24 @@
+--- rtaudio-4.0.11/configure.ac
++++ rtaudio-4.0.11/configure.ac
+@@ -23,8 +23,8 @@
+ AC_MSG_CHECKING(whether to compile debug version)
+ AC_ARG_ENABLE(debug,
+ [ --enable-debug = enable various debug output],
+- [AC_SUBST( cppflag, [-D__RTAUDIO_DEBUG__] ) AC_SUBST( cxxflag, [-g] ) AC_SUBST( object_path, [Debug] ) AC_MSG_RESULT(yes)],
+- [AC_SUBST( cppflag, [] ) AC_SUBST( cxxflag, [-O2] ) AC_SUBST( object_path, [Release] ) AC_MSG_RESULT(no)])
++ [AC_SUBST( cppflag, [-D__RTAUDIO_DEBUG__] ) AC_SUBST( object_path, [Debug] ) AC_MSG_RESULT(yes)],
++ [AC_SUBST( cppflag, [] ) AC_SUBST( object_path, [Release] ) AC_MSG_RESULT(no)])
+
+
+ # Checks for functions
+@@ -33,10 +33,6 @@
+ # For -I and -D flags
+ CPPFLAGS="$CPPFLAGS $cppflag"
+
+-# For debugging and optimization ... overwrite default because it has both -g and -O2
+-#CXXFLAGS="$CXXFLAGS $cxxflag"
+-CXXFLAGS="$cxxflag"
+-
+ # Check compiler and use -Wall if gnu.
+ if [test $GXX = "yes" ;] then
+ AC_SUBST( cxxflag, [-Wall] )
diff --git a/media-libs/rtaudio/files/rtaudio-4.0.11-configure.patch b/media-libs/rtaudio/files/rtaudio-4.0.11-configure.patch
new file mode 100644
index 000000000000..55862e2782ca
--- /dev/null
+++ b/media-libs/rtaudio/files/rtaudio-4.0.11-configure.patch
@@ -0,0 +1,51 @@
+--- rtaudio-4.0.11/configure.ac
++++ rtaudio-4.0.11/configure.ac
+@@ -68,28 +68,40 @@
+ ;;
+
+ *-*-linux*)
+- AC_ARG_WITH(jack, [ --with-jack = choose JACK server support (mac and linux only)], [
++ AC_ARG_WITH([jack], AS_HELP_STRING([--with-jack], [choose JACK server support (mac and linux only)]))
++
++ AS_IF([test "x$with_jack" != "xno"], [
+ api="$api -D__UNIX_JACK__"
+ AC_MSG_RESULT(using JACK)
+ AC_CHECK_LIB(jack, jack_client_open, , AC_MSG_ERROR(JACK support requires the jack library!))
+- AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(Jack support also requires the asound library!))], )
++ AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(Jack support also requires the asound library!))
++ ])
+
+ # Look for ALSA flag
+- AC_ARG_WITH(alsa, [ --with-alsa = choose native ALSA API support (linux only)], [
++ AC_ARG_WITH([alsa], AS_HELP_STRING([--with-alsa], [choose native ALSA API support (linux only)]))
++
++ AS_IF([test "x$with_alsa" != "xno"], [
+ api="$api -D__LINUX_ALSA__"
+ AC_MSG_RESULT(using ALSA)
+- AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(ALSA support requires the asound library!))], )
++ AC_CHECK_LIB(asound, snd_pcm_open, , AC_MSG_ERROR(ALSA support requires the asound library!))
++ ])
+
+ # Look for PULSE flag
+- AC_ARG_WITH(pulse, [ --with-pulse = choose PulseAudio API support (linux only)], [
++ AC_ARG_WITH([pulse], AS_HELP_STRING([--with-pulse], [choose PulseAudio API support (linux only)]))
++
++ AS_IF([test "x$with_pulse" != "xno"], [
+ api="$api -D__LINUX_PULSE__"
+ AC_MSG_RESULT(using PulseAudio)
+- AC_CHECK_LIB(pulse-simple, pa_simple_new, , AC_MSG_ERROR(PulseAudio support requires the pulse-simple library!))], )
++ AC_CHECK_LIB(pulse-simple, pa_simple_new, , AC_MSG_ERROR(PulseAudio support requires the pulse-simple library!))
++ ])
+
+ # Look for OSS flag
+- AC_ARG_WITH(oss, [ --with-oss = choose OSS API support (linux only)], [
++ AC_ARG_WITH([oss], AS_HELP_STRING([--with-oss], [choose OSS API support (linux only)]))
++
++ AS_IF([test "x$with_oss" != "xno"], [
+ api="$api -D__LINUX_OSS__"
+- AC_MSG_RESULT(using OSS)], )
++ AC_MSG_RESULT(using OSS)
++ ])
+
+ # If no audio api flags specified, use ALSA
+ if [test "$api" == "";] then
diff --git a/media-libs/rtaudio/files/rtaudio-4.0.11-makefile.patch b/media-libs/rtaudio/files/rtaudio-4.0.11-makefile.patch
new file mode 100644
index 000000000000..af1c88e7d11c
--- /dev/null
+++ b/media-libs/rtaudio/files/rtaudio-4.0.11-makefile.patch
@@ -0,0 +1,21 @@
+--- rtaudio-4.0.11/Makefile.in
++++ rtaudio-4.0.11/Makefile.in
+@@ -24,13 +24,14 @@
+ tests:
+ cd tests && $(MAKE) all
+
+-$(LIBRARIES): $(OBJECTS)
++$(STATIC): $(OBJECTS)
+ $(AR) ruv $(STATIC) $(OBJECTS)
+- ranlib $(STATIC)
++ $(RANLIB) $(STATIC)
++
++$(SHARED): $(OBJECTS)
+ $(CC) -fPIC @libflags@ $(OBJECTS) @LIBS@
+ $(LN) -s @sharedname@ $(SHARED)
+-
+-# $(CC) -shared $(OBJECTS) -o $(SHARED) @LIBS@
++ $(LN) -s @sharedname@ $(SHARED).$(MAJOR)
+
+ %.o : %.cpp
+ $(CC) $(CFLAGS) $(DEFS) -c $(<) -o $@