summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2014-08-05 10:52:21 +0000
committerTony Vroon <chainsaw@gentoo.org>2014-08-05 10:52:21 +0000
commit2fe74b3f782b299dce92abb1f478db09ecb96bee (patch)
tree821f512511a7bb3d5008d5e7b73bf0ad5d4e526b /media-libs/spandsp
parentRe-enable libuuid/libblkid for non-Linux platforms #278667 by Alexis Ballier. (diff)
downloadgentoo-2-2fe74b3f782b299dce92abb1f478db09ecb96bee.tar.gz
gentoo-2-2fe74b3f782b299dce92abb1f478db09ecb96bee.tar.bz2
gentoo-2-2fe74b3f782b299dce92abb1f478db09ecb96bee.zip
USE-flags reworked by Oliver Jaksch, version bump closes bug #516830.
(Portage version: 2.2.11-r1/cvs/Linux x86_64, signed Manifest commit with key 0xB5058F9A)
Diffstat (limited to 'media-libs/spandsp')
-rw-r--r--media-libs/spandsp/ChangeLog8
-rw-r--r--media-libs/spandsp/metadata.xml1
-rw-r--r--media-libs/spandsp/spandsp-0.0.6.ebuild57
3 files changed, 65 insertions, 1 deletions
diff --git a/media-libs/spandsp/ChangeLog b/media-libs/spandsp/ChangeLog
index 3f453c587d1b..4dcc7c3548ab 100644
--- a/media-libs/spandsp/ChangeLog
+++ b/media-libs/spandsp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/spandsp
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/spandsp/ChangeLog,v 1.31 2014/07/27 18:15:19 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/spandsp/ChangeLog,v 1.32 2014/08/05 10:52:21 chainsaw Exp $
+
+*spandsp-0.0.6 (05 Aug 2014)
+
+ 05 Aug 2014; Tony Vroon <chainsaw@gentoo.org> +spandsp-0.0.6.ebuild,
+ metadata.xml:
+ USE-flags reworked by Oliver Jaksch, version bump closes bug #516830.
27 Jul 2014; Rick Farina <zerochaos@gentoo.org> spandsp-0.0.6_pre12-r1.ebuild,
spandsp-0.0.6_pre21.ebuild:
diff --git a/media-libs/spandsp/metadata.xml b/media-libs/spandsp/metadata.xml
index 185b7406f610..cd9f2a71456d 100644
--- a/media-libs/spandsp/metadata.xml
+++ b/media-libs/spandsp/metadata.xml
@@ -4,5 +4,6 @@
<maintainer><email>chainsaw@gentoo.org</email></maintainer>
<use>
<flag name='fixed-point'>Enable fixed point support</flag>
+ <flag name='sse4a'>Enable AMD Barcelona (SSE4a) instruction set support</flag>
</use>
</pkgmetadata>
diff --git a/media-libs/spandsp/spandsp-0.0.6.ebuild b/media-libs/spandsp/spandsp-0.0.6.ebuild
new file mode 100644
index 000000000000..2557efe4ca0c
--- /dev/null
+++ b/media-libs/spandsp/spandsp-0.0.6.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/spandsp/spandsp-0.0.6.ebuild,v 1.1 2014/08/05 10:52:21 chainsaw Exp $
+
+EAPI="5"
+
+inherit multilib versionator
+
+DESCRIPTION="SpanDSP is a library of DSP functions for telephony"
+HOMEPAGE="http://www.soft-switch.org/"
+SRC_URI="http://www.soft-switch.org/downloads/spandsp/${P/_}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="doc fixed-point mmx sse sse2 sse3 ssse3 sse4a avx static-libs"
+
+RDEPEND="media-libs/tiff"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen
+ dev-libs/libxslt )"
+
+S=${WORKDIR}/${PN}-$(get_version_component_range 1-3)
+
+# TODO:
+# there are two tests options: tests and test-data
+# they need audiofile, fftw, libxml and probably more
+# configure script is auto-enabling some sse* options sometimes
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable doc) \
+ $(use_enable fixed-point) \
+ $(use_enable mmx) \
+ $(use_enable sse) \
+ $(use_enable sse2) \
+ $(use_enable sse3) \
+ $(use_enable ssse3) \
+ $(use_enable sse4a) \
+ $(use_enable avx) \
+ $(use_enable static-libs static)
+}
+
+src_install () {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog DueDiligence NEWS README
+
+ if ! use static-libs; then
+ # remove useless la file when not installing static lib
+ rm "${D}"/usr/$(get_libdir)/lib${PN}.la || die "rm failed"
+ fi
+
+ if use doc; then
+ dohtml -r doc/{api/html/*,t38_manual}
+ fi
+}