summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-08-16 14:36:09 +0000
committerMike Frysinger <vapier@gentoo.org>2008-08-16 14:36:09 +0000
commitfd647e716478f3f02569815a87e3625c84462284 (patch)
treed186034357ccc9a354808162af9c3f86635458d7 /media-libs/svgalib
parentVersion bump, bug #217542 (diff)
downloadgentoo-2-fd647e716478f3f02569815a87e3625c84462284.tar.gz
gentoo-2-fd647e716478f3f02569815a87e3625c84462284.tar.bz2
gentoo-2-fd647e716478f3f02569815a87e3625c84462284.zip
Fix from Brett Mravec for building with linux-2.6.26 #232117 by Marco Leogrande.
(Portage version: 2.2_rc6/cvs/Linux 2.6.26.1 x86_64)
Diffstat (limited to 'media-libs/svgalib')
-rw-r--r--media-libs/svgalib/ChangeLog7
-rw-r--r--media-libs/svgalib/files/svgalib-1.9.25-linux2.6.patch30
2 files changed, 36 insertions, 1 deletions
diff --git a/media-libs/svgalib/ChangeLog b/media-libs/svgalib/ChangeLog
index f7aea65b1488..48d3420357b9 100644
--- a/media-libs/svgalib/ChangeLog
+++ b/media-libs/svgalib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/svgalib
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/svgalib/ChangeLog,v 1.78 2008/04/10 04:43:56 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/svgalib/ChangeLog,v 1.79 2008/08/16 14:36:08 vapier Exp $
+
+ 16 Aug 2008; Mike Frysinger <vapier@gentoo.org>
+ files/svgalib-1.9.25-linux2.6.patch:
+ Fix from Brett Mravec for building with linux-2.6.26 #232117 by Marco
+ Leogrande.
10 Apr 2008; Mike Frysinger <vapier@gentoo.org> svgalib-1.9.25.ebuild:
Drop MODULESD_SVGALIB_HELPER_ADDITIONS #214274.
diff --git a/media-libs/svgalib/files/svgalib-1.9.25-linux2.6.patch b/media-libs/svgalib/files/svgalib-1.9.25-linux2.6.patch
index ae3617da0f7c..8475d3ae0f89 100644
--- a/media-libs/svgalib/files/svgalib-1.9.25-linux2.6.patch
+++ b/media-libs/svgalib/files/svgalib-1.9.25-linux2.6.patch
@@ -82,6 +82,36 @@
}
#endif
+@@ -105,7 +109,8 @@
+ class_device_create(svgalib_helper_class, \
+ MKDEV(SVGALIB_HELPER_MAJOR, _minor), \
+ &sh_pci_devs[_minor]->dev->dev, _name);
+-#else /* 2.6.15 changed class_device_create */
++/* 2.6.15 changed class_device_create */
++#elif LINUX_VERSION_CODE < KERNEL_VERSION(2,6,26)
+ # define SLH_SYSFS_ADD_CONTROL \
+ class_device_create(svgalib_helper_class, NULL, \
+ MKDEV(SVGALIB_HELPER_MAJOR, 0), \
+@@ -115,7 +120,18 @@
+ class_device_create(svgalib_helper_class, NULL, \
+ MKDEV(SVGALIB_HELPER_MAJOR, _minor), \
+ &sh_pci_devs[_minor]->dev->dev, _name);
+-#endif /* 2.6.15 */
++/* 2.6.26 changed class_device_create to device_create */
++#else
++# define SLH_SYSFS_ADD_CONTROL \
++ device_create(svgalib_helper_class, NULL, \
++ MKDEV(SVGALIB_HELPER_MAJOR, 0), \
++ "svga");
++
++# define SLH_SYSFS_ADD_DEVICE(_name, _minor) \
++ device_create(svgalib_helper_class, &sh_pci_devs[_minor]->dev->dev, \
++ MKDEV(SVGALIB_HELPER_MAJOR, _minor), \
++ _name);
++#endif
+
+ # define SLH_SYSFS_REMOVE_DEVICE(i) \
+ class_destroy(svgalib_helper_class);
@@ -167,3 +167,7 @@
#ifndef PCI_VENDOR_ID_RENDITION
#define PCI_VENDOR_ID_RENDITION 0x1163