summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-10-16 06:22:49 +0000
committerMamoru Komachi <usata@gentoo.org>2004-10-16 06:22:49 +0000
commitaefaccb15921eaf8ac453796e53ee1a16e579c19 (patch)
tree150bd84d72c019570df669967bbbc63d400df734 /media-libs/t1lib/t1lib-5.0.0-r2.ebuild
parentAdded patch and keyword for ~ppc-macos (Manifest recommit) (diff)
downloadgentoo-2-aefaccb15921eaf8ac453796e53ee1a16e579c19.tar.gz
gentoo-2-aefaccb15921eaf8ac453796e53ee1a16e579c19.tar.bz2
gentoo-2-aefaccb15921eaf8ac453796e53ee1a16e579c19.zip
Simplified ebuilds with epatch.
Diffstat (limited to 'media-libs/t1lib/t1lib-5.0.0-r2.ebuild')
-rw-r--r--media-libs/t1lib/t1lib-5.0.0-r2.ebuild37
1 files changed, 9 insertions, 28 deletions
diff --git a/media-libs/t1lib/t1lib-5.0.0-r2.ebuild b/media-libs/t1lib/t1lib-5.0.0-r2.ebuild
index 911f3df1fb4d..73d0f388437c 100644
--- a/media-libs/t1lib/t1lib-5.0.0-r2.ebuild
+++ b/media-libs/t1lib/t1lib-5.0.0-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/t1lib/t1lib-5.0.0-r2.ebuild,v 1.13 2004/06/24 23:24:07 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/t1lib/t1lib-5.0.0-r2.ebuild,v 1.14 2004/10/16 06:22:49 usata Exp $
-inherit gnuconfig flag-o-matic
+inherit eutils gnuconfig flag-o-matic
DESCRIPTION="A Type 1 Font Rasterizer Library for UNIX/X11"
HOMEPAGE="ftp://metalab.unc.edu/pub/Linux/libs/graphics"
@@ -10,7 +10,7 @@ SRC_URI="ftp://sunsite.unc.edu/pub/Linux/libs/graphics/${P}.tar.gz"
LICENSE="LGPL-2 GPL-2"
SLOT="5"
-KEYWORDS="x86 ~ppc sparc alpha hppa ~amd64 ia64"
+KEYWORDS="x86 ppc sparc alpha hppa ~amd64 ia64"
IUSE="X doc"
DEPEND="X? ( virtual/x11 )"
@@ -20,6 +20,8 @@ src_unpack() {
if use amd64 || use alpha; then
gnuconfig_update || die "gnuconfig_update failed"
fi
+ cd ${S}
+ epatch ${FILESDIR}/t1lib-5.0.2-gentoo.diff
cd ${S}/doc
mv Makefile.in Makefile.in-orig
@@ -32,40 +34,19 @@ src_compile() {
use alpha && append-flags -mieee
- use X \
- && myconf="--with-x" \
- || myconf="--without-x"
-
if [ ! -x /usr/bin/latex ] ; then
myopt="without_doc"
+ else
+ addwrite /var/cache/fonts
fi
- echo `pwd`
- econf ${myconf} || die
+ econf ${myconf} --datadir=/etc $(use_with X x) || die
make ${myopt} || die
}
src_install() {
- cd lib
- insinto /usr/include
- doins t1lib.h
-
- use X && ( \
- doins t1libx.h
- ln -s -f libt1x.lai .libs/libt1x.la
- dolib .libs/libt1x.{la,a,so.${PV}}
- dosym libt1x.so.${PV} /usr/lib/libt1x.so.${PV%%.*}
- dosym libt1x.so.${PV} /usr/lib/libt1x.so
- )
-
- ln -s -f libt1.lai .libs/libt1.la
- dolib .libs/libt1.{la,a,so.${PV}}
- dosym libt1.so.${PV} /usr/lib/libt1.so.${PV%%.*}
- dosym libt1.so.${PV} /usr/lib/libt1.so
- insinto /etc/t1lib
- doins t1lib.config
+ make DESTDIR=${D} install || die
- cd ..
dodoc Changes LGPL LICENSE README*
if use doc ; then
cd doc