summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2003-10-06 17:25:53 +0000
committerAron Griffis <agriffis@gentoo.org>2003-10-06 17:25:53 +0000
commitfe9066ceb939a56db89b080fc24fa5cbdf5e6db6 (patch)
tree825a97ff0aa21b8cec2722b1e45854e52d4b07f5 /media-libs/t1lib/t1lib-5.0.0-r2.ebuild
parentver bump (diff)
downloadgentoo-2-fe9066ceb939a56db89b080fc24fa5cbdf5e6db6.tar.gz
gentoo-2-fe9066ceb939a56db89b080fc24fa5cbdf5e6db6.tar.bz2
gentoo-2-fe9066ceb939a56db89b080fc24fa5cbdf5e6db6.zip
Use -mieee on alpha
Diffstat (limited to 'media-libs/t1lib/t1lib-5.0.0-r2.ebuild')
-rw-r--r--media-libs/t1lib/t1lib-5.0.0-r2.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/media-libs/t1lib/t1lib-5.0.0-r2.ebuild b/media-libs/t1lib/t1lib-5.0.0-r2.ebuild
index 04afcd835b68..760ee98e6ac5 100644
--- a/media-libs/t1lib/t1lib-5.0.0-r2.ebuild
+++ b/media-libs/t1lib/t1lib-5.0.0-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/t1lib/t1lib-5.0.0-r2.ebuild,v 1.4 2003/09/24 16:39:26 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/t1lib/t1lib-5.0.0-r2.ebuild,v 1.5 2003/10/06 17:25:50 agriffis Exp $
-inherit gnuconfig
+inherit gnuconfig flag-o-matic
IUSE="X doc"
@@ -20,7 +20,9 @@ KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64"
src_unpack() {
unpack ${A}
- use amd64 && gnuconfig_update
+ if use amd64 || use alpha; then
+ gnuconfig_update || die "gnuconfig_update failed"
+ fi
cd ${S}/doc
mv Makefile.in Makefile.in-orig
@@ -33,6 +35,8 @@ src_compile() {
local myconf
local myopt
+ use alpha && append-flags -mieee
+
use X \
&& myconf="--with-x" \
|| myconf="--without-x"