summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-04-09 20:36:39 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-04-09 20:36:39 +0000
commitf08c50ee62eb7d912fcf27c3da0e617cfcf0f38d (patch)
tree2a00ea342aaa15e333b594e01dc64ccbc356d29b /media-libs/taglib
parentold (diff)
downloadgentoo-2-f08c50ee62eb7d912fcf27c3da0e617cfcf0f38d.tar.gz
gentoo-2-f08c50ee62eb7d912fcf27c3da0e617cfcf0f38d.tar.bz2
gentoo-2-f08c50ee62eb7d912fcf27c3da0e617cfcf0f38d.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/taglib')
-rw-r--r--media-libs/taglib/ChangeLog7
-rw-r--r--media-libs/taglib/taglib-1.6.2.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/media-libs/taglib/ChangeLog b/media-libs/taglib/ChangeLog
index 73eb20b66fc4..a07454832c20 100644
--- a/media-libs/taglib/ChangeLog
+++ b/media-libs/taglib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/taglib
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/taglib/ChangeLog,v 1.87 2010/04/04 18:22:23 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/taglib/ChangeLog,v 1.88 2010/04/09 20:36:39 ssuominen Exp $
+
+*taglib-1.6.2 (09 Apr 2010)
+
+ 09 Apr 2010; Samuli Suominen <ssuominen@gentoo.org> +taglib-1.6.2.ebuild:
+ Version bump.
04 Apr 2010; Raúl Porcel <armin76@gentoo.org> taglib-1.6.1-r1.ebuild:
alpha/arm/ia64/sh/sparc stable wrt #306099
diff --git a/media-libs/taglib/taglib-1.6.2.ebuild b/media-libs/taglib/taglib-1.6.2.ebuild
new file mode 100644
index 000000000000..136ecd257ab0
--- /dev/null
+++ b/media-libs/taglib/taglib-1.6.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/taglib/taglib-1.6.2.ebuild,v 1.1 2010/04/09 20:36:39 ssuominen Exp $
+
+EAPI=3
+inherit cmake-utils
+
+DESCRIPTION="A library for reading and editing audio meta data"
+HOMEPAGE="http://developer.kde.org/~wheeler/taglib.html"
+SRC_URI="http://developer.kde.org/~wheeler/files/src/${P}.tar.gz"
+
+LICENSE="LGPL-2 MPL-1.1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+SLOT="0"
+IUSE="+asf debug examples +mp4 test"
+
+RDEPEND=""
+DEPEND="dev-util/pkgconfig
+ test? ( dev-util/cppunit )"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.6.1-install-examples.patch )
+
+DOCS="AUTHORS NEWS"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_build examples)
+ $(cmake-utils_use_with asf)
+ $(cmake-utils_use_with mp4)
+ )
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ if ! use asf; then
+ elog "You've chosen to disable the asf use flag, thus taglib won't include"
+ elog "support for Microsoft's 'advanced systems format' media container"
+ fi
+ if ! use mp4; then
+ elog "You've chosen to disable the mp4 use flag, thus taglib won't include"
+ elog "support for the MPEG-4 part 14 / MP4 media container"
+ fi
+}