summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-10-10 20:40:39 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-10-10 20:40:39 +0000
commitc34eb2d219288ae5c3c3861927ff5879f25d83d9 (patch)
treecf1b91f14378d043980bb173ea4d624ca71eb8d2 /media-libs/tiff
parentold (diff)
downloadgentoo-2-c34eb2d219288ae5c3c3861927ff5879f25d83d9.tar.gz
gentoo-2-c34eb2d219288ae5c3c3861927ff5879f25d83d9.tar.bz2
gentoo-2-c34eb2d219288ae5c3c3861927ff5879f25d83d9.zip
Commit libtiff.so.3 and libtiffxx.so.3 ABI compat ebuild in SLOT="3" to replace media-libs/tiff-compat.
(Portage version: 2.2.0_alpha64/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/tiff')
-rw-r--r--media-libs/tiff/ChangeLog8
-rw-r--r--media-libs/tiff/tiff-3.9.5-r1.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/media-libs/tiff/ChangeLog b/media-libs/tiff/ChangeLog
index 14a4b007138c..19d172638151 100644
--- a/media-libs/tiff/ChangeLog
+++ b/media-libs/tiff/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/tiff
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/tiff/ChangeLog,v 1.175 2011/10/10 20:24:39 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/tiff/ChangeLog,v 1.176 2011/10/10 20:40:39 ssuominen Exp $
+
+*tiff-3.9.5-r1 (10 Oct 2011)
+
+ 10 Oct 2011; Samuli Suominen <ssuominen@gentoo.org> +tiff-3.9.5-r1.ebuild:
+ Commit libtiff.so.3 and libtiffxx.so.3 ABI compat ebuild in SLOT="3" to
+ replace media-libs/tiff-compat.
10 Oct 2011; Samuli Suominen <ssuominen@gentoo.org> -tiff-3.9.4-r1.ebuild,
-files/tiff-3.9.4-CVE-2011-0192.patch, -files/tiff-3.9.4-CVE-2011-1167.patch:
diff --git a/media-libs/tiff/tiff-3.9.5-r1.ebuild b/media-libs/tiff/tiff-3.9.5-r1.ebuild
new file mode 100644
index 000000000000..9af7fdf60efb
--- /dev/null
+++ b/media-libs/tiff/tiff-3.9.5-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/tiff/tiff-3.9.5-r1.ebuild,v 1.1 2011/10/10 20:40:39 ssuominen Exp $
+
+# this ebuild is only for the libtiff.so.3 and libtiffxx.so.3 SONAME for ABI compat
+
+EAPI=4
+inherit libtool multilib
+
+DESCRIPTION="Library for manipulation of TIFF (Tag Image File Format) images"
+HOMEPAGE="http://www.remotesensing.org/libtiff/"
+SRC_URI="ftp://ftp.remotesensing.org/pub/libtiff/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="+cxx jbig jpeg zlib"
+
+RDEPEND="jpeg? ( virtual/jpeg )
+ jbig? ( media-libs/jbigkit )
+ zlib? ( sys-libs/zlib )
+ !media-libs/tiff-compat
+ !=media-libs/tiff-3*:0"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_enable cxx) \
+ $(use_enable zlib) \
+ $(use_enable jpeg) \
+ $(use_enable jbig) \
+ --without-x
+}
+
+src_install() {
+ exeinto /usr/$(get_libdir)
+ doexe libtiff/.libs/libtiff$(get_libname 3)
+ use cxx && doexe libtiff/.libs/libtiffxx$(get_libname 3)
+}