summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2014-09-26 20:46:48 +0000
committerMatt Turner <mattst88@gentoo.org>2014-09-26 20:46:48 +0000
commit6c93fc8c9e339096209ac853e5fce3d84f1466ca (patch)
treeb69a9b6d03c608bb5ef931c36c768e846a4ef8dd /media-libs/waffle
parentclean up install (diff)
downloadgentoo-2-6c93fc8c9e339096209ac853e5fce3d84f1466ca.tar.gz
gentoo-2-6c93fc8c9e339096209ac853e5fce3d84f1466ca.tar.bz2
gentoo-2-6c93fc8c9e339096209ac853e5fce3d84f1466ca.zip
Version bump to 1.4.0.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 974CA72A)
Diffstat (limited to 'media-libs/waffle')
-rw-r--r--media-libs/waffle/ChangeLog7
-rw-r--r--media-libs/waffle/waffle-1.4.0.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/media-libs/waffle/ChangeLog b/media-libs/waffle/ChangeLog
index 1ff64873d738..eb098a4de6ca 100644
--- a/media-libs/waffle/ChangeLog
+++ b/media-libs/waffle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/waffle
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/waffle/ChangeLog,v 1.8 2014/07/26 09:08:29 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/waffle/ChangeLog,v 1.9 2014/09/26 20:46:48 mattst88 Exp $
+
+*waffle-1.4.0 (26 Sep 2014)
+
+ 26 Sep 2014; Matt Turner <mattst88@gentoo.org> +waffle-1.4.0.ebuild:
+ Version bump to 1.4.0.
26 Jul 2014; Samuli Suominen <ssuominen@gentoo.org> waffle-1.3.0-r1.ebuild,
waffle-1.3.0.ebuild, waffle-9999.ebuild:
diff --git a/media-libs/waffle/waffle-1.4.0.ebuild b/media-libs/waffle/waffle-1.4.0.ebuild
new file mode 100644
index 000000000000..7053ee4a5356
--- /dev/null
+++ b/media-libs/waffle/waffle-1.4.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/waffle/waffle-1.4.0.ebuild,v 1.1 2014/09/26 20:46:48 mattst88 Exp $
+
+EAPI=5
+
+EGIT_REPO_URI="git://github.com/waffle-gl/waffle.git"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-2"
+fi
+
+inherit cmake-utils cmake-multilib ${GIT_ECLASS}
+
+DESCRIPTION="Library that allows selection of GL API and of window system at runtime"
+HOMEPAGE="http://people.freedesktop.org/~chadversary/waffle/"
+
+if [[ $PV = 9999* ]]; then
+ KEYWORDS=""
+else
+ SRC_URI="http://people.freedesktop.org/~chadversary/waffle/files/release/${P}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="doc egl gbm test wayland"
+
+RDEPEND="
+ >=media-libs/mesa-9.1.6[egl?,gbm?,${MULTILIB_USEDEP}]
+ >=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}]
+ wayland? ( >=dev-libs/wayland-1.0.6[${MULTILIB_USEDEP}] )
+ gbm? ( >=virtual/libudev-208:=[${MULTILIB_USEDEP}] )
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libxcb-1.9.1[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ >=x11-proto/xcb-proto-1.8-r3[${MULTILIB_USEDEP}]
+ doc? (
+ dev-libs/libxslt
+ app-text/docbook-xml-dtd:4.2
+ )"
+
+src_unpack() {
+ default
+ [[ $PV = 9999* ]] && git-2_src_unpack
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -Dwaffle_has_glx=ON
+ -Dwaffle_build_examples=OFF
+ $(cmake-utils_use doc waffle_build_manpages)
+ $(cmake-utils_use egl waffle_has_x11_egl)
+ $(cmake-utils_use gbm waffle_has_gbm)
+ $(cmake-utils_use test waffle_build_tests)
+ $(cmake-utils_use wayland waffle_has_wayland)
+ )
+
+ cmake-multilib_src_configure
+}
+
+src_test() {
+ emake -C "${CMAKE_BUILD_DIR}" check
+}