summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2009-11-26 03:50:14 +0000
committerSteve Dibb <beandog@gentoo.org>2009-11-26 03:50:14 +0000
commit9f84475e21d276d6124940686820f22fc613cf8c (patch)
tree245e44f0ecbf4f805e6333effc9017c0cd8f703e /media-libs/x264
parentAdd x264-encoder with x264 (diff)
downloadgentoo-2-9f84475e21d276d6124940686820f22fc613cf8c.tar.gz
gentoo-2-9f84475e21d276d6124940686820f22fc613cf8c.tar.bz2
gentoo-2-9f84475e21d276d6124940686820f22fc613cf8c.zip
Snapshot bump
(Portage version: 2.2_rc42/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/x264')
-rw-r--r--media-libs/x264/ChangeLog7
-rw-r--r--media-libs/x264/x264-0.0.20091124.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/media-libs/x264/ChangeLog b/media-libs/x264/ChangeLog
index 673a28c0d3db..e383392f2708 100644
--- a/media-libs/x264/ChangeLog
+++ b/media-libs/x264/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/x264
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/ChangeLog,v 1.25 2009/10/22 14:56:34 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/ChangeLog,v 1.26 2009/11/26 03:50:14 beandog Exp $
+
+*x264-0.0.20091124 (26 Nov 2009)
+
+ 26 Nov 2009; Steve Dibb <beandog@gentoo.org> +x264-0.0.20091124.ebuild:
+ Snapshot bump
*x264-0.0.20091021 (22 Oct 2009)
diff --git a/media-libs/x264/x264-0.0.20091124.ebuild b/media-libs/x264/x264-0.0.20091124.ebuild
new file mode 100644
index 000000000000..14361f629759
--- /dev/null
+++ b/media-libs/x264/x264-0.0.20091124.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/x264-0.0.20091124.ebuild,v 1.1 2009/11/26 03:50:14 beandog Exp $
+
+EAPI=2
+inherit eutils multilib toolchain-funcs versionator
+
+MY_P=x264-snapshot-$(get_version_component_range 3)-2245
+
+DESCRIPTION="A free library for encoding X264/AVC streams"
+HOMEPAGE="http://www.videolan.org/developers/x264.html"
+SRC_URI="ftp://ftp.videolan.org/pub/videolan/x264/snapshots/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug +threads pic"
+
+RDEPEND=""
+DEPEND="amd64? ( >=dev-lang/yasm-0.6.2 )
+ x86? ( >=dev-lang/yasm-0.6.2 )
+ x86-fbsd? ( >=dev-lang/yasm-0.6.2 )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-nostrip.patch \
+ "${FILESDIR}"/${PN}-onlylib-20090408.patch
+}
+
+src_configure() {
+ tc-export CC
+
+ local myconf=""
+ use debug && myconf="${myconf} --enable-debug"
+
+ if use x86 && use pic; then
+ myconf="${myconf} --disable-asm"
+ fi
+
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/$(get_libdir) \
+ --disable-avis-input \
+ --disable-mp4-output \
+ $(use_enable threads pthread) \
+ --enable-pic \
+ --enable-shared \
+ --extra-asflags="${ASFLAGS}" \
+ --extra-cflags="${CFLAGS}" \
+ --extra-ldflags="${LDFLAGS}" \
+ --host="${CHOST}" \
+ ${myconf} \
+ || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS doc/*.txt
+}