summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-05-03 20:08:47 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-05-03 20:08:47 +0000
commitcf89c3dba4fa8ba985f36033ae00dd5b006c1d46 (patch)
treec56aee9372e47049971c392022cbec291aec7035 /media-libs/x264
parentNew ebuild for bug 233738. (diff)
downloadgentoo-2-cf89c3dba4fa8ba985f36033ae00dd5b006c1d46.tar.gz
gentoo-2-cf89c3dba4fa8ba985f36033ae00dd5b006c1d46.tar.bz2
gentoo-2-cf89c3dba4fa8ba985f36033ae00dd5b006c1d46.zip
bump a new snapshot
(Portage version: 2.2_rc32/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/x264')
-rw-r--r--media-libs/x264/ChangeLog10
-rw-r--r--media-libs/x264/files/x264-onlylib-20090408.patch28
-rw-r--r--media-libs/x264/x264-0.0.20090502.ebuild58
3 files changed, 94 insertions, 2 deletions
diff --git a/media-libs/x264/ChangeLog b/media-libs/x264/ChangeLog
index 27397d8ae1c7..bc3c3688ee67 100644
--- a/media-libs/x264/ChangeLog
+++ b/media-libs/x264/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/x264
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/ChangeLog,v 1.19 2008/12/20 22:47:24 fmccor Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/ChangeLog,v 1.20 2009/05/03 20:08:47 aballier Exp $
+
+*x264-0.0.20090502 (03 May 2009)
+
+ 03 May 2009; Alexis Ballier <aballier@gentoo.org>
+ +x264-0.0.20090502.ebuild, +files/x264-onlylib-20090408.patch:
+ bump a new snapshot
20 Dec 2008; Ferris McCormick <fmccor@gentoo.org>
x264-0.0.20081006.ebuild:
diff --git a/media-libs/x264/files/x264-onlylib-20090408.patch b/media-libs/x264/files/x264-onlylib-20090408.patch
new file mode 100644
index 000000000000..19b5fb4d85cd
--- /dev/null
+++ b/media-libs/x264/files/x264-onlylib-20090408.patch
@@ -0,0 +1,28 @@
+Index: x264-snapshot-20090408-2245/Makefile
+===================================================================
+--- x264-snapshot-20090408-2245.orig/Makefile
++++ x264-snapshot-20090408-2245/Makefile
+@@ -71,7 +71,7 @@ DEP = depend
+
+ .PHONY: all default fprofiled clean distclean install uninstall dox test testclean
+
+-default: $(DEP) x264$(EXE)
++default: $(DEP)
+
+ libx264.a: .depend $(OBJS) $(OBJASM)
+ $(AR) rc libx264.a $(OBJS) $(OBJASM)
+@@ -143,13 +143,12 @@ distclean: clean
+ rm -f config.mak config.h x264.pc
+ rm -rf test/
+
+-install: x264$(EXE) $(SONAME)
++install: libx264.a $(SONAME)
+ install -d $(DESTDIR)$(bindir) $(DESTDIR)$(includedir)
+ install -d $(DESTDIR)$(libdir) $(DESTDIR)$(libdir)/pkgconfig
+ install -m 644 x264.h $(DESTDIR)$(includedir)
+ install -m 644 libx264.a $(DESTDIR)$(libdir)
+ install -m 644 x264.pc $(DESTDIR)$(libdir)/pkgconfig
+- install x264$(EXE) $(DESTDIR)$(bindir)
+ $(RANLIB) $(DESTDIR)$(libdir)/libx264.a
+ ifeq ($(SYS),MINGW)
+ $(if $(SONAME), install -m 755 $(SONAME) $(DESTDIR)$(bindir))
diff --git a/media-libs/x264/x264-0.0.20090502.ebuild b/media-libs/x264/x264-0.0.20090502.ebuild
new file mode 100644
index 000000000000..43dde69be86b
--- /dev/null
+++ b/media-libs/x264/x264-0.0.20090502.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/x264-0.0.20090502.ebuild,v 1.1 2009/05/03 20:08:47 aballier Exp $
+
+EAPI="1"
+inherit multilib eutils toolchain-funcs versionator
+
+MY_P="x264-snapshot-$(get_version_component_range 3)-2245"
+
+DESCRIPTION="A free library for encoding X264/AVC streams"
+HOMEPAGE="http://www.videolan.org/developers/x264.html"
+SRC_URI="ftp://ftp.videolan.org/pub/videolan/x264/snapshots/${MY_P}.tar.bz2"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug +threads"
+
+RDEPEND=""
+DEPEND="amd64? ( >=dev-lang/yasm-0.6.2 )
+ x86? ( >=dev-lang/yasm-0.6.2 )
+ x86-fbsd? ( >=dev-lang/yasm-0.6.2 )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-nostrip.patch"
+ epatch "${FILESDIR}/${PN}-onlylib-20090408.patch"
+}
+
+src_compile() {
+ local myconf=""
+ use debug && myconf="${myconf} --enable-debug"
+ ./configure --prefix=/usr \
+ --libdir=/usr/$(get_libdir) \
+ --enable-pic --enable-shared \
+ "--extra-cflags=${CFLAGS}" \
+ "--extra-ldflags=${LDFLAGS}" \
+ "--extra-asflags=${ASFLAGS}" \
+ "--host=${CHOST}" \
+ $(use_enable threads pthread) \
+ ${myconf} \
+ --disable-mp4-output \
+ || die "configure failed"
+ emake CC="$(tc-getCC)" || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS doc/*.txt
+}
+
+pkg_postinst() {
+ elog "Please note that this package now only installs"
+ elog "${PN} libraries. In order to have the encoder,"
+ elog "please emerge media-video/x264-encoder."
+}