summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-05-07 22:34:50 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-05-07 22:34:50 +0000
commitc562c28b7f73779a1dd88d1b4dc96fb09fe866cd (patch)
treeeb35fba030fe47f378a426b258768ae650e2aaa7 /media-libs/xvid/xvid-1.3.2-r1.ebuild
parentRemove old. (diff)
downloadgentoo-2-c562c28b7f73779a1dd88d1b4dc96fb09fe866cd.tar.gz
gentoo-2-c562c28b7f73779a1dd88d1b4dc96fb09fe866cd.tar.bz2
gentoo-2-c562c28b7f73779a1dd88d1b4dc96fb09fe866cd.zip
Remove old.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'media-libs/xvid/xvid-1.3.2-r1.ebuild')
-rw-r--r--media-libs/xvid/xvid-1.3.2-r1.ebuild73
1 files changed, 0 insertions, 73 deletions
diff --git a/media-libs/xvid/xvid-1.3.2-r1.ebuild b/media-libs/xvid/xvid-1.3.2-r1.ebuild
deleted file mode 100644
index 9c88cd6c0410..000000000000
--- a/media-libs/xvid/xvid-1.3.2-r1.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xvid/xvid-1.3.2-r1.ebuild,v 1.4 2014/07/31 14:34:57 klausman Exp $
-
-EAPI=5
-inherit flag-o-matic multilib multilib-minimal
-
-MY_PN=${PN}core
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="XviD, a high performance/quality MPEG-4 video de-/encoding solution"
-HOMEPAGE="http://www.xvid.org/"
-SRC_URI="http://downloads.xvid.org/downloads/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
-IUSE="examples elibc_FreeBSD +threads pic"
-
-NASM=">=dev-lang/nasm-2"
-YASM=">=dev-lang/yasm-1"
-
-DEPEND="amd64? ( || ( ${YASM} ${NASM} ) )
- amd64-fbsd? ( ${NASM} )
- x86? ( || ( ${YASM} ${NASM} ) )
- x86-fbsd? ( ${NASM} )"
-RDEPEND="abi_x86_32? ( !app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)] )"
-
-S=${WORKDIR}/${MY_PN}/build/generic
-
-src_prepare() {
- # make build verbose
- sed \
- -e 's/@$(CC)/$(CC)/' \
- -e 's/@$(AS)/$(AS)/' \
- -e 's/@$(RM)/$(RM)/' \
- -e 's/@$(INSTALL)/$(INSTALL)/' \
- -e 's/@cd/cd/' \
- -i Makefile || die
- # Since only the build system is in $S, this will only copy it but not the
- # entire sources.
- multilib_copy_sources
-}
-
-multilib_src_configure() {
- use sparc && append-cflags -mno-vis #357149
- use elibc_FreeBSD && export ac_cv_prog_ac_yasm=no #477736
-
- local myconf
- if use pic || [[ ${ABI} == "x32" ]] ; then #421841
- myconf="--disable-assembly"
- fi
-
- econf ${myconf} \
- $(use_enable threads pthread)
-}
-
-multilib_src_install() {
- emake DESTDIR="${D}" install
-
- local mylib=$(basename $(ls "${D}"/usr/$(get_libdir)/libxvidcore.so*))
- dosym ${mylib} /usr/$(get_libdir)/libxvidcore.so
- dosym ${mylib} /usr/$(get_libdir)/${mylib%.?}
-}
-
-multilib_src_install_all() {
- dodoc "${S}"/../../{AUTHORS,ChangeLog*,CodingStyle,README,TODO}
-
- if use examples; then
- insinto /usr/share/${PN}
- doins -r "${S}"/../../examples
- fi
-}